- migrate to apache 2.4 auto/th/collectd-5.1.0-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 15 May 2013 16:27:50 +0000 (18:27 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 15 May 2013 16:27:50 +0000 (18:27 +0200)
- rel 3

collectd-apache.conf [new file with mode: 0644]
collectd-http.conf
collectd.spec

diff --git a/collectd-apache.conf b/collectd-apache.conf
new file mode 100644 (file)
index 0000000..2b79bab
--- /dev/null
@@ -0,0 +1,19 @@
+# $Id$
+
+Alias /collectd /usr/share/collectd
+ScriptAlias /collection /usr/share/collectd/cgi-bin/collection.cgi
+
+<Directory /usr/share/collectd/cgi-bin>
+       Options ExecCGI
+       AddHandler cgi-script .cgi
+
+       AllowOverride AuthConfig Limit
+
+       Order allow,deny
+       Allow from all
+
+       <IfModule mod_expires.c>
+               ExpiresActive On
+               ExpiresByType image/png M5
+       </IfModule>
+</Directory>
index 2b79bab6bbaf34f09ea6b81e6eab1175522a287e..77d4c4faaa89d079f32f3e61f1fd888e64a2eafd 100644 (file)
@@ -1,5 +1,3 @@
-# $Id$
-
 Alias /collectd /usr/share/collectd
 ScriptAlias /collection /usr/share/collectd/cgi-bin/collection.cgi
 
@@ -9,8 +7,7 @@ ScriptAlias /collection /usr/share/collectd/cgi-bin/collection.cgi
 
        AllowOverride AuthConfig Limit
 
-       Order allow,deny
-       Allow from all
+       Require all granted
 
        <IfModule mod_expires.c>
                ExpiresActive On
index 026c0490c4eccd9f2c650a1158b4bc43945973b1..0eadc0f68e870babb2ebdbfa790df34094a6c55b 100644 (file)
@@ -68,7 +68,7 @@ Summary:      Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
 Version:       5.1.0
-Release:       2
+Release:       3
 License:       GPL v2
 Group:         Daemons
 Source0:       http://collectd.org/files/%{name}-%{version}.tar.bz2
@@ -77,6 +77,7 @@ Source1:      %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
 Source4:       %{name}-lighttpd.conf
+Source5:       %{name}-apache.conf
 Source10:      %{name}-df.conf
 Source11:      %{name}-rrdtool.conf
 Patch0:                %{name}-collection.patch
@@ -262,6 +263,7 @@ Requires:   perl(RRDs)
 Requires:      perl(URI::Escape)
 Requires:      webserver(cgi)
 Suggests:      fonts-TTF-DejaVu
+Conflicts:     apache-base < 2.4.0-1
 
 %description collection
 Web script for collectd.
@@ -278,6 +280,7 @@ Requires:   perl(Regexp::Common)
 Requires:      perl(RRDs)
 Requires:      webserver(cgi)
 Suggests:      fonts-TTF-DejaVu
+Conflicts:     apache-base < 2.4.0-1
 
 %description collection3
 Web script for collectd.
@@ -1329,7 +1332,7 @@ install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 # Web frontend:
 install contrib/collection.conf $RPM_BUILD_ROOT%{_webappdir}
 install contrib/collection.cgi $RPM_BUILD_ROOT%{_appdir}/cgi-bin
-install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
+install %{SOURCE5} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
 install %{SOURCE4} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
 
@@ -1478,10 +1481,10 @@ fi
 %triggerun collection -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin collection -- apache < 2.2.0, apache-base
+%triggerin collection -- apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun collection -- apache < 2.2.0, apache-base
+%triggerun collection -- apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerin collection -- lighttpd
This page took 0.05942 seconds and 4 git commands to generate.