]> git.pld-linux.org Git - packages/collectd.git/blobdiff - collectd.spec
- own directories
[packages/collectd.git] / collectd.spec
index 426e5152d348f2940eb9e00ff6a28465d8f304af..e7e6a125776165f35d5df25bc90aeff64837c717 100644 (file)
@@ -5,7 +5,7 @@
 # - Current plugins status:
 #    apache  . . . . . . yes
 #    apcups  . . . . . . yes
-#    apple_sensors . . . no
+#    apple_sensors . . . no            (obvious)
 #    ascent  . . . . . . yes
 #    battery . . . . . . yes
 #    cpu . . . . . . . . yes
 #    hddtemp . . . . . . yes
 #    interface . . . . . yes
 #    iptables  . . . . . yes
-#    ipmi  . . . . . . . no
-#    ipvs  . . . . . . . no (ip_vs.h not found)
+#    ipmi  . . . . . . . yes
+#    ipvs  . . . . . . . no            (ip_vs.h not found - llh to be fixed)
 #    irq . . . . . . . . yes
-#    libvirt . . . . . . no
+#    libvirt . . . . . . no            (requires library)
 #    load  . . . . . . . yes
 #    logfile . . . . . . yes
 #    mbmon . . . . . . . yes
 #    memcached . . . . . yes
 #    memory  . . . . . . yes
-#    multimeter  . . . . yes
+#    multimeter  . . . . no
 #    mysql . . . . . . . yes
 #    netlink . . . . . . yes
 #    network . . . . . . yes
 #    nfs . . . . . . . . yes
 #    nginx . . . . . . . yes
 #    ntpd  . . . . . . . yes
-#    nut . . . . . . . . no
-#    perl  . . . . . . . no (needs libperl)
+#    nut . . . . . . . . yes
+#    perl  . . . . . . . no            (needs libperl)
 #    ping  . . . . . . . yes
 #    powerdns  . . . . . yes
 #    processes . . . . . yes
@@ -48,7 +48,7 @@
 #    swap  . . . . . . . yes
 #    syslog  . . . . . . yes
 #    tail  . . . . . . . yes
-#    tape  . . . . . . . no
+#    tape  . . . . . . . no            ?
 #    tcpconns  . . . . . yes
 #    teamspeak2  . . . . yes
 #    unixsock  . . . . . yes
 #    vserver . . . . . . yes
 #    wireless  . . . . . yes
 #    xmms  . . . . . . . yes
-%bcond_without dns
-%bcond_without iptables
-%bcond_without netlink
-
+#
+# Conditional build:
+%bcond_without dns             # ???
+%bcond_without ipmi            # ipmi plugin package
+%bcond_without iptables        # iptables plugin
+%bcond_with    multimeter      # multimeter plugin
+%bcond_without netlink         # netlink plugin
+#
 #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358637
 %ifarch %{x8664}
 %undefine with_iptables
 Summary:       Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
-Version:       4.4.2
-Release:       2
+Version:       4.5.0
+Release:       4
 License:       GPL v2
 Group:         Daemons
 Source0:       http://collectd.org/files/%{name}-%{version}.tar.gz
-# Source0-md5: dbffe35a2d19840e86253c7052485ff0
+# Source0-md5: f73dbadc8dca136b98c0f96567e0f78c
 Source1:       %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
@@ -84,14 +88,17 @@ BuildRequires:      OpenIPMI-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: curl-devel
-BuildRequires: iptables-devel
+BuildRequires: iptables-devel >= 1.4.1.1-4
+BuildRequires: libesmtp-devel
 BuildRequires: libnetlink-devel
+BuildRequires: libnotify-devel
 BuildRequires: liboping-devel
 BuildRequires: libpcap-devel
 BuildRequires: libstatgrab-devel >= 0.12
 BuildRequires: libtool
 BuildRequires: lm_sensors-devel
 BuildRequires: mysql-devel
+BuildRequires: nut-devel
 BuildRequires: perl-devel
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: rrdtool-devel
@@ -178,6 +185,18 @@ Requires:  %{name} = %{version}-%{release}
 %description hddtemp
 hddtemp plugin for collectd.
 
+%package ipmi
+Summary:       ipmi-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka ipmi dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description ipmi
+ipmi plugin for collectd.
+
+%description ipmi -l pl.UTF-8
+Wtyczka ipmi dla collectd.
+
 %package mysql
 Summary:       mysql-plugin for collectd
 Summary(pl_PL.UTF-8):  ModuĊ‚ mysql dla collectd.
@@ -201,6 +220,15 @@ Requires:  %{name} = %{version}-%{release}
 %description nginx
 nginx plugin for collectd.
 
+%package notify_desktop
+Summary:       notify_desktop for collectd
+Summary(pl_PL.UTF-8):  Wtyczka notify_desktop dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description notify_desktop
+notify_desktop plugin for collectd.
+
 %package ping
 Summary:       ping-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka ping dla collectd
@@ -285,12 +313,17 @@ EOF
        --with-libstatgrab=/usr \
        --with-lm-sensors=/usr \
        --with-libmysql=/usr \
-       --%{?with_dns:en}%{?!with_dns:dis}able-dns \
-       --%{?with_iptables:en}%{?!with_iptables:dis}able-iptables \
-       --%{?with_netlink:en}%{?!with_netlink:dis}able-netlink
+       --%{?with_ipmi:en}%{!?with_ipmi:dis}able-ipmi \
+       --%{?with_multimeter:en}%{!?with_multimeter:dis}able-multimeter \
+       --%{?with_dns:en}%{!?with_dns:dis}able-dns \
+       --%{?with_iptables:en}%{!?with_iptables:dis}able-iptables \
+       --%{?with_netlink:en}%{!?with_netlink:dis}able-netlink \
+       --disable-ipvs
 
 
-%{__make} LDFLAGS="%{rpmldflags} -lstatgrab"
+%{__make} LDFLAGS="%{rpmldflags} -lstatgrab" \
+       BUILD_WITH_OPENIPMI_CFLAGS="-I/usr/include" \
+       BUILD_WITH_OPENIPMI_LIBS="-L/usr/lib64 -lOpenIPMIutils -lOpenIPMIpthread"
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -358,24 +391,33 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/email.so
 %attr(755,root,root) %{_libdir}/%{name}/entropy.so
 %attr(755,root,root) %{_libdir}/%{name}/exec.so
+%attr(755,root,root) %{_libdir}/%{name}/filecount.so
 %attr(755,root,root) %{_libdir}/%{name}/interface.so
 %if %{with iptables}
 %attr(755,root,root) %{_libdir}/%{name}/iptables.so
 %endif
+# Disabled - requires fixed libc-headers or whole kernel source.
+# It was marked as disabled in status message on top.
+#%attr(755,root,root) %{_libdir}/%{name}/ipvs.so
 %attr(755,root,root) %{_libdir}/%{name}/irq.so
 %attr(755,root,root) %{_libdir}/%{name}/load.so
 %attr(755,root,root) %{_libdir}/%{name}/logfile.so
 %attr(755,root,root) %{_libdir}/%{name}/mbmon.so
+%attr(755,root,root) %{_libdir}/%{name}/notify_email.so
 %attr(755,root,root) %{_libdir}/%{name}/memcached.so
 %attr(755,root,root) %{_libdir}/%{name}/memory.so
+%if %{with multimeter}
 %attr(755,root,root) %{_libdir}/%{name}/multimeter.so
+%endif
 %if %{with netlink}
 %attr(755,root,root) %{_libdir}/%{name}/netlink.so
 %endif
 %attr(755,root,root) %{_libdir}/%{name}/network.so
+%attr(755,root,root) %{_libdir}/%{name}/nut.so
 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
 %attr(755,root,root) %{_libdir}/%{name}/ntpd.so
 #%attr(755,root,root) %{_libdir}/%{name}/perl.so
+%attr(755,root,root) %{_libdir}/%{name}/postgresql.so
 %attr(755,root,root) %{_libdir}/%{name}/processes.so
 %attr(755,root,root) %{_libdir}/%{name}/serial.so
 %attr(755,root,root) %{_libdir}/%{name}/swap.so
@@ -384,6 +426,7 @@ fi
 #%attr(755,root,root) %{_libdir}/%{name}/tape.so
 %attr(755,root,root) %{_libdir}/%{name}/teamspeak2.so
 %attr(755,root,root) %{_libdir}/%{name}/tcpconns.so
+%attr(755,root,root) %{_libdir}/%{name}/thermal.so
 #%attr(755,root,root) %{_libdir}/%{name}/traffic.so
 %attr(755,root,root) %{_libdir}/%{name}/unixsock.so
 %attr(755,root,root) %{_libdir}/%{name}/users.so
@@ -420,9 +463,11 @@ fi
 
 %files collection
 %defattr(644,root,root,755)
+%dir %{_webappdir}
 %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/collection.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
+%dir %{_appdir}/cgi-bin
 %attr(755,root,root) %{_appdir}/cgi-bin/collection.cgi
 
 %files dns
@@ -433,6 +478,12 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/hddtemp.so
 
+%if %{with ipmi}
+%files ipmi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/ipmi.so
+%endif
+
 %files mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
@@ -441,6 +492,10 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/nginx.so
 
+%files notify_desktop
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/notify_desktop.so
+
 %files ping
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/ping.so
This page took 0.087753 seconds and 4 git commands to generate.