]> git.pld-linux.org Git - packages/collectd.git/blobdiff - collectd.spec
- BR: libmemcached-devel, libnetlink-devel, ncurses-devel, pkgconfig,
[packages/collectd.git] / collectd.spec
index 34bd6a262e3661f5aefd4d6a9243a9cba573103d..e6eeefc489ce7835991f0abf09ba5d7dd27946e2 100644 (file)
@@ -1,3 +1,46 @@
+# TODO:
+# - package contrib scripts as %doc
+# - perl modules with Collectd classes package to separate package
+# - Bundled libraries - check if its not changed ones and if it can be
+#   mainstream library:
+# liboconfig  . . . . . yes (shipped version)
+# - Libraries not found by configure:
+#   libganglia  . . . . . no (gm_protocol.h not found)
+#   libiokit  . . . . . . no
+#   libjvm  . . . . . . . no (javac not found)
+#   libkstat  . . . . . . no (Solaris only)
+#   libkvm  . . . . . . . no
+#   libmemcached  . . . . no (libmemcached/memcached.h not found)
+#   libnetapp . . . . . . no (netapp_api.h not found)
+#   libperl . . . . . . . no
+#   librouteros . . . . . no ('routeros_api.h' not found)
+#   libtokyotyrant  . . . no (tcrdb.h not found)
+#   libvirt . . . . . . . no (pkg-config doesn't know library)
+#   libyajl . . . . . . . no (yajl/yajl_parse.h not found)
+#   oracle  . . . . . . . no (ORACLE_HOME is not set)
+# - Disabled modules:
+#   apple_sensors . . . no             (obvious)
+#   ipvs  . . . . . . . no             (ip_vs.h not found - llh to be fixed)
+#   libvirt . . . . . . no             (requires library)
+#   multimeter  . . . . no             ?
+#   onewire . . . . . . no             (needs libowfs)
+#   perl  . . . . . . . no             (buggy perl: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=467072)
+#   rrdcached . . . . . no             (requires rrdtool >= 1.4.0)
+#   tape  . . . . . . . no             ?
+#   curl_json . . . . . . no
+#   gmond . . . . . . . . no
+#   java  . . . . . . . . no
+#   memcachec . . . . . . no
+#   netapp  . . . . . . . no
+#   oracle  . . . . . . . no
+#   routeros  . . . . . . no
+#   rrdcached . . . . . . no
+#   tokyotyrant . . . . . no
+#   zfs_arc . . . . . . . no
+# - logrotate file for logfile plugin
+# - %desc -l pl for plugins
+# - package SpamAssassin plugin from contrib
+
 # Conditional build:
 %bcond_without curl            # apache, ascent, bind, curl and nginx plugins
 %bcond_without dns             # DNS plugin
@@ -9,7 +52,7 @@
 %bcond_without netlink         # netlink plugin
 %bcond_without notify          # notify_desktop plugin
 %bcond_without ping            # ping plugin
-%bcond_without psql            # PostgreSQL plugin
+%bcond_without pgsql           # PostgreSQL plugin
 %bcond_without rrd             # rrdtool and rrdcached plugins
 %bcond_without sensors         # sensors plugin
 %bcond_without snmp            # SNMP plugin
 Summary:       Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
-Version:       4.7.1
-Release:       1.1
+Version:       4.9.1
+Release:       0.9
 License:       GPL v2
 Group:         Daemons
 Source0:       http://collectd.org/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 20e95914219a32bfd51d01333dbb7c01
+# Source0-md5: 5753496651c8c84afaea1fe290876bfc
 Source1:       %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
@@ -39,7 +82,6 @@ Source4:      %{name}-lighttpd.conf
 Source10:      %{name}-df.conf
 Source11:      %{name}-rrdtool.conf
 Patch0:                %{name}-collection.patch
-Patch1:                %{name}-as_needed.patch
 URL:           http://collectd.org/
 %{?with_ipmi:BuildRequires:    OpenIPMI-devel >= 2.0.14-3}
 BuildRequires: autoconf
@@ -50,6 +92,8 @@ BuildRequires:        hal-devel
 BuildRequires: libdbi-devel
 %{?with_libesmtp:BuildRequires:        libesmtp-devel}
 BuildRequires: libltdl-devel
+BuildRequires: libmemcached-devel
+BuildRequires: libnetlink-devel
 %{?with_netlink:BuildRequires: libnetlink-devel}
 %{?with_notify:BuildRequires:  libnotify-devel}
 %{?with_ping:BuildRequires:    liboping-devel}
@@ -60,12 +104,18 @@ BuildRequires:     libtool
 %{?with_xml:BuildRequires:     libxml2-devel}
 %{?with_sensors:BuildRequires: lm_sensors-devel}
 %{?with_mysql:BuildRequires:   mysql-devel}
+BuildRequires: ncurses-devel
 %{?with_snmp:BuildRequires:    net-snmp-devel}
 %{?with_ups:BuildRequires:     nut-devel}
 BuildRequires: perl-devel
-%{?with_psql:BuildRequires:    postgresql-devel}
+BuildRequires: pkgconfig
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+BuildRequires: python-devel
+BuildRequires: python-modules
 BuildRequires: rpmbuild(macros) >= 1.268
 %{?with_rrd:BuildRequires:     rrdtool-devel}
+BuildRequires: which
+#BuildRequires:        xfsprogs-devel
 %{?with_xmms:BuildRequires:    xmms-devel}
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
@@ -153,7 +203,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description apcups
-APC UPS plugin for collectd.
+The APC UPS plugin connects to an instance of Apcupsd to read various
+statistics about a connected uninterruptible power supply (UPS), such as
+voltage, load, etc.
 
 %package ascent
 Summary:       ascent-plugin for collectd
@@ -162,7 +214,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description ascent
-ascent plugin for collectd.
+The Ascent plugin reads and parses the statistics page of Ascent, a free and
+open-source server software for the game World of Warcraft by Blizzard
+Entertainment.
 
 %package battery
 Summary:       battery plugin for collectd
@@ -217,6 +271,16 @@ Suggests:  fonts-TTF-DejaVu
 %description collection3
 Web script for collectd.
 
+%package contextswitch
+Summary:       contextswitch-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka contextswitch dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description contextswitch
+The ContextSwitch plugin collects the number of context switches
+done by the operating system.
+
 %package conntrack
 Summary:       conntrack-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka conntrack dla collectd
@@ -336,7 +400,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description entropy
-entropy plugin for collectd.
+The Entropy plugin collects the available entropy on a system. Entropy is
+important to generate random numbers, which are used for encryption,
+authorization and similar tasks.
 
 %package exec
 Summary:       exec-plugin for collectd
@@ -416,10 +482,10 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description ipmi
-ipmi plugin for collectd.
-
-%description ipmi -l pl.UTF-8
-Wtyczka ipmi dla collectd.
+The IPMI plugin uses the OpenIPMI library to read hardware sensors from
+servers using the Intelligent Platform Management Interface (IPMI). IPMI
+is very common with server hardware but usually not available in consumer
+hardware.
 
 %package irq
 Summary:       IRQs-plugin for collectd
@@ -428,7 +494,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description irq
-IRQs plugin for collectd.
+The IRQ plugin collects the number of times each interrupt has been handled
+by the operating system.
 
 %package load
 Summary:       load-plugin for collectd
@@ -447,7 +514,41 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description logfile
-Logfile plugin for collectd.
+The LogFile plugin receives log messages from the daemon and writes them to
+a text file.
+
+%package madwifi
+Summary:       madwifi plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka madwifi dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description madwifi
+The MadWifi plugin collects information about Atheros wireless LAN chipsets
+from the MadWifi driver. It uses the /sys filesystem to identify cards
+handled by this driver automatically but can be configured manually, too.
+Because very many statistics are available, an advanced selection mechanism
+is provided.
+
+%package match_empty_counter
+Summary:       match_empty_counter plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka match_empty_counter dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description match_empty_counter
+Empty Counter match matches value lists, where at least one data source is
+of type COUNTER and the counter value of all counter data sources is zero.
+
+%package match_hashed
+Summary:       match_hashed plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka match_hashed dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description match_hashed
+match_hashed plugin for collectd - match for simple load balancing and
+redundant storage.
 
 %package match_regex
 Summary:       match_regex plugin for collectd
@@ -513,7 +614,11 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description multimeter
-Multimeter plugin for collectd.
+The Multimeter plugin reads a value (usually a voltage or current) from a
+multimeter connected to a serial bus. The plugin tries /dev/ttyS0-9 in order
+to find a multimeter – no configuration is possible.
+
+The multimeter used for development was a Metex M-4650CR.
 
 %package mysql
 Summary:       mysql-plugin for collectd
@@ -550,7 +655,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description network
-nginx plugin for collectd.
+The Network plugin can send values to other instances and receive values
+from other %{name} instances.
 
 %package nfs
 Summary:       NFS-plugin for collectd
@@ -592,7 +698,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description notify_email
-notify_email plugin for collectd.
+The Notify Email plugin uses libESMTP to send notifications to a configured
+email address(es).
 
 %package ntpd
 Summary:       ntpd-plugin for collectd
@@ -601,7 +708,10 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description ntpd
-NTPd plugin for collectd.
+The NTPd plugin queries an NTP server (usually the local one, where
+statistics access is allowed) and extracts :
+- "local" clock parameters: time offset, error and offset loop,
+- parameters for each NTP server used to sync time: offset, dispersion, delay.
 
 %package nut
 Summary:       nut-plugin for collectd
@@ -614,6 +724,17 @@ UPS statistics using the Network UPS Tools. These statistics include
 basically everything NUT will give us, including voltages, currents,
 power, frequencies, load, and temperatures.
 
+%package olsrd
+Summary:       olsrd plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka olsrd dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+Requires:      openvpn
+
+%description olsrd
+The olsrd plugin reads information about meshed networks from the txtinfo
+plugin of the Optimized Link State Routing daemon (olsrd).
+
 %package openvpn
 Summary:       openvpn plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka openvpn dla collectd
@@ -685,6 +806,21 @@ Requires:  %{name} = %{version}-%{release}
 The protocols-plugin provides information about network protocols,
 such as IP, TCP and UDP.
 
+%package python
+Summary:       python-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka python dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description python
+The Python plugin embeds a Python interpreter into collectd and exposes
+the application programming interface (API) to Python-scripts. This allows
+to write own plugins in the popular scripting language, which are then
+loaded and executed by the daemon without the need to start a new process
+and interpreter every few seconds. Python-modules written for the Python
+plugin are therefore more powerful and efficient than scripts executed by
+the Exec plugin.
+
 %package rrdtool
 Summary:       rrdtool-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka rrdtool dla collectd
@@ -693,7 +829,7 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      rrdtool
 
 %description rrdtool
-RRDTOOL plugin for collectd.
+The RRDtool plugin writes values to RRD-files using librrd.
 
 %package sensors
 Summary:       sensors-plugin for collectd
@@ -713,7 +849,7 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description serial
-Serial plugin for collectd.
+The Serial plugin collects the traffic on serial interfaces.
 
 %package snmp
 Summary:       snmp-plugin for collectd
@@ -735,7 +871,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description swap
-Swap space plugin for collectd.
+The Swap plugin collects the amount of memory currently written onto hard
+disk or whatever the system calls “swap”.
 
 %package syslog
 Summary:       syslog-plugin for collectd
@@ -744,7 +881,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description syslog
-Syslog plugin for collectd.
+The SysLog plugin receives log messages from the daemon and dispatches
+them to syslog(3).
 
 %package table
 Summary:       table-plugin for collectd
@@ -774,6 +912,15 @@ Requires:  %{name} = %{version}-%{release}
 %description target_replace
 target_replace plugin for collectd.
 
+%package target_scale
+Summary:       target_scale-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka target_scale dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description target_scale
+Target to scale (multiply) values by an arbitrary value.
+
 %package target_set
 Summary:       target_set-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka target_set dla collectd
@@ -835,7 +982,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description thermal
-Thermal plugin for collectd.
+The thermal plugin reads ACPI thermal zone information from the sysfs or
+procfs file system, i. e. mostly system temperature information.
 
 %package unixsock
 Summary:       unixsock-plugin for collectd
@@ -901,6 +1049,17 @@ Requires: %{name} = %{version}-%{release}
 Collects information about the virtual servers running on a system,
 using Linux-Vserver.
 
+%package write_http
+Summary:       write_http-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka write_http dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description write_http
+The Write HTTP plugin sends the values collected by collectd to a
+web-server using HTTP POST requests. The data is formatted as PUTVAL
+commands.
+
 %package wireless
 Summary:       wireless-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka wireless dla collectd
@@ -908,7 +1067,8 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description wireless
-Wireless plugin for collectd.
+The Wireless plugin collects signal quality, signal power and
+signal-to-noise ratio for wireless LAN cards.
 
 %package xmms
 Summary:       xmms-plugin for collectd
@@ -917,7 +1077,9 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description xmms
-This plugin collectd data provided by XMMS.
+The XMMS plugin is a plugin for the XMMS music player. It graphs the
+bit-rate and sampling rate as you play songs. Not really useful, just
+something that got written because we can.
 
 %package -n perl-Collectd
 Summary:       Perl files from Collectd package
@@ -929,7 +1091,6 @@ Perl files from Collectd package
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -952,7 +1113,7 @@ Perl files from Collectd package
        --%{?with_libesmtp:en}%{!?with_libesmtp:dis}able-notify_email \
        --%{?with_ups:en}%{!?with_ups:dis}able-nut \
        --%{?with_ping:en}%{!?with_ping:dis}able-ping \
-       --%{?with_psql:en}%{!?with_psql:dis}able-postgresql \
+       --%{?with_pgsql:en}%{!?with_pgsql:dis}able-postgresql \
        --%{?with_rrd:en}%{!?with_rrd:dis}able-rrdtool \
        --%{?with_sensors:en}%{!?with_sensors:dis}able-sensors \
        --%{?with_snmp:en}%{!?with_snmp:dis}able-snmp \
@@ -1034,6 +1195,7 @@ fi
 %module_scripts ascent
 %module_scripts battery
 %module_scripts bind
+%module_scripts contextswitch
 %module_scripts conntrack
 %module_scripts cpu
 %module_scripts cpufreq
@@ -1055,6 +1217,9 @@ fi
 %module_scripts irq
 %module_scripts load
 %module_scripts logfile
+%module_scripts madwifi
+%module_scripts match_empty_counter
+%module_scripts match_hashed
 %module_scripts match_regex
 %module_scripts match_timediff
 %module_scripts match_value
@@ -1071,12 +1236,14 @@ fi
 %module_scripts notify_email
 %module_scripts ntpd
 %module_scripts nut
+%module_scripts olsrd
 %module_scripts openvpn
 %module_scripts ping
 %module_scripts postgresql
 %module_scripts powerdns
 %module_scripts processes
 %module_scripts protocols
+%module_scripts python
 %module_scripts rrdtool
 %module_scripts sensors
 %module_scripts serial
@@ -1087,6 +1254,7 @@ fi
 %module_scripts tail
 %module_scripts target_notification
 %module_scripts target_replace
+%module_scripts target_scale
 %module_scripts target_set
 %module_scripts tcpconns
 %module_scripts teamspeak2
@@ -1098,6 +1266,7 @@ fi
 %module_scripts uuid
 %module_scripts vmem
 %module_scripts vserver
+%module_scripts write_http
 %module_scripts wireless
 %module_scripts xmms
 
@@ -1209,6 +1378,11 @@ fi
 %endif
 %endif
 
+%files contextswitch
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/contextswitch.conf
+%attr(755,root,root) %{_libdir}/%{name}/contextswitch.so
+
 %files conntrack
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/conntrack.conf
@@ -1325,6 +1499,21 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/logfile.so
 %{_var}/log/collectd.log
 
+%files madwifi
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/madwifi.conf
+%attr(755,root,root) %{_libdir}/%{name}/madwifi.so
+
+%files match_empty_counter
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/match_empty_counter.conf
+%attr(755,root,root) %{_libdir}/%{name}/match_empty_counter.so
+
+%files match_hashed
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/match_hashed.conf
+%attr(755,root,root) %{_libdir}/%{name}/match_hashed.so
+
 %files match_regex
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/match_regex.conf
@@ -1419,6 +1608,11 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/nut.so
 %endif
 
+%files olsrd
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/olsrd.conf
+%attr(755,root,root) %{_libdir}/%{name}/olsrd.so
+
 %files openvpn
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/openvpn.conf
@@ -1431,7 +1625,7 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/ping.so
 %endif
 
-%if %{with psql}
+%if %{with pgsql}
 %files postgresql
 %defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/postgresql.conf
@@ -1454,6 +1648,12 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/protocols.conf
 %attr(755,root,root) %{_libdir}/%{name}/protocols.so
 
+%files python
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/python.conf
+%attr(755,root,root) %{_libdir}/%{name}/python.so
+%{_mandir}/man5/collectd-python.5*
+
 %if %{with rrd}
 %files rrdtool
 %defattr(644,root,root,755)
@@ -1511,6 +1711,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/target_replace.conf
 %attr(755,root,root) %{_libdir}/%{name}/target_replace.so
 
+%files target_scale
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/target_scale.conf
+%attr(755,root,root) %{_libdir}/%{name}/target_scale.so
+
 %files target_set
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/target_set.conf
@@ -1572,6 +1777,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/wireless.conf
 %attr(755,root,root) %{_libdir}/%{name}/wireless.so
 
+%files write_http
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/write_http.conf
+%attr(755,root,root) %{_libdir}/%{name}/write_http.so
+
 %if %{with xmms}
 %files xmms
 %defattr(644,root,root,755)
This page took 0.087952 seconds and 4 git commands to generate.