]> git.pld-linux.org Git - packages/collectd.git/blobdiff - collectd.spec
- unify
[packages/collectd.git] / collectd.spec
index 831f4de4ff85572de1e14ffbfca7cddebb7dcfde..d818ff1e93de648770af1009e881109f464cf263 100644 (file)
@@ -64,13 +64,14 @@ Summary:    Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
 Version:       4.4.0
-Release:       0.4
+Release:       0.5
 License:       GPL v2
 Group:         Daemons
 Source0:       http://collectd.org/files/%{name}-%{version}.tar.gz
 # Source0-md5: a677ddcad97fdb3cdd09efac4842b11d
 Source1:       %{name}.conf
 Source2:       %{name}.init
+Source3:       %{name}-http.conf
 URL:           http://collectd.org/
 BuildRequires: OpenIPMI-devel
 BuildRequires: autoconf
@@ -92,6 +93,12 @@ Requires(post,preun):        /sbin/chkconfig
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define         _pkglibdir      /var/lib/%{name}
+%define         _webapps        /etc/webapps 
+%define         _webapp         %{name}
+%define         _webappdir      %{_webapps}/%{_webapp}
+%define         _appdir         %{_datadir}/%{_webapp}
+
 %description
 collectd is a small daemon which collects system information every 10
 seconds and writes the results in an RRD-file.
@@ -135,26 +142,13 @@ This plugin collectd data provided by Apache's `mod_status'.
 Wtyczka collectd zbierająca informacje udostępniane przez moduł
 'mod_status' Apacha.
 
-%package collection-apache
-Summary:       Web script for collectiond
-Summary(pl_PL.UTF-8):  Web script for collectiond
-Group:         Applications/WWW
-Requires:      %{name} = %{version}-%{release}
-Requires:      perl-HTML-Parser
-Requires:      perl-URI
-
-%description collection-apache
-Web script for collectiond
-
-%package collection-lighttpd
+%package collection
 Summary:       Web script for collectiond
 Summary(pl_PL.UTF-8):  Web script for collectiond
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
-Requires:      perl-HTML-Parser
-Requires:      perl-URI
 
-%description collection-lighttpd
+%description collection
 Web script for collectiond
 
 %package dns
@@ -277,23 +271,26 @@ EOF
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_var}/{log/,lib/%{name}},/etc/rc.d/init.d/} \
+       $RPM_BUILD_ROOT{%{_appdir}/cgi-bin,%{_webappdir},%{_pkglibdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-
-install -d $RPM_BUILD_ROOT%{_var}/{log/,lib/%{name}}
-install -d $RPM_BUILD_ROOT/home/services/{httpd,lighttpd}/cgi-bin
-install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/
 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
 touch $RPM_BUILD_ROOT%{_var}/log/collectd.log
 install src/collectd.conf $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
-install collection.conf $RPM_BUILD_ROOT%{_sysconfdir}
-install contrib/collection.cgi $RPM_BUILD_ROOT/home/services/httpd/cgi-bin
-install contrib/collection.cgi $RPM_BUILD_ROOT/home/services/lighttpd/cgi-bin
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
+# Web frontend:
+install contrib/collection.conf $RPM_BUILD_ROOT%{_webappdir}
+install contrib/collection.cgi $RPM_BUILD_ROOT%{_appdir}/cgi-bin
+install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
+install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
+
+# Cleanups:
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -307,6 +304,18 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del %{name}
 fi
 
+%triggerin collection -- apache1 < 1.3.37-3, apache1-base
+%webapp_register apache %{_webapp}
+
+%triggerun collection -- apache1 < 1.3.37-3, apache1-base
+%webapp_unregister apache %{_webapp}
+
+%triggerin collection -- apache < 2.2.0, apache-base
+%webapp_register httpd %{_webapp}
+
+%triggerun collection -- apache < 2.2.0, apache-base
+%webapp_unregister httpd %{_webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README TODO contrib
@@ -383,15 +392,12 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/apache.so
 
-%files collection-apache
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/collection.conf
-%attr(755,root,root) /home/services/httpd/cgi-bin/collection.cgi
-
-%files collection-lighttpd
+%files collection
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/collection.conf
-%attr(755,root,root) /home/services/lighttpd/cgi-bin/collection.cgi
+%config(noreplace) %verify(not md5 mtime size) %{_webappdir}/collection.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
+%attr(755,root,root) %{_appdir}/cgi-bin/collection.cgi
 
 %files dns
 %defattr(644,root,root,755)
This page took 0.057857 seconds and 4 git commands to generate.