]> git.pld-linux.org Git - packages/collectd.git/blobdiff - collectd.spec
- release 2
[packages/collectd.git] / collectd.spec
index 150938fd8e873f94379e480cb3d1dbbc9ae3efb8..2402d8e9b2ca1e1dfd6f669015f6efe10fd32604 100644 (file)
@@ -10,7 +10,6 @@
 #   libjvm  . . . . . . . no (javac not found)
 #   libkstat  . . . . . . no (Solaris only)
 #   libkvm  . . . . . . . no
-#   libmemcached  . . . . no (libmemcached/memcached.h not found)
 #   libnetapp . . . . . . no (netapp_api.h not found)
 #   libperl . . . . . . . no
 #   librouteros . . . . . no ('routeros_api.h' not found)
@@ -18,7 +17,7 @@
 #   libvirt . . . . . . . no (pkg-config doesn't know library)
 #   libyajl . . . . . . . no (yajl/yajl_parse.h not found)
 #   oracle  . . . . . . . no (ORACLE_HOME is not set)
-# - Disabled modules:
+# - Disabled modules (build most of them an package):
 #   apple_sensors . . . no             (obvious)
 #   ipvs  . . . . . . . no             (ip_vs.h not found - llh to be fixed)
 #   libvirt . . . . . . no             (requires library)
@@ -30,7 +29,6 @@
 #   curl_json . . . . . . no
 #   gmond . . . . . . . . no
 #   java  . . . . . . . . no
-#   memcachec . . . . . . no
 #   netapp  . . . . . . . no
 #   oracle  . . . . . . . no
 #   routeros  . . . . . . no
@@ -52,7 +50,7 @@
 %bcond_without netlink         # netlink plugin
 %bcond_without notify          # notify_desktop plugin
 %bcond_without ping            # ping plugin
-%bcond_without psql            # PostgreSQL plugin
+%bcond_without pgsql           # PostgreSQL plugin
 %bcond_without rrd             # rrdtool and rrdcached plugins
 %bcond_without sensors         # sensors plugin
 %bcond_without snmp            # SNMP plugin
@@ -70,7 +68,7 @@ Summary:      Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
 Version:       4.9.1
-Release:       0.9
+Release:       2
 License:       GPL v2
 Group:         Daemons
 Source0:       http://collectd.org/files/%{name}-%{version}.tar.bz2
@@ -92,6 +90,8 @@ BuildRequires:        hal-devel
 BuildRequires: libdbi-devel
 %{?with_libesmtp:BuildRequires:        libesmtp-devel}
 BuildRequires: libltdl-devel
+BuildRequires: libmemcached-devel
+BuildRequires: libnetlink-devel
 %{?with_netlink:BuildRequires: libnetlink-devel}
 %{?with_notify:BuildRequires:  libnotify-devel}
 %{?with_ping:BuildRequires:    liboping-devel}
@@ -102,12 +102,18 @@ BuildRequires:    libtool
 %{?with_xml:BuildRequires:     libxml2-devel}
 %{?with_sensors:BuildRequires: lm_sensors-devel}
 %{?with_mysql:BuildRequires:   mysql-devel}
+BuildRequires: ncurses-devel
 %{?with_snmp:BuildRequires:    net-snmp-devel}
 %{?with_ups:BuildRequires:     nut-devel}
 BuildRequires: perl-devel
-%{?with_psql:BuildRequires:    postgresql-devel}
+BuildRequires: pkgconfig
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+BuildRequires: python-devel
+BuildRequires: python-modules
 BuildRequires: rpmbuild(macros) >= 1.268
 %{?with_rrd:BuildRequires:     rrdtool-devel}
+BuildRequires: which
+#BuildRequires:        xfsprogs-devel
 %{?with_xmms:BuildRequires:    xmms-devel}
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
@@ -578,6 +584,18 @@ Requires:  %{name} = %{version}-%{release}
 %description mbmon
 The mbmon plugin uses mbmon to retrieve temperature, voltage, etc.
 
+%package memcachec
+Summary:       memcachec-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka memcachec dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description memcachec
+The memcachec plugin connects to a memcached server, queries one or more
+given pages and parses the returned data according to user specification.
+The matches used are similar to the matches used in the cURL and Tail
+plugins.
+
 %package memcached
 Summary:       memcached-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka memcached dla collectd
@@ -1105,7 +1123,7 @@ Perl files from Collectd package
        --%{?with_libesmtp:en}%{!?with_libesmtp:dis}able-notify_email \
        --%{?with_ups:en}%{!?with_ups:dis}able-nut \
        --%{?with_ping:en}%{!?with_ping:dis}able-ping \
-       --%{?with_psql:en}%{!?with_psql:dis}able-postgresql \
+       --%{?with_pgsql:en}%{!?with_pgsql:dis}able-postgresql \
        --%{?with_rrd:en}%{!?with_rrd:dis}able-rrdtool \
        --%{?with_sensors:en}%{!?with_sensors:dis}able-sensors \
        --%{?with_snmp:en}%{!?with_snmp:dis}able-snmp \
@@ -1216,6 +1234,7 @@ fi
 %module_scripts match_timediff
 %module_scripts match_value
 %module_scripts mbmon
+%module_scripts memcachec
 %module_scripts memcached
 %module_scripts memory
 %module_scripts multimeter
@@ -1495,7 +1514,7 @@ fi
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/madwifi.conf
 %attr(755,root,root) %{_libdir}/%{name}/madwifi.so
-   
+
 %files match_empty_counter
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/match_empty_counter.conf
@@ -1526,6 +1545,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/mbmon.conf
 %attr(755,root,root) %{_libdir}/%{name}/mbmon.so
 
+%files memcachec
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/memcachec.conf
+%attr(755,root,root) %{_libdir}/%{name}/memcachec.so
+
 %files memcached
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/memcached.conf
@@ -1617,7 +1641,7 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/ping.so
 %endif
 
-%if %{with psql}
+%if %{with pgsql}
 %files postgresql
 %defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/postgresql.conf
This page took 0.038488 seconds and 4 git commands to generate.