]> git.pld-linux.org Git - packages/collectd.git/blobdiff - collectd.spec
- one %desc devel -l pl is enough; adapter
[packages/collectd.git] / collectd.spec
index d0accfb2be983281581089f3b34e95e4558d1401..1b5332556a4916de96c5f868ced687e14fd7c3a7 100644 (file)
@@ -1,38 +1,37 @@
-# TODO:
-# - package contrib scripts as %doc
-# - perl modules with Collectd classes package to separate package
-# - Disabled modules:
-#    apple_sensors . . . no            (obvious)
-#    ipvs  . . . . . . . no            (ip_vs.h not found - llh to be fixed)
-#    libvirt . . . . . . no            (requires library)
-#    multimeter  . . . . no            ?
-#    onewire . . . . . . no            (needs libowfs)
-#    perl  . . . . . . . no            (needs libperl)
-#    tape  . . . . . . . no            ?
-# - logrotate file for logfile plugin
-# - %desc -l pl for plugins
-#
 # Conditional build:
-%bcond_without dns             # ???
-%bcond_without ipmi            # ipmi plugin package
+%bcond_without curl            # apache, ascent, bind, curl and nginx plugins
+%bcond_without dns             # DNS plugin
+%bcond_without ipmi            # IPMI plugin
 %bcond_without iptables        # iptables plugin
+%bcond_without libesmtp        # notify_email plugin
 %bcond_with    multimeter      # multimeter plugin
+%bcond_without mysql           # MySQL plugin
 %bcond_without netlink         # netlink plugin
-#
-#http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358637
+%bcond_without notify          # notify_desktop plugin
+%bcond_without ping            # ping plugin
+%bcond_without psql            # PostgreSQL plugin
+%bcond_without rrd             # rrdtool and rrdcached plugins
+%bcond_without sensors         # sensors plugin
+%bcond_without snmp            # SNMP plugin
+%bcond_without ups             # nut plugin
+%bcond_without xml             # ascent, bind and libvirt plugins
+%bcond_without xmms            # XMMS plugin
+
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358637
 %ifarch %{x8664}
 %undefine with_iptables
 %undefine with_netlink
 %endif
+
 Summary:       Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
-Version:       4.6.2
-Release:       2
+Version:       4.7.1
+Release:       1
 License:       GPL v2
 Group:         Daemons
-Source0:       http://collectd.org/files/%{name}-%{version}.tar.gz
-# Source0-md5: 9eee46a6330780d6e6b41155b159f4f9
+Source0:       http://collectd.org/files/%{name}-%{version}.tar.bz2
+# Source0-md5: 20e95914219a32bfd51d01333dbb7c01
 Source1:       %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
@@ -40,30 +39,34 @@ Source4:    %{name}-lighttpd.conf
 Source10:      %{name}-df.conf
 Source11:      %{name}-rrdtool.conf
 Patch0:                %{name}-collection.patch
+Patch1:                %{name}-as_needed.patch
 URL:           http://collectd.org/
 %{?with_ipmi:BuildRequires:    OpenIPMI-devel >= 2.0.14-3}
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: curl-devel
+%{?with_curl:BuildRequires:    curl-devel}
 BuildRequires: hal-devel
 %{?with_iptables:BuildRequires:        iptables-devel >= 1.4.1.1-4}
-BuildRequires: libesmtp-devel
-BuildRequires: libnetlink-devel
-BuildRequires: libnotify-devel
-BuildRequires: liboping-devel
-BuildRequires: libpcap-devel
+BuildRequires: libdbi-devel
+%{?with_libesmtp:BuildRequires:        libesmtp-devel}
+BuildRequires: libltdl-devel
+%{?with_netlink:BuildRequires: libnetlink-devel}
+%{?with_notify:BuildRequires:  libnotify-devel}
+%{?with_ping:BuildRequires:    liboping-devel}
+%{?with_dns:BuildRequires:     libpcap-devel}
 BuildRequires: libstatgrab-devel >= 0.12
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: libxml2-devel
-BuildRequires: lm_sensors-devel
-BuildRequires: mysql-devel
-BuildRequires: nut-devel
+%{?with_xml:BuildRequires:     libxml2-devel}
+%{?with_sensors:BuildRequires: lm_sensors-devel}
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_snmp:BuildRequires:    net-snmp-devel}
+%{?with_ups:BuildRequires:     nut-devel}
 BuildRequires: perl-devel
-BuildRequires: postgresql-devel
+%{?with_psql:BuildRequires:    postgresql-devel}
 BuildRequires: rpmbuild(macros) >= 1.268
-BuildRequires: rrdtool-devel
-BuildRequires: net-snmp-devel
-BuildRequires: xmms-devel
+%{?with_rrd:BuildRequires:     rrdtool-devel}
+%{?with_xmms:BuildRequires:    xmms-devel}
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -96,9 +99,9 @@ zapisane nowe wartości. Dzięki temu collect może mieć rozdzielczość 10
 sekund i nie obciążać zbytnio systemu.
 
 %package libs
-Summary:        %{name} libraries
-Summary(pl.UTF-8):      Biblioteki %{name} 
-Group:          Libraries
+Summary:       %{name} libraries
+Summary(pl.UTF-8):     Biblioteki %{name}
+Group:         Libraries
 
 %description libs
 %{name} libraries.
@@ -107,10 +110,10 @@ Group:          Libraries
 Biblioteki %{name}.
 
 %package devel
-Summary:        Header files for %{name} libraries
-Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek %{name} 
-Group:          Development/Libraries
-Requires:       %{name}-libs = %{version}-%{release}
+Summary:       Header files for %{name} libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek %{name}
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 Header files for %{name} libraries.
@@ -118,6 +121,18 @@ Header files for %{name} libraries.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe bibliotek %{name}.
 
+%package static
+Summary:       Static files for %{name} libraries
+Summary(pl.UTF-8):     Pliki statyczne bibliotek %{name}
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description static
+Static files for %{name} libraries.
+
+%description static -l pl.UTF-8
+Pliki statyczne bibliotek %{name}.
+
 %package apache
 Summary:       apache-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka apache dla collectd
@@ -125,7 +140,7 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description apache
-This plugin collectd data provided by Apache's `mod_status'.
+This plugin collect data provided by Apache's `mod_status'.
 
 %description apache -l pl.UTF-8
 Wtyczka collectd zbierająca informacje udostępniane przez moduł
@@ -166,10 +181,11 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description bind
-Starting with BIND 9.5.0, the most widely used DNS server software provides
-extensive statistics about queries, responses and lots of other information.
-The bind plugin retrieves this information that's encoded in XML and provided
-via HTTP and submits the values to collectd.
+Starting with BIND 9.5.0, the most widely used DNS server software
+provides extensive statistics about queries, responses and lots of
+other information. The bind plugin retrieves this information that's
+encoded in XML and provided via HTTP and submits the values to
+collectd.
 
 %package collection
 Summary:       Web script for collectd
@@ -187,6 +203,15 @@ Suggests:  fonts-TTF-DejaVu
 %description collection
 Web script for collectd.
 
+%package conntrack
+Summary:       conntrack-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka conntrack dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description conntrack
+The conntrack-plugin collects the connection tracking table size.
+
 %package cpu
 Summary:       cpu-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka cpu dla collectd
@@ -194,9 +219,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description cpu
-The cpu-plugin collects the amount of time spent by the CPU in various states,
-most notably executing user code, executing system code, waiting for IO
-operations and being idle.
+The cpu-plugin collects the amount of time spent by the CPU in various
+states, most notably executing user code, executing system code,
+waiting for IO operations and being idle.
 
 %package cpufreq
 Summary:       cpufreq-plugin for collectd
@@ -234,11 +259,12 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description dbi
-This plugin uses the dbi library to connect to various databases, execute
-SQL statements and read back the results. dbi is an acronym for "database
-interface" in case you were wondering about the name. You can configure how
-each column is to be interpreted and the plugin will generate one or more
-data sets from each row returned according to these rules.
+This plugin uses the dbi library to connect to various databases,
+execute SQL statements and read back the results. dbi is an acronym
+for "database interface" in case you were wondering about the name.
+You can configure how each column is to be interpreted and the plugin
+will generate one or more data sets from each row returned according
+to these rules.
 
 %package df
 Summary:       df-plugin for collectd
@@ -247,10 +273,10 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description df
-The df-plugin collects file system usage information, i. e. basically how
-much space on a mounted partition is used and how much is available. It's
-named after and very similar to the df(1) UNIX command that's been around
-forever.
+The df-plugin collects file system usage information, i. e. basically
+how much space on a mounted partition is used and how much is
+available. It's named after and very similar to the df(1) UNIX command
+that's been around forever.
 
 %package disk
 Summary:       disk-plugin for collectd
@@ -270,9 +296,9 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      perl-rrdtool
 
 %description dns
-This plugin has a similar functionality to dnstop: It uses libpcap to get
-a copy of all traffic from/to port UDP/53 (that's the DNS port), interprets
-the packets and collects statistics of your DNS traffic.
+This plugin has a similar functionality to dnstop: It uses libpcap to
+get a copy of all traffic from/to port UDP/53 (that's the DNS port),
+interprets the packets and collects statistics of your DNS traffic.
 
 %package email
 Summary:       email-plugin for collectd
@@ -282,12 +308,12 @@ Requires: %{name} = %{version}-%{release}
 
 %description email
 The email plugin opens an UNIX-socket over which one can submit email
-statistics, such as the number of ``ham'', ``spam'', ``virus'', etc. mails
-received/handled, spam scores and matched spam checks.
+statistics, such as the number of ``ham'', ``spam'', ``virus'', etc.
+mails received/handled, spam scores and matched spam checks.
 
 This plugin is intended to be used with the the
-Mail::SpamAssassin::Plugin::Collectd manpage SpamAssassin-plugin which is
-included in contrib/, but is of course not limited to that use.
+Mail::SpamAssassin::Plugin::Collectd manpage SpamAssassin-plugin which
+is included in contrib/, but is of course not limited to that use.
 
 %package entropy
 Summary:       entropy-plugin for collectd
@@ -315,11 +341,21 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description filecount
-The filecount-plugin does something very simple: Count the number of files
-in a directory and all its subdirectories. This can be used for a variety of
-statistics, for example the queue length of an MTA, the number of PHP
-sessions of a web server or simply the number of files in your home
-directory.
+The filecount-plugin does something very simple: Count the number of
+files in a directory and all its subdirectories. This can be used for
+a variety of statistics, for example the queue length of an MTA, the
+number of PHP sessions of a web server or simply the number of files
+in your home directory.
+
+%package fscache
+Summary:       fscache-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka fscache dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description fscache
+The fscache-plugin collects statistics about Linux file-system based
+caching framework.
 
 %package hddtemp
 Summary:       hddtemp-plugin for collectd
@@ -329,8 +365,8 @@ Requires:   %{name} = %{version}-%{release}
 Suggests:      hddtemp-hddtempd
 
 %description hddtemp
-Temperature of harddisks. The temperatures are provided via S.M.A.R.T. and
-queried by the external hddtemp-daemon.
+Temperature of harddisks. The temperatures are provided via S.M.A.R.T.
+and queried by the external hddtemp-daemon.
 
 %package interface
 Summary:       interface-plugin for collectd
@@ -339,8 +375,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description interface
-The interface-plugin collects information about the traffic (octets), packets
-and errors of interfaces.
+The interface-plugin collects information about the traffic (octets),
+packets and errors of interfaces.
 
 %package iptables
 Summary:       iptables-plugin for collectd
@@ -350,13 +386,14 @@ Requires: %{name} = %{version}-%{release}
 
 %description iptables
 With this plugin you can gather statistics from your ip_tables based
-packetfilter (aka. firewall). It can collect the byte- and packet-counters
-of selected rules and submit them to collectd. You can select rules that
-should be collected wither by its position (e.g. "the fourth rule in the
-INPUT queue in the filter table") or by its comment (using the COMMENT
-match). This means that depending on your firewall layout you can collect
-certain services (such as the amount of web-traffic), source or destination
-hosts or networks, dropped packets and much more.
+packetfilter (aka. firewall). It can collect the byte- and
+packet-counters of selected rules and submit them to collectd. You can
+select rules that should be collected wither by its position (e.g.
+"the fourth rule in the INPUT queue in the filter table") or by its
+comment (using the COMMENT match). This means that depending on your
+firewall layout you can collect certain services (such as the amount
+of web-traffic), source or destination hosts or networks, dropped
+packets and much more.
 
 %package ipmi
 Summary:       ipmi-plugin for collectd
@@ -441,9 +478,10 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description memcached
-The memcached plugin connects to a memcached daemon and collects the number
-of connections and requests handled by the daemon, the CPU resources consumed,
-number of items cached, number of threads, and bytes sent and received.
+The memcached plugin connects to a memcached daemon and collects the
+number of connections and requests handled by the daemon, the CPU
+resources consumed, number of items cached, number of threads, and
+bytes sent and received.
 
 %package memory
 Summary:       memory-plugin for collectd
@@ -468,6 +506,7 @@ Summary:    mysql-plugin for collectd
 Summary(pl_PL.UTF-8):  Moduł mysql dla collectd.
 Group:         Daemons
 Requires:      %{name} = %{version}-%{release}
+Requires:      mysql-client
 
 %description mysql
 MySQL querying plugin. This plugins provides data of issued commands,
@@ -484,11 +523,11 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description netlink
-This plugin will open a netlink socket to the Linux kernel and use it to get
-statistics for interfaces, qdiscs, classes, and, if you can make use of it,
-filters. Since in most setups many of the statistics this plugin can collect
-aren't of interest, you can select which information to gather using the
-configuration.
+This plugin will open a netlink socket to the Linux kernel and use it
+to get statistics for interfaces, qdiscs, classes, and, if you can
+make use of it, filters. Since in most setups many of the statistics
+this plugin can collect aren't of interest, you can select which
+information to gather using the configuration.
 
 %package network
 Summary:       network-plugin for collectd
@@ -506,8 +545,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description nfs
-The nfs plugin counts the number of procedure calls of the different NFS
-procedures.
+The nfs plugin counts the number of procedure calls of the different
+NFS procedures.
 
 %package nginx
 Summary:       nginx-plugin for collectd
@@ -516,9 +555,10 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description nginx
-This plugin collects the number of connections and requests handled by the
-nginx daemon, a HTTP and mail server/proxy. It queries the page provided by
-the ngx_http_stub_status_module module, which isn't compiled by default.
+This plugin collects the number of connections and requests handled by
+the nginx daemon, a HTTP and mail server/proxy. It queries the page
+provided by the ngx_http_stub_status_module module, which isn't
+compiled by default.
 
 %package notify_desktop
 Summary:       notify_desktop for collectd
@@ -528,9 +568,9 @@ Requires:   %{name} = %{version}-%{release}
 
 %description notify_desktop
 This plugin sends a desktop notification to a notification daemon, as
-defined in the Desktop Notification Specification. To actually display the
-notifications, notification-daemon is required and collectd has to be able
-to access the X server.
+defined in the Desktop Notification Specification. To actually display
+the notifications, notification-daemon is required and collectd has to
+be able to access the X server.
 
 %package notify_email
 Summary:       notify_email-plugin for collectd
@@ -558,8 +598,8 @@ Requires:   %{name} = %{version}-%{release}
 
 %description nut
 UPS statistics using the Network UPS Tools. These statistics include
-basically everything NUT will give us, including voltages, currents, power,
-frequencies, load, and temperatures.
+basically everything NUT will give us, including voltages, currents,
+power, frequencies, load, and temperatures.
 
 %package openvpn
 Summary:       openvpn plugin for collectd
@@ -569,22 +609,24 @@ Requires: %{name} = %{version}-%{release}
 Requires:      openvpn
 
 %description openvpn
-The OpenVPN plugin reads a status file maintained by OpenVPN and gathers
-traffic statistics about connected clients.
+The OpenVPN plugin reads a status file maintained by OpenVPN and
+gathers traffic statistics about connected clients.
 
 %package ping
 Summary:       ping-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka ping dla collectd
 Group:         Daemons
 Requires:      %{name} = %{version}-%{release}
+Requires:      liboping >= 1.1.2
 
 %description ping
-The network latency is measured as a roundtrip time. An ICMP-echo-request
-(aka. "ping")is sent to a host and the time needed for his echo-reply (aka.
-"pong") to arrive is measured. If a reply is not received within one second
-the plugin will no longer expect a reply and return. This may happen in
-several circumstances, e. g. the packet is lost, the host is down, a router
-has dismissed the packet, etc.
+The network latency is measured as a roundtrip time. An
+ICMP-echo-request (aka. "ping")is sent to a host and the time needed
+for his echo-reply (aka. "pong") to arrive is measured. If a reply is
+not received within one second the plugin will no longer expect a
+reply and return. This may happen in several circumstances, e. g. the
+packet is lost, the host is down, a router has dismissed the packet,
+etc.
 
 %package postgresql
 Summary:       mysql-plugin for collectd
@@ -593,9 +635,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description postgresql
-The postgresql plugin queries statistics from PostgreSQL databases. It keeps
-a persistent connection to all configured databases and tries to reconnect
-if the connection has been interrupted.
+The postgresql plugin queries statistics from PostgreSQL databases. It
+keeps a persistent connection to all configured databases and tries to
+reconnect if the connection has been interrupted.
 
 %package powerdns
 Summary:       powerdns-plugin for collectd
@@ -605,9 +647,9 @@ Requires:   %{name} = %{version}-%{release}
 
 %description powerdns
 The powerdns plugin queries statistics from an authoritative PowerDNS
-nameserver and/or a PowerDNS recursor. Since both offer a wide variety of
-values, many of which are probably meaningless to most users, but may be
-useful for some.
+nameserver and/or a PowerDNS recursor. Since both offer a wide variety
+of values, many of which are probably meaningless to most users, but
+may be useful for some.
 
 %package processes
 Summary:       processes-plugin for collectd
@@ -616,9 +658,19 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description processes
-This plugin collects the number of processes, grouped by their state (e.g.
-running, sleeping, zombies, etc.). In addition to that, it can select
-detailed statistics about selected processes, grouped by name.
+This plugin collects the number of processes, grouped by their state
+(e.g. running, sleeping, zombies, etc.). In addition to that, it can
+select detailed statistics about selected processes, grouped by name.
+
+%package protocols
+Summary:       protocols-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka protocols dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description protocols
+The protocols-plugin provides information about network protocols,
+such as IP, TCP and UDP.
 
 %package rrdtool
 Summary:       rrdtool-plugin for collectd
@@ -638,10 +690,9 @@ Requires:  %{name} = %{version}-%{release}
 
 %description sensors
 This plugin uses lm-sensors to read hardware sensors. You will need to
-configure lm-sensors before this plugin will collect any usefull and correct
-data.
+configure lm-sensors before this plugin will collect any usefull and
+correct data.
 
-%module_scripts serial
 %package serial
 Summary:       serial-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka serial dla collectd
@@ -659,10 +710,10 @@ Requires: %{name} = %{version}-%{release}
 
 %description snmp
 The snmp plugin queries other hosts using SNMP, the Simple Network
-Management Protocol, and translates the value it receives to collectd's
-internal format and dispatches them. Depending on the write plugins you have
-loaded they may be written to disk or submitted to another instance or
-whatever you configured.
+Management Protocol, and translates the value it receives to
+collectd's internal format and dispatches them. Depending on the write
+plugins you have loaded they may be written to disk or submitted to
+another instance or whatever you configured.
 
 %package swap
 Summary:       swap-plugin for collectd
@@ -682,6 +733,16 @@ Requires:  %{name} = %{version}-%{release}
 %description syslog
 Syslog plugin for collectd.
 
+%package table
+Summary:       table-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka table dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description table
+The table-plugin provides parsing for table-like structured files,
+such as many files beneath /proc.
+
 %package target_notification
 Summary:       target_notification-plugin for collectd
 Summary(pl_PL.UTF-8):  Wtyczka target_notification dla collectd
@@ -716,9 +777,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description tail
-The tail-plugin can be used to "tail" logfiles, i.e. follow them as tail -F
-does. Each line is given to one or more "matches" which test if the line is
-relevant for any statistics using a regular expression.
+The tail-plugin can be used to "tail" logfiles, i.e. follow them as
+tail -F does. Each line is given to one or more "matches" which test
+if the line is relevant for any statistics using a regular expression.
 
 %package tcpconns
 Summary:       tcpconns-plugin for collectd
@@ -728,9 +789,9 @@ Requires:   %{name} = %{version}-%{release}
 
 %description tcpconns
 The tcpconns-plugin counts the number of TCP connections to or from a
-specified port. Typically the connectioins where you specify the local port
-are incoming connections while the connections where you specify the remote
-port are outgoing connections.
+specified port. Typically the connectioins where you specify the local
+port are incoming connections while the connections where you specify
+the remote port are outgoing connections.
 
 %package teamspeak2
 Summary:       teamspeak2-plugin for collectd
@@ -739,9 +800,20 @@ Group:             Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description teamspeak2
-The teamspeak2 plugin connects to the query port of a teamspeak2 server and
-polls interesting global and virtual server data. The plugin can query only
-one physical server but unlimited virtual servers.
+The teamspeak2 plugin connects to the query port of a teamspeak2
+server and polls interesting global and virtual server data. The
+plugin can query only one physical server but unlimited virtual
+servers.
+
+%package ted
+Summary:       ted-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka ted dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description ted
+The TED-plugin reads power consumption measurements from “The Energy
+Detective” (TED).
 
 %package thermal
 Summary:       thermal-plugin for collectd
@@ -759,10 +831,19 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description unixsock
-The unixsock plugin opens an UNIX-socket over which one can interact with
-the daemon. This can be used to use the values collected by collectd in
-other applications, such as monitoring, or submit externally collected
-values to collectd.
+The unixsock plugin opens an UNIX-socket over which one can interact
+with the daemon. This can be used to use the values collected by
+collectd in other applications, such as monitoring, or submit
+externally collected values to collectd.
+
+%package uptime
+Summary:       uptime-plugin for collectd
+Summary(pl_PL.UTF-8):  Wtyczka uptime dla collectd
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+
+%description uptime
+The uptime-plugin can collect the server's uptime.
 
 %package users
 Summary:       users-plugin for collectd
@@ -780,11 +861,11 @@ Group:            Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description uuid
-This plugin, if loaded, causes the Hostname to be taken from the machine's
-UUID. The UUID is a universally unique designation for the machine, usually
-taken from the machine's BIOS. This is most useful if the machine is
-running in a virtual environment such as Xen, in which case the UUID is
-preserved across shutdowns and migration.
+This plugin, if loaded, causes the Hostname to be taken from the
+machine's UUID. The UUID is a universally unique designation for the
+machine, usually taken from the machine's BIOS. This is most useful if
+the machine is running in a virtual environment such as Xen, in which
+case the UUID is preserved across shutdowns and migration.
 
 %package vmem
 Summary:       vmem-plugin for collectd
@@ -793,9 +874,9 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description vmem
-The vmem plugin collects information about the usage of virtual memory.
-Since the statistics provided by the Linux kernel are very detailed, they
-are collected very detailed.
+The vmem plugin collects information about the usage of virtual
+memory. Since the statistics provided by the Linux kernel are very
+detailed, they are collected very detailed.
 
 %package vserver
 Summary:       vserver-plugin for collectd
@@ -804,8 +885,8 @@ Group:              Daemons
 Requires:      %{name} = %{version}-%{release}
 
 %description vserver
-Collects information about the virtual servers running on a system, using
-Linux-Vserver.
+Collects information about the virtual servers running on a system,
+using Linux-Vserver.
 
 %package wireless
 Summary:       wireless-plugin for collectd
@@ -828,6 +909,7 @@ This plugin collectd data provided by XMMS.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -840,11 +922,23 @@ This plugin collectd data provided by XMMS.
        --with-libstatgrab=/usr \
        --with-lm-sensors=/usr \
        --with-libmysql=/usr \
-       --%{?with_ipmi:en}%{!?with_ipmi:dis}able-ipmi \
-       --%{?with_multimeter:en}%{!?with_multimeter:dis}able-multimeter \
        --%{?with_dns:en}%{!?with_dns:dis}able-dns \
+       --%{?with_ipmi:en}%{!?with_ipmi:dis}able-ipmi \
        --%{?with_iptables:en}%{!?with_iptables:dis}able-iptables \
+       --%{?with_multimeter:en}%{!?with_multimeter:dis}able-multimeter \
+       --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
        --%{?with_netlink:en}%{!?with_netlink:dis}able-netlink \
+       --%{?with_notify:en}%{!?with_notify:dis}able-notify_desktop \
+       --%{?with_libesmtp:en}%{!?with_libesmtp:dis}able-notify_email \
+       --%{?with_ups:en}%{!?with_ups:dis}able-nut \
+       --%{?with_ping:en}%{!?with_ping:dis}able-ping \
+       --%{?with_psql:en}%{!?with_psql:dis}able-postgresql \
+       --%{?with_rrd:en}%{!?with_rrd:dis}able-rrdtool \
+       --%{?with_sensors:en}%{!?with_sensors:dis}able-sensors \
+       --%{?with_snmp:en}%{!?with_snmp:dis}able-snmp \
+       --%{?with_xmms:en}%{!?with_xmms:dis}able-xmms \
+       %{!?with_curl:--disable-{apache,ascent,bind,curl,nginx}} \
+       %{!?with_xml:--disable-{ascent,bind,libvirt}} \
        --disable-ipvs \
        --disable-libvirt \
        --disable-perl
@@ -916,22 +1010,24 @@ fi
 %module_scripts ascent
 %module_scripts battery
 %module_scripts bind
-%module_scripts cpufreq
+%module_scripts conntrack
 %module_scripts cpu
+%module_scripts cpufreq
 %module_scripts csv
 %module_scripts curl
 %module_scripts dbi
 %module_scripts df
 %module_scripts disk
-%{?with_dns:%module_scripts dns}
+%module_scripts dns
 %module_scripts email
 %module_scripts entropy
 %module_scripts exec
 %module_scripts filecount
+%module_scripts fscache
 %module_scripts hddtemp
 %module_scripts interface
-%{?with_ipmi:%module_scripts ipmi}
-%{?with_iptables:%module_scripts iptables}
+%module_scripts ipmi
+%module_scripts iptables
 %module_scripts irq
 %module_scripts load
 %module_scripts logfile
@@ -941,9 +1037,9 @@ fi
 %module_scripts mbmon
 %module_scripts memcached
 %module_scripts memory
-%{?with_multimeter:%module_scripts multimeter}
+%module_scripts multimeter
 %module_scripts mysql
-%{?with_netlink:%module_scripts netlink}
+%module_scripts netlink
 %module_scripts network
 %module_scripts nfs
 %module_scripts nginx
@@ -956,20 +1052,24 @@ fi
 %module_scripts postgresql
 %module_scripts powerdns
 %module_scripts processes
+%module_scripts protocols
 %module_scripts rrdtool
 %module_scripts sensors
 %module_scripts serial
 %module_scripts snmp
 %module_scripts swap
 %module_scripts syslog
+%module_scripts table
 %module_scripts tail
 %module_scripts target_notification
 %module_scripts target_replace
 %module_scripts target_set
 %module_scripts tcpconns
 %module_scripts teamspeak2
+%module_scripts ted
 %module_scripts thermal
 %module_scripts unixsock
+%module_scripts uptime
 %module_scripts users
 %module_scripts uuid
 %module_scripts vmem
@@ -1008,9 +1108,10 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %{_mandir}/man1/collectd.1*
 %{_mandir}/man1/collectd-nagios.1*
+%{_mandir}/man1/collectdmon.1*
 %{_mandir}/man5/collectd.conf.5*
+%{_mandir}/man5/collectd-java.5*
 %{_mandir}/man5/collectd-perl.5*
-%{_mandir}/man1/collectdmon.1*
 %{_mandir}/man5/types.db.5*
 %dir %{_var}/lib/%{name}
 
@@ -1028,6 +1129,11 @@ fi
 %{_includedir}/%{name}/*.h
 %{_pkgconfigdir}/libcollectdclient.pc
 
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libcollectdclient.a
+%{_libdir}/%{name}/*.a
+
 %files collection
 %defattr(644,root,root,755)
 %dir %{_webappdir}
@@ -1040,30 +1146,45 @@ fi
 %attr(755,root,root) %{_appdir}/cgi-bin/collection.cgi
 
 ########## PLUGINS:
+%if %{with xml}
+%if %{with curl}
+%files apache
+%defattr(640,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/apache.conf
+%attr(755,root,root) %{_libdir}/%{name}/apache.so
+%endif
+%endif
+
 %files apcups
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/apcups.conf
 %attr(755,root,root) %{_libdir}/%{name}/apcups.so
 
+%if %{with curl}
 %files ascent
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ascent.conf
 %attr(755,root,root) %{_libdir}/%{name}/ascent.so
-
-%files apache
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/apache.conf
-%attr(755,root,root) %{_libdir}/%{name}/apache.so
+%endif
 
 %files battery
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/battery.conf
 %attr(755,root,root) %{_libdir}/%{name}/battery.so
 
+%if %{with xml}
+%if %{with curl}
 %files bind
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/bind.conf
 %attr(755,root,root) %{_libdir}/%{name}/bind.so
+%endif
+%endif
+
+%files conntrack
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/conntrack.conf
+%attr(755,root,root) %{_libdir}/%{name}/conntrack.so
 
 %files cpu
 %defattr(644,root,root,755)
@@ -1080,13 +1201,15 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/csv.conf
 %attr(755,root,root) %{_libdir}/%{name}/csv.so
 
+%if %{with curl}
 %files curl
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/curl.conf
 %attr(755,root,root) %{_libdir}/%{name}/curl.so
+%endif
 
 %files dbi
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/dbi.conf
 %attr(755,root,root) %{_libdir}/%{name}/dbi.so
 
@@ -1100,10 +1223,12 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/disk.conf
 %attr(755,root,root) %{_libdir}/%{name}/disk.so
 
+%if %{with dns}
 %files dns
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/dns.conf
 %attr(755,root,root) %{_libdir}/%{name}/dns.so
+%endif
 
 %files email
 %defattr(644,root,root,755)
@@ -1127,6 +1252,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/filecount.conf
 %attr(755,root,root) %{_libdir}/%{name}/filecount.so
 
+%files fscache
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/fscache.conf
+%attr(755,root,root) %{_libdir}/%{name}/fscache.so
+
 %files hddtemp
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/hddtemp.conf
@@ -1175,6 +1305,7 @@ fi
 %files match_timediff
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/match_timediff.so
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/match_timediff.conf
 
 %files match_value
 %defattr(644,root,root,755)
@@ -1203,10 +1334,12 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/multimeter.so
 %endif
 
+%if %{with mysql}
 %files mysql
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/mysql.conf
 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
+%endif
 
 %if %{with netlink}
 %files netlink
@@ -1225,45 +1358,58 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/nfs.conf
 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
 
+%if %{with curl}
 %files nginx
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/nginx.conf
 %attr(755,root,root) %{_libdir}/%{name}/nginx.so
+%endif
 
+%if %{with notify}
 %files notify_desktop
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/notify_desktop.conf
 %attr(755,root,root) %{_libdir}/%{name}/notify_desktop.so
+%endif
 
+%if %{with libesmtp}
 %files notify_email
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/notify_email.conf
 %attr(755,root,root) %{_libdir}/%{name}/notify_email.so
+%endif
 
 %files ntpd
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ntpd.conf
 %attr(755,root,root) %{_libdir}/%{name}/ntpd.so
 
+%if %{with ups}
 %files nut
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/nut.conf
 %attr(755,root,root) %{_libdir}/%{name}/nut.so
+%endif
 
 %files openvpn
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/openvpn.conf
 %attr(755,root,root) %{_libdir}/%{name}/openvpn.so
 
+%if %{with ping}
 %files ping
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ping.conf
 %attr(755,root,root) %{_libdir}/%{name}/ping.so
+%endif
 
+%if %{with psql}
 %files postgresql
-%defattr(644,root,root,755)
+%defattr(640,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/postgresql.conf
 %attr(755,root,root) %{_libdir}/%{name}/postgresql.so
+%{_datadir}/%{name}/postgresql_default.conf
+%endif
 
 %files powerdns
 %defattr(644,root,root,755)
@@ -1275,26 +1421,37 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/processes.conf
 %attr(755,root,root) %{_libdir}/%{name}/processes.so
 
+%files protocols
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/protocols.conf
+%attr(755,root,root) %{_libdir}/%{name}/protocols.so
+
+%if %{with rrd}
 %files rrdtool
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/rrdtool.conf
 %attr(755,root,root) %{_libdir}/%{name}/rrdtool.so
+%endif
 
+%if %{with sensors}
 %files sensors
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/sensors.conf
 %attr(755,root,root) %{_libdir}/%{name}/sensors.so
+%endif
 
 %files serial
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/serial.conf
 %attr(755,root,root) %{_libdir}/%{name}/serial.so
 
+%if %{with snmp}
 %files snmp
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/snmp.conf
 %attr(755,root,root) %{_libdir}/%{name}/snmp.so
 %{_mandir}/man5/collectd-snmp.5*
+%endif
 
 %files swap
 %defattr(644,root,root,755)
@@ -1306,6 +1463,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/syslog.conf
 %attr(755,root,root) %{_libdir}/%{name}/syslog.so
 
+%files table
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/table.conf
+%attr(755,root,root) %{_libdir}/%{name}/table.so
+
 %files tail
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/tail.conf
@@ -1336,6 +1498,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/teamspeak2.conf
 %attr(755,root,root) %{_libdir}/%{name}/teamspeak2.so
 
+%files ted
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ted.conf
+%attr(755,root,root) %{_libdir}/%{name}/ted.so
+
 %files thermal
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/thermal.conf
@@ -1347,6 +1514,11 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/unixsock.so
 %{_mandir}/man5/collectd-unixsock.5*
 
+%files uptime
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/uptime.conf
+%attr(755,root,root) %{_libdir}/%{name}/uptime.so
+
 %files users
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/users.conf
@@ -1372,7 +1544,9 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/wireless.conf
 %attr(755,root,root) %{_libdir}/%{name}/wireless.so
 
+%if %{with xmms}
 %files xmms
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/xmms.conf
 %attr(755,root,root) %{_libdir}/%{name}/xmms.so
+%endif
This page took 0.069766 seconds and 4 git commands to generate.