]> git.pld-linux.org Git - packages/collectd.git/blob - collectd.spec
- put modules configs into separate files and start using collectd.d dir
[packages/collectd.git] / collectd.spec
1 # TODO:
2 # - lm_sensors subpackage
3 # - package contrib scripts as %doc
4 # - put every plugin into subpackages
5 # - Current plugins status:
6 #    apache  . . . . . . yes
7 #    apcups  . . . . . . yes
8 #    apple_sensors . . . no             (obvious)
9 #    ascent  . . . . . . yes
10 #    battery . . . . . . yes
11 #    cpu . . . . . . . . yes
12 #    cpufreq . . . . . . yes
13 #    csv . . . . . . . . yes
14 #    df  . . . . . . . . yes
15 #    disk  . . . . . . . yes
16 #    dns . . . . . . . . yes
17 #    email . . . . . . . yes
18 #    entropy . . . . . . yes
19 #    exec  . . . . . . . yes
20 #    hddtemp . . . . . . yes
21 #    interface . . . . . yes
22 #    iptables  . . . . . yes
23 #    ipmi  . . . . . . . yes
24 #    ipvs  . . . . . . . no             (ip_vs.h not found - llh to be fixed)
25 #    irq . . . . . . . . yes
26 #    libvirt . . . . . . no             (requires library)
27 #    load  . . . . . . . yes
28 #    logfile . . . . . . yes
29 #    mbmon . . . . . . . yes
30 #    memcached . . . . . yes
31 #    memory  . . . . . . yes
32 #    multimeter  . . . . no
33 #    mysql . . . . . . . yes
34 #    netlink . . . . . . yes
35 #    network . . . . . . yes
36 #    nfs . . . . . . . . yes
37 #    nginx . . . . . . . yes
38 #    ntpd  . . . . . . . yes
39 #    nut . . . . . . . . yes
40 #    perl  . . . . . . . no             (needs libperl)
41 #    ping  . . . . . . . yes
42 #    powerdns  . . . . . yes
43 #    processes . . . . . yes
44 #    rrdtool . . . . . . yes
45 #    sensors . . . . . . yes
46 #    serial  . . . . . . yes
47 #    snmp  . . . . . . . yes
48 #    swap  . . . . . . . yes
49 #    syslog  . . . . . . yes
50 #    tail  . . . . . . . yes
51 #    tape  . . . . . . . no             ?
52 #    tcpconns  . . . . . yes
53 #    teamspeak2  . . . . yes
54 #    unixsock  . . . . . yes
55 #    users . . . . . . . yes
56 #    uuid  . . . . . . . yes
57 #    vmem  . . . . . . . yes
58 #    vserver . . . . . . yes
59 #    wireless  . . . . . yes
60 #    xmms  . . . . . . . yes
61 #
62 # Conditional build:
63 %bcond_without  dns             # ???
64 %bcond_without  ipmi            # ipmi plugin package
65 %bcond_without  iptables        # iptables plugin
66 %bcond_with     multimeter      # multimeter plugin
67 %bcond_without  netlink         # netlink plugin
68 #
69 #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358637
70 %ifarch %{x8664}
71 %undefine with_iptables
72 %undefine with_netlink
73 %endif
74 Summary:        Collects system information in RRD files
75 Summary(pl.UTF-8):      Zbieranie informacji o systemie w plikach RRD
76 Name:           collectd
77 Version:        4.5.0
78 Release:        5.1
79 License:        GPL v2
80 Group:          Daemons
81 Source0:        http://collectd.org/files/%{name}-%{version}.tar.gz
82 # Source0-md5:  f73dbadc8dca136b98c0f96567e0f78c
83 Source1:        %{name}.conf
84 Source2:        %{name}.init
85 Source3:        %{name}-http.conf
86 Source10:       %{name}-ascent.conf
87 Source11:       %{name}-apache.conf
88 Source12:       %{name}-dns.conf
89 Source13:       %{name}-hddtemp.conf
90 Source14:       %{name}-ipmi.conf
91 Source15:       %{name}-mysql.conf
92 Source16:       %{name}-nginx.conf
93 Source17:       %{name}-notify_desktop.conf
94 Source18:       %{name}-notify_email.conf
95 Source19:       %{name}-nut.conf
96 Source20:       %{name}-ping.conf
97 Source21:       %{name}-postgresql.conf
98 Source22:       %{name}-powerdns.conf
99 Source23:       %{name}-rrdtool.conf
100 Source24:       %{name}-sensors.conf
101 Source25:       %{name}-snmp.conf
102 Source26:       %{name}-uuid.conf
103 Source27:       %{name}-xmms.conf
104 URL:            http://collectd.org/
105 BuildRequires:  OpenIPMI-devel
106 BuildRequires:  autoconf
107 BuildRequires:  automake
108 BuildRequires:  curl-devel
109 BuildRequires:  iptables-devel >= 1.4.1.1-4
110 BuildRequires:  libesmtp-devel
111 BuildRequires:  libnetlink-devel
112 BuildRequires:  libnotify-devel
113 BuildRequires:  liboping-devel
114 BuildRequires:  libpcap-devel
115 BuildRequires:  libstatgrab-devel >= 0.12
116 BuildRequires:  libtool
117 BuildRequires:  lm_sensors-devel
118 BuildRequires:  mysql-devel
119 BuildRequires:  nut-devel
120 BuildRequires:  perl-devel
121 BuildRequires:  rpmbuild(macros) >= 1.268
122 BuildRequires:  rrdtool-devel
123 BuildRequires:  net-snmp-devel
124 BuildRequires:  xmms-devel
125 Requires(post,preun):   /sbin/chkconfig
126 Requires:       rc-scripts
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %define         _pkglibdir      /var/lib/%{name}
130 %define         _webapps        /etc/webapps 
131 %define         _webapp         %{name}
132 %define         _webappdir      %{_webapps}/%{_webapp}
133 %define         _appdir         %{_datadir}/%{_webapp}
134
135 %description
136 collectd is a small daemon which collects system information every 10
137 seconds and writes the results in an RRD-file.
138
139 In contrast to most similar software, collectd is not a script but
140 written in plain C for performance and portability. As a daemon it
141 stays in memory, so there is no need to start up a heavy interpreter
142 every time new values should be logged. This allows collectd to have a
143 10 second resolution while being nice to the system.
144
145 %description -l pl.UTF-8
146 collectd to mały demon zbierający co 10 sekund informacje o systemie i
147 zapisujący wyniki do pliku RRD.
148
149 W odróżnieniu od innych podobnych programów collectd nie jest
150 skryptem, lecz jest napisany w czystym C z myślą o wydajności i
151 przenośności. Jako demon pozostaje w pamięci, więc nie ma potrzeby
152 urychamiania ciężkiego interpretera za każdym razem, kiedy powinny być
153 zapisane nowe wartości. Dzięki temu collect może mieć rozdzielczość 10
154 sekund i nie obciążać zbytnio systemu.
155
156 %package ascent
157 Summary:        ascent-plugin for collectd
158 Summary(pl_PL.UTF-8):   Wtyczka ascent dla collectd
159 Group:          Daemons
160 Requires:       %{name} = %{version}-%{release}
161
162 %description ascent
163 ascent plugin for collectd.
164
165 %package apache
166 Summary:        apache-plugin for collectd
167 Summary(pl_PL.UTF-8):   Wtyczka apache dla collectd
168 Group:          Daemons
169 Requires:       %{name} = %{version}-%{release}
170
171 %description apache
172 This plugin collectd data provided by Apache's `mod_status'.
173
174 %description apache -l pl.UTF-8
175 Wtyczka collectd zbierająca informacje udostępniane przez moduł
176 'mod_status' Apacha.
177
178 %package collection
179 Summary:        Web script for collectiond
180 Summary(pl_PL.UTF-8):   Web script for collectiond
181 Group:          Applications/WWW
182 Requires:       %{name} = %{version}-%{release}
183
184 %description collection
185 Web script for collectiond
186
187 %package dns
188 Summary:        dns-plugin for collectd
189 Summary(pl_PL.UTF-8):   Wtyczka dns dla collectd
190 Group:          Daemons
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       perl-rrdtool
193
194 %description dns
195 dns plugin for collectd.
196
197 %package hddtemp
198 Summary:        hddtemp-plugin for collectd
199 Summary(pl_PL.UTF-8):   Wtyczka hddtemp dla collectd
200 Group:          Daemons
201 Requires:       %{name} = %{version}-%{release}
202
203 %description hddtemp
204 hddtemp plugin for collectd.
205
206 %package ipmi
207 Summary:        ipmi-plugin for collectd
208 Summary(pl_PL.UTF-8):   Wtyczka ipmi dla collectd
209 Group:          Daemons
210 Requires:       %{name} = %{version}-%{release}
211
212 %description ipmi
213 ipmi plugin for collectd.
214
215 %description ipmi -l pl.UTF-8
216 Wtyczka ipmi dla collectd.
217
218 %package mysql
219 Summary:        mysql-plugin for collectd
220 Summary(pl_PL.UTF-8):   Moduł mysql dla collectd.
221 Group:          Daemons
222 Requires:       %{name} = %{version}-%{release}
223
224 %description mysql
225 MySQL querying plugin. This plugins provides data of issued commands,
226 called handlers and database traffic.
227
228 %description mysql -l pl.UTF-8
229 Moduł odpytujący MySQL. Wtyczka udostępnia dane o wydawanych
230 poleceniach, wywoływanych procedurach obsługi i ruchu bazodanowym.
231
232 %package nginx
233 Summary:        nginx-plugin for collectd
234 Summary(pl_PL.UTF-8):   Wtyczka nginx dla collectd
235 Group:          Daemons
236 Requires:       %{name} = %{version}-%{release}
237
238 %description nginx
239 nginx plugin for collectd.
240
241 %package notify_desktop
242 Summary:        notify_desktop for collectd
243 Summary(pl_PL.UTF-8):   Wtyczka notify_desktop dla collectd
244 Group:          Daemons
245 Requires:       %{name} = %{version}-%{release}
246
247 %description notify_desktop
248 notify_desktop plugin for collectd.
249
250 %package notify_email
251 Summary:        notify_email for collectd
252 Summary(pl_PL.UTF-8):   Wtyczka notify_email dla collectd
253 Group:          Daemons
254 Requires:       %{name} = %{version}-%{release}
255
256 %description notify_email
257 notify_email plugin for collectd.
258
259 %package nut
260 Summary:        nut-plugin for collectd
261 Summary(pl_PL.UTF-8):   Wtyczka nut dla collectd
262 Group:          Daemons
263 Requires:       %{name} = %{version}-%{release}
264
265 %description nut
266 nut plugin for collectd.
267
268 %package ping
269 Summary:        ping-plugin for collectd
270 Summary(pl_PL.UTF-8):   Wtyczka ping dla collectd
271 Group:          Daemons
272 Requires:       %{name} = %{version}-%{release}
273
274 %description ping
275 ping plugin for collectd.
276
277 %package postgresql
278 Summary:        mysql-plugin for collectd
279 Summary(pl_PL.UTF-8):   Moduł postgresql dla collectd.
280 Group:          Daemons
281 Requires:       %{name} = %{version}-%{release}
282
283 %description postgresql
284 PostgreSQL querying plugin. This plugins provides data of issued commands,
285 called handlers and database traffic.
286
287 %description postgresql -l pl.UTF-8
288 Moduł odpytujący PostgreSQL. Wtyczka udostępnia dane o wydawanych
289 poleceniach, wywoływanych procedurach obsługi i ruchu bazodanowym.
290
291 %package powerdns
292 Summary:        powerdns-plugin for collectd
293 Summary(pl_PL.UTF-8):   Wtyczka powerdns dla collectd
294 Group:          Daemons
295 Requires:       %{name} = %{version}-%{release}
296
297 %description powerdns
298 powerdns plugin for collectd.
299
300 %package rrdtool
301 Summary:        rrdtool-plugin for collectd
302 Summary(pl_PL.UTF-8):   Wtyczka rrdtool dla collectd
303 Group:          Daemons
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       rrdtool
306
307 %description rrdtool
308 RRDTOOL plugin for collectd.
309
310 %package sensors
311 Summary:        sensors-plugin for collectd
312 Summary(pl_PL.UTF-8):   Wtyczka sensors dla collectd
313 Group:          Daemons
314 Requires:       %{name} = %{version}-%{release}
315
316 %description sensors
317 This plugin collectd data provided by hardware sensors.
318
319 %package snmp
320 Summary:        snmp-plugin for collectd
321 Summary(pl_PL.UTF-8):   Wtyczka snmp dla collectd
322 Group:          Daemons
323 Requires:       %{name} = %{version}-%{release}
324
325 %description snmp
326 snmp plugin for collectd.
327
328 %package uuid
329 Summary:        uuid-plugin for collectd
330 Summary(pl_PL.UTF-8):   Wtyczka uuid dla collectd
331 Group:          Daemons
332 Requires:       %{name} = %{version}-%{release}
333
334 %description uuid
335 This plugin collectd UUID data.
336
337 %package xmms
338 Summary:        xmms-plugin for collectd
339 Summary(pl_PL.UTF-8):   Wtyczka xmms dla collectd
340 Group:          Daemons
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       xmms-libs
343
344 %description xmms
345 This plugin collectd data provided by XMMS.
346
347 %prep
348 %setup -q
349
350 cat >> collection.conf <<'EOF'
351 datadir: "/var/lib/collectd/"
352 libdir: "/usr/lib/collectd/"
353 EOF
354
355 %build
356 %{__libtoolize}
357 %{__aclocal}
358 %{__autoconf}
359 %{__autoheader}
360 %{__automake}
361
362 %configure \
363         --with-libstatgrab=/usr \
364         --with-lm-sensors=/usr \
365         --with-libmysql=/usr \
366         --%{?with_ipmi:en}%{!?with_ipmi:dis}able-ipmi \
367         --%{?with_multimeter:en}%{!?with_multimeter:dis}able-multimeter \
368         --%{?with_dns:en}%{!?with_dns:dis}able-dns \
369         --%{?with_iptables:en}%{!?with_iptables:dis}able-iptables \
370         --%{?with_netlink:en}%{!?with_netlink:dis}able-netlink \
371         --disable-ipvs
372
373
374 %{__make} LDFLAGS="%{rpmldflags} -lstatgrab" \
375         BUILD_WITH_OPENIPMI_CFLAGS="-I/usr/include" \
376         BUILD_WITH_OPENIPMI_LIBS="-L/usr/lib64 -lOpenIPMIutils -lOpenIPMIpthread"
377
378 %install
379 rm -rf $RPM_BUILD_ROOT
380 install -d $RPM_BUILD_ROOT{%{_var}/{log/,lib/%{name}},/etc/{rc.d/init.d/,collectd.d}} \
381         $RPM_BUILD_ROOT{%{_appdir}/cgi-bin,%{_webappdir},%{_pkglibdir}}
382
383 %{__make} install \
384         DESTDIR=$RPM_BUILD_ROOT
385
386 touch $RPM_BUILD_ROOT%{_var}/log/collectd.log
387 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
388
389 # Web frontend:
390 install contrib/collection.conf $RPM_BUILD_ROOT%{_webappdir}
391 install contrib/collection.cgi $RPM_BUILD_ROOT%{_appdir}/cgi-bin
392 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
393 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
394
395 ### Configs instalation ###
396 # Example config in sources: src/collectd.conf
397 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
398 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/ascent.conf
399 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/apache.conf
400 install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/dns.conf
401 install %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/hddtemp.conf
402 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/ipmi.conf
403 install %{SOURCE15} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/mysql.conf
404 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/nginx.conf
405 install %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/notify_desktop.conf
406 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/notify_email.conf
407 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/nut.conf
408 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/ping.conf
409 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/postgresql.conf
410 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/powerdns.conf
411 install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/rrdtool.conf
412 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/sensors.conf
413 install %{SOURCE25} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/snmp.conf
414 install %{SOURCE26} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/uuid.conf
415 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.d/xmms.conf
416
417 # Cleanups:
418 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
419
420 %clean
421 rm -rf $RPM_BUILD_ROOT
422
423 %post
424 /sbin/chkconfig --add %{name}
425 %service %{name} restart
426
427 %preun
428 if [ "$1" = "0" ]; then
429         %service -q %{name} stop
430         /sbin/chkconfig --del %{name}
431 fi
432
433 %triggerin collection -- apache1 < 1.3.37-3, apache1-base
434 %webapp_register apache %{_webapp}
435
436 %triggerun collection -- apache1 < 1.3.37-3, apache1-base
437 %webapp_unregister apache %{_webapp}
438
439 %triggerin collection -- apache < 2.2.0, apache-base
440 %webapp_register httpd %{_webapp}
441
442 %triggerun collection -- apache < 2.2.0, apache-base
443 %webapp_unregister httpd %{_webapp}
444
445 %files
446 %defattr(644,root,root,755)
447 %doc AUTHORS ChangeLog README TODO contrib
448
449 %attr(755,root,root) %{_sbindir}/collectd
450 %attr(755,root,root) %{_sbindir}/collectdmon
451 %attr(755,root,root) %{_bindir}/collectd-nagios
452 %dir %{_libdir}/%{name}
453 %attr(755,root,root) %{_libdir}/%{name}/apcups.so
454 #%attr(755,root,root) %{_libdir}/%{name}/apple_sensors.so
455 %attr(755,root,root) %{_libdir}/%{name}/battery.so
456 %attr(755,root,root) %{_libdir}/%{name}/cpufreq.so
457 %attr(755,root,root) %{_libdir}/%{name}/cpu.so
458 %attr(755,root,root) %{_libdir}/%{name}/csv.so
459 %attr(755,root,root) %{_libdir}/%{name}/df.so
460 %attr(755,root,root) %{_libdir}/%{name}/disk.so
461 %attr(755,root,root) %{_libdir}/%{name}/email.so
462 %attr(755,root,root) %{_libdir}/%{name}/entropy.so
463 %attr(755,root,root) %{_libdir}/%{name}/exec.so
464 %attr(755,root,root) %{_libdir}/%{name}/filecount.so
465 %attr(755,root,root) %{_libdir}/%{name}/interface.so
466 %if %{with iptables}
467 %attr(755,root,root) %{_libdir}/%{name}/iptables.so
468 %endif
469 # Disabled - requires fixed libc-headers or whole kernel source.
470 # It was marked as disabled in status message on top.
471 #%attr(755,root,root) %{_libdir}/%{name}/ipvs.so
472 %attr(755,root,root) %{_libdir}/%{name}/irq.so
473 %attr(755,root,root) %{_libdir}/%{name}/load.so
474 %attr(755,root,root) %{_libdir}/%{name}/logfile.so
475 %attr(755,root,root) %{_libdir}/%{name}/mbmon.so
476 %attr(755,root,root) %{_libdir}/%{name}/memcached.so
477 %attr(755,root,root) %{_libdir}/%{name}/memory.so
478 %if %{with multimeter}
479 %attr(755,root,root) %{_libdir}/%{name}/multimeter.so
480 %endif
481 %if %{with netlink}
482 %attr(755,root,root) %{_libdir}/%{name}/netlink.so
483 %endif
484 %attr(755,root,root) %{_libdir}/%{name}/network.so
485 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
486 %attr(755,root,root) %{_libdir}/%{name}/ntpd.so
487 #%attr(755,root,root) %{_libdir}/%{name}/perl.so
488 %attr(755,root,root) %{_libdir}/%{name}/processes.so
489 %attr(755,root,root) %{_libdir}/%{name}/serial.so
490 %attr(755,root,root) %{_libdir}/%{name}/swap.so
491 %attr(755,root,root) %{_libdir}/%{name}/syslog.so
492 %attr(755,root,root) %{_libdir}/%{name}/tail.so
493 #%attr(755,root,root) %{_libdir}/%{name}/tape.so
494 %attr(755,root,root) %{_libdir}/%{name}/teamspeak2.so
495 %attr(755,root,root) %{_libdir}/%{name}/tcpconns.so
496 %attr(755,root,root) %{_libdir}/%{name}/thermal.so
497 #%attr(755,root,root) %{_libdir}/%{name}/traffic.so
498 %attr(755,root,root) %{_libdir}/%{name}/unixsock.so
499 %attr(755,root,root) %{_libdir}/%{name}/users.so
500 %attr(755,root,root) %{_libdir}/%{name}/vmem.so
501 %attr(755,root,root) %{_libdir}/%{name}/vserver.so
502 %attr(755,root,root) %{_libdir}/%{name}/wireless.so
503 %{_libdir}/%{name}/types.db
504
505 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
506 %dir %{_sysconfdir}/%{name}.d
507
508 %attr(754,root,root) /etc/rc.d/init.d/%{name}
509
510 %{_mandir}/man1/collectd.1*
511 %{_mandir}/man1/collectd-nagios.1*
512 %{_mandir}/man5/collectd.conf.5*
513 %{_mandir}/man5/collectd-email.5*
514 %{_mandir}/man5/collectd-exec.5*
515 %{_mandir}/man5/collectd-perl.5*
516 %{_mandir}/man5/collectd-snmp.5*
517 %{_mandir}/man5/collectd-unixsock.5*
518 %{_mandir}/man1/collectdmon.1*
519 %{_mandir}/man5/types.db.5*
520 %{_var}/log/collectd.log
521 %dir %{_var}/lib/%{name}
522
523 ########## PLUGINS:
524 %files ascent
525 %defattr(644,root,root,755)
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ascent.conf
527 %attr(755,root,root) %{_libdir}/%{name}/ascent.so
528
529 %files apache
530 %defattr(644,root,root,755)
531 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/apache.conf
532 %attr(755,root,root) %{_libdir}/%{name}/apache.so
533
534 %files collection
535 %defattr(644,root,root,755)
536 %dir %{_webappdir}
537 %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/collection.conf
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
540 %dir %{_appdir}
541 %dir %{_appdir}/cgi-bin
542 %attr(755,root,root) %{_appdir}/cgi-bin/collection.cgi
543
544 %files dns
545 %defattr(644,root,root,755)
546 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/dns.conf
547 %attr(755,root,root) %{_libdir}/%{name}/dns.so
548
549 %files hddtemp
550 %defattr(644,root,root,755)
551 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/hddtemp.conf
552 %attr(755,root,root) %{_libdir}/%{name}/hddtemp.so
553
554 %if %{with ipmi}
555 %files ipmi
556 %defattr(644,root,root,755)
557 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ipmi.conf
558 %attr(755,root,root) %{_libdir}/%{name}/ipmi.so
559 %endif
560
561 %files mysql
562 %defattr(644,root,root,755)
563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/mysql.conf
564 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
565
566 %files nginx
567 %defattr(644,root,root,755)
568 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/nginx.conf
569 %attr(755,root,root) %{_libdir}/%{name}/nginx.so
570
571 %files notify_desktop
572 %defattr(644,root,root,755)
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/notify_desktop.conf
574 %attr(755,root,root) %{_libdir}/%{name}/notify_desktop.so
575
576 %files notify_email
577 %defattr(644,root,root,755)
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/notify_email.conf
579 %attr(755,root,root) %{_libdir}/%{name}/notify_email.so
580
581 %files nut
582 %defattr(644,root,root,755)
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/nut.conf
584 %attr(755,root,root) %{_libdir}/%{name}/nut.so
585
586 %files ping
587 %defattr(644,root,root,755)
588 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/ping.conf
589 %attr(755,root,root) %{_libdir}/%{name}/ping.so
590
591 %files postgresql
592 %defattr(644,root,root,755)
593 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/postgresql.conf
594 %attr(755,root,root) %{_libdir}/%{name}/postgresql.so
595
596 %files powerdns
597 %defattr(644,root,root,755)
598 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/powerdns.conf
599 %attr(755,root,root) %{_libdir}/%{name}/powerdns.so
600
601 %files rrdtool
602 %defattr(644,root,root,755)
603 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/rrdtool.conf
604 %attr(755,root,root) %{_libdir}/%{name}/rrdtool.so
605
606 %files sensors
607 %defattr(644,root,root,755)
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/sensors.conf
609 %attr(755,root,root) %{_libdir}/%{name}/sensors.so
610
611 %files snmp
612 %defattr(644,root,root,755)
613 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/snmp.conf
614 %attr(755,root,root) %{_libdir}/%{name}/snmp.so
615
616 %files uuid
617 %defattr(644,root,root,755)
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/uuid.conf
619 %attr(755,root,root) %{_libdir}/%{name}/uuid.so
620
621 %files xmms
622 %defattr(644,root,root,755)
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.d/xmms.conf
624 %attr(755,root,root) %{_libdir}/%{name}/xmms.so
This page took 0.080717 seconds and 4 git commands to generate.