]> git.pld-linux.org Git - packages/collectd.git/blob - collectd.spec
e7e6a125776165f35d5df25bc90aeff64837c717
[packages/collectd.git] / collectd.spec
1 # TODO:
2 # - lm_sensors subpackage
3 # - package contrib scripts as %doc
4 # - put every plugin into subpackages
5 # - Current plugins status:
6 #    apache  . . . . . . yes
7 #    apcups  . . . . . . yes
8 #    apple_sensors . . . no             (obvious)
9 #    ascent  . . . . . . yes
10 #    battery . . . . . . yes
11 #    cpu . . . . . . . . yes
12 #    cpufreq . . . . . . yes
13 #    csv . . . . . . . . yes
14 #    df  . . . . . . . . yes
15 #    disk  . . . . . . . yes
16 #    dns . . . . . . . . yes
17 #    email . . . . . . . yes
18 #    entropy . . . . . . yes
19 #    exec  . . . . . . . yes
20 #    hddtemp . . . . . . yes
21 #    interface . . . . . yes
22 #    iptables  . . . . . yes
23 #    ipmi  . . . . . . . yes
24 #    ipvs  . . . . . . . no             (ip_vs.h not found - llh to be fixed)
25 #    irq . . . . . . . . yes
26 #    libvirt . . . . . . no             (requires library)
27 #    load  . . . . . . . yes
28 #    logfile . . . . . . yes
29 #    mbmon . . . . . . . yes
30 #    memcached . . . . . yes
31 #    memory  . . . . . . yes
32 #    multimeter  . . . . no
33 #    mysql . . . . . . . yes
34 #    netlink . . . . . . yes
35 #    network . . . . . . yes
36 #    nfs . . . . . . . . yes
37 #    nginx . . . . . . . yes
38 #    ntpd  . . . . . . . yes
39 #    nut . . . . . . . . yes
40 #    perl  . . . . . . . no             (needs libperl)
41 #    ping  . . . . . . . yes
42 #    powerdns  . . . . . yes
43 #    processes . . . . . yes
44 #    rrdtool . . . . . . yes
45 #    sensors . . . . . . yes
46 #    serial  . . . . . . yes
47 #    snmp  . . . . . . . yes
48 #    swap  . . . . . . . yes
49 #    syslog  . . . . . . yes
50 #    tail  . . . . . . . yes
51 #    tape  . . . . . . . no             ?
52 #    tcpconns  . . . . . yes
53 #    teamspeak2  . . . . yes
54 #    unixsock  . . . . . yes
55 #    users . . . . . . . yes
56 #    uuid  . . . . . . . yes
57 #    vmem  . . . . . . . yes
58 #    vserver . . . . . . yes
59 #    wireless  . . . . . yes
60 #    xmms  . . . . . . . yes
61 #
62 # Conditional build:
63 %bcond_without  dns             # ???
64 %bcond_without  ipmi            # ipmi plugin package
65 %bcond_without  iptables        # iptables plugin
66 %bcond_with     multimeter      # multimeter plugin
67 %bcond_without  netlink         # netlink plugin
68 #
69 #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358637
70 %ifarch %{x8664}
71 %undefine with_iptables
72 %undefine with_netlink
73 %endif
74 Summary:        Collects system information in RRD files
75 Summary(pl.UTF-8):      Zbieranie informacji o systemie w plikach RRD
76 Name:           collectd
77 Version:        4.5.0
78 Release:        4
79 License:        GPL v2
80 Group:          Daemons
81 Source0:        http://collectd.org/files/%{name}-%{version}.tar.gz
82 # Source0-md5:  f73dbadc8dca136b98c0f96567e0f78c
83 Source1:        %{name}.conf
84 Source2:        %{name}.init
85 Source3:        %{name}-http.conf
86 URL:            http://collectd.org/
87 BuildRequires:  OpenIPMI-devel
88 BuildRequires:  autoconf
89 BuildRequires:  automake
90 BuildRequires:  curl-devel
91 BuildRequires:  iptables-devel >= 1.4.1.1-4
92 BuildRequires:  libesmtp-devel
93 BuildRequires:  libnetlink-devel
94 BuildRequires:  libnotify-devel
95 BuildRequires:  liboping-devel
96 BuildRequires:  libpcap-devel
97 BuildRequires:  libstatgrab-devel >= 0.12
98 BuildRequires:  libtool
99 BuildRequires:  lm_sensors-devel
100 BuildRequires:  mysql-devel
101 BuildRequires:  nut-devel
102 BuildRequires:  perl-devel
103 BuildRequires:  rpmbuild(macros) >= 1.268
104 BuildRequires:  rrdtool-devel
105 BuildRequires:  net-snmp-devel
106 BuildRequires:  xmms-devel
107 Requires(post,preun):   /sbin/chkconfig
108 Requires:       rc-scripts
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _pkglibdir      /var/lib/%{name}
112 %define         _webapps        /etc/webapps 
113 %define         _webapp         %{name}
114 %define         _webappdir      %{_webapps}/%{_webapp}
115 %define         _appdir         %{_datadir}/%{_webapp}
116
117 %description
118 collectd is a small daemon which collects system information every 10
119 seconds and writes the results in an RRD-file.
120
121 In contrast to most similar software, collectd is not a script but
122 written in plain C for performance and portability. As a daemon it
123 stays in memory, so there is no need to start up a heavy interpreter
124 every time new values should be logged. This allows collectd to have a
125 10 second resolution while being nice to the system.
126
127 %description -l pl.UTF-8
128 collectd to mały demon zbierający co 10 sekund informacje o systemie i
129 zapisujący wyniki do pliku RRD.
130
131 W odróżnieniu od innych podobnych programów collectd nie jest
132 skryptem, lecz jest napisany w czystym C z myślą o wydajności i
133 przenośności. Jako demon pozostaje w pamięci, więc nie ma potrzeby
134 urychamiania ciężkiego interpretera za każdym razem, kiedy powinny być
135 zapisane nowe wartości. Dzięki temu collect może mieć rozdzielczość 10
136 sekund i nie obciążać zbytnio systemu.
137
138 %package ascent
139 Summary:        ascent-plugin for collectd
140 Summary(pl_PL.UTF-8):   Wtyczka ascent dla collectd
141 Group:          Daemons
142 Requires:       %{name} = %{version}-%{release}
143
144 %description ascent
145 ascent plugin for collectd.
146
147 %package apache
148 Summary:        apache-plugin for collectd
149 Summary(pl_PL.UTF-8):   Wtyczka apache dla collectd
150 Group:          Daemons
151 Requires:       %{name} = %{version}-%{release}
152
153 %description apache
154 This plugin collectd data provided by Apache's `mod_status'.
155
156 %description apache -l pl.UTF-8
157 Wtyczka collectd zbierająca informacje udostępniane przez moduł
158 'mod_status' Apacha.
159
160 %package collection
161 Summary:        Web script for collectiond
162 Summary(pl_PL.UTF-8):   Web script for collectiond
163 Group:          Applications/WWW
164 Requires:       %{name} = %{version}-%{release}
165
166 %description collection
167 Web script for collectiond
168
169 %package dns
170 Summary:        dns-plugin for collectd
171 Summary(pl_PL.UTF-8):   Wtyczka dns dla collectd
172 Group:          Daemons
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       perl-rrdtool
175
176 %description dns
177 dns plugin for collectd.
178
179 %package hddtemp
180 Summary:        hddtemp-plugin for collectd
181 Summary(pl_PL.UTF-8):   Wtyczka hddtemp dla collectd
182 Group:          Daemons
183 Requires:       %{name} = %{version}-%{release}
184
185 %description hddtemp
186 hddtemp plugin for collectd.
187
188 %package ipmi
189 Summary:        ipmi-plugin for collectd
190 Summary(pl_PL.UTF-8):   Wtyczka ipmi dla collectd
191 Group:          Daemons
192 Requires:       %{name} = %{version}-%{release}
193
194 %description ipmi
195 ipmi plugin for collectd.
196
197 %description ipmi -l pl.UTF-8
198 Wtyczka ipmi dla collectd.
199
200 %package mysql
201 Summary:        mysql-plugin for collectd
202 Summary(pl_PL.UTF-8):   Moduł mysql dla collectd.
203 Group:          Daemons
204 Requires:       %{name} = %{version}-%{release}
205
206 %description mysql
207 MySQL querying plugin. This plugins provides data of issued commands,
208 called handlers and database traffic.
209
210 %description mysql -l pl.UTF-8
211 Moduł odpytujący MySQL. Wtyczka udostępnia dane o wydawanych
212 poleceniach, wywoływanych procedurach obsługi i ruchu bazodanowym.
213
214 %package nginx
215 Summary:        nginx-plugin for collectd
216 Summary(pl_PL.UTF-8):   Wtyczka nginx dla collectd
217 Group:          Daemons
218 Requires:       %{name} = %{version}-%{release}
219
220 %description nginx
221 nginx plugin for collectd.
222
223 %package notify_desktop
224 Summary:        notify_desktop for collectd
225 Summary(pl_PL.UTF-8):   Wtyczka notify_desktop dla collectd
226 Group:          Daemons
227 Requires:       %{name} = %{version}-%{release}
228
229 %description notify_desktop
230 notify_desktop plugin for collectd.
231
232 %package ping
233 Summary:        ping-plugin for collectd
234 Summary(pl_PL.UTF-8):   Wtyczka ping dla collectd
235 Group:          Daemons
236 Requires:       %{name} = %{version}-%{release}
237
238 %description ping
239 ping plugin for collectd.
240
241 %package powerdns
242 Summary:        powerdns-plugin for collectd
243 Summary(pl_PL.UTF-8):   Wtyczka powerdns dla collectd
244 Group:          Daemons
245 Requires:       %{name} = %{version}-%{release}
246
247 %description powerdns
248 powerdns plugin for collectd.
249
250 %package rrdtool
251 Summary:        rrdtool-plugin for collectd
252 Summary(pl_PL.UTF-8):   Wtyczka rrdtool dla collectd
253 Group:          Daemons
254 Requires:       %{name} = %{version}-%{release}
255 Requires:       rrdtool
256
257 %description rrdtool
258 RRDTOOL plugin for collectd.
259
260 %package sensors
261 Summary:        sensors-plugin for collectd
262 Summary(pl_PL.UTF-8):   Wtyczka sensors dla collectd
263 Group:          Daemons
264 Requires:       %{name} = %{version}-%{release}
265
266 %description sensors
267 This plugin collectd data provided by hardware sensors.
268
269 %package snmp
270 Summary:        snmp-plugin for collectd
271 Summary(pl_PL.UTF-8):   Wtyczka snmp dla collectd
272 Group:          Daemons
273 Requires:       %{name} = %{version}-%{release}
274
275 %description snmp
276 snmp plugin for collectd.
277
278 %package uuid
279 Summary:        uuid-plugin for collectd
280 Summary(pl_PL.UTF-8):   Wtyczka uuid dla collectd
281 Group:          Daemons
282 Requires:       %{name} = %{version}-%{release}
283
284 %description uuid
285 This plugin collectd UUID data.
286
287 %package xmms
288 Summary:        xmms-plugin for collectd
289 Summary(pl_PL.UTF-8):   Wtyczka xmms dla collectd
290 Group:          Daemons
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       xmms-libs
293
294 %description xmms
295 This plugin collectd data provided by XMMS.
296
297 %prep
298 %setup -q
299
300 cat >> collection.conf <<'EOF'
301 datadir: "/var/lib/collectd/"
302 libdir: "/usr/lib/collectd/"
303 EOF
304
305 %build
306 %{__libtoolize}
307 %{__aclocal}
308 %{__autoconf}
309 %{__autoheader}
310 %{__automake}
311
312 %configure \
313         --with-libstatgrab=/usr \
314         --with-lm-sensors=/usr \
315         --with-libmysql=/usr \
316         --%{?with_ipmi:en}%{!?with_ipmi:dis}able-ipmi \
317         --%{?with_multimeter:en}%{!?with_multimeter:dis}able-multimeter \
318         --%{?with_dns:en}%{!?with_dns:dis}able-dns \
319         --%{?with_iptables:en}%{!?with_iptables:dis}able-iptables \
320         --%{?with_netlink:en}%{!?with_netlink:dis}able-netlink \
321         --disable-ipvs
322
323
324 %{__make} LDFLAGS="%{rpmldflags} -lstatgrab" \
325         BUILD_WITH_OPENIPMI_CFLAGS="-I/usr/include" \
326         BUILD_WITH_OPENIPMI_LIBS="-L/usr/lib64 -lOpenIPMIutils -lOpenIPMIpthread"
327
328 %install
329 rm -rf $RPM_BUILD_ROOT
330 install -d $RPM_BUILD_ROOT{%{_var}/{log/,lib/%{name}},/etc/rc.d/init.d/} \
331         $RPM_BUILD_ROOT{%{_appdir}/cgi-bin,%{_webappdir},%{_pkglibdir}}
332
333 %{__make} install \
334         DESTDIR=$RPM_BUILD_ROOT
335
336 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
337 touch $RPM_BUILD_ROOT%{_var}/log/collectd.log
338 install src/collectd.conf $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
339 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
340
341 # Web frontend:
342 install contrib/collection.conf $RPM_BUILD_ROOT%{_webappdir}
343 install contrib/collection.cgi $RPM_BUILD_ROOT%{_appdir}/cgi-bin
344 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
345 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
346
347 # Cleanups:
348 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
349
350 %clean
351 rm -rf $RPM_BUILD_ROOT
352
353 %post
354 /sbin/chkconfig --add %{name}
355 %service %{name} restart
356
357 %preun
358 if [ "$1" = "0" ]; then
359         %service -q %{name} stop
360         /sbin/chkconfig --del %{name}
361 fi
362
363 %triggerin collection -- apache1 < 1.3.37-3, apache1-base
364 %webapp_register apache %{_webapp}
365
366 %triggerun collection -- apache1 < 1.3.37-3, apache1-base
367 %webapp_unregister apache %{_webapp}
368
369 %triggerin collection -- apache < 2.2.0, apache-base
370 %webapp_register httpd %{_webapp}
371
372 %triggerun collection -- apache < 2.2.0, apache-base
373 %webapp_unregister httpd %{_webapp}
374
375 %files
376 %defattr(644,root,root,755)
377 %doc AUTHORS ChangeLog README TODO contrib
378
379 %attr(755,root,root) %{_sbindir}/collectd
380 %attr(755,root,root) %{_sbindir}/collectdmon
381 %attr(755,root,root) %{_bindir}/collectd-nagios
382 %dir %{_libdir}/%{name}
383 %attr(755,root,root) %{_libdir}/%{name}/apcups.so
384 #%attr(755,root,root) %{_libdir}/%{name}/apple_sensors.so
385 %attr(755,root,root) %{_libdir}/%{name}/battery.so
386 %attr(755,root,root) %{_libdir}/%{name}/cpufreq.so
387 %attr(755,root,root) %{_libdir}/%{name}/cpu.so
388 %attr(755,root,root) %{_libdir}/%{name}/csv.so
389 %attr(755,root,root) %{_libdir}/%{name}/df.so
390 %attr(755,root,root) %{_libdir}/%{name}/disk.so
391 %attr(755,root,root) %{_libdir}/%{name}/email.so
392 %attr(755,root,root) %{_libdir}/%{name}/entropy.so
393 %attr(755,root,root) %{_libdir}/%{name}/exec.so
394 %attr(755,root,root) %{_libdir}/%{name}/filecount.so
395 %attr(755,root,root) %{_libdir}/%{name}/interface.so
396 %if %{with iptables}
397 %attr(755,root,root) %{_libdir}/%{name}/iptables.so
398 %endif
399 # Disabled - requires fixed libc-headers or whole kernel source.
400 # It was marked as disabled in status message on top.
401 #%attr(755,root,root) %{_libdir}/%{name}/ipvs.so
402 %attr(755,root,root) %{_libdir}/%{name}/irq.so
403 %attr(755,root,root) %{_libdir}/%{name}/load.so
404 %attr(755,root,root) %{_libdir}/%{name}/logfile.so
405 %attr(755,root,root) %{_libdir}/%{name}/mbmon.so
406 %attr(755,root,root) %{_libdir}/%{name}/notify_email.so
407 %attr(755,root,root) %{_libdir}/%{name}/memcached.so
408 %attr(755,root,root) %{_libdir}/%{name}/memory.so
409 %if %{with multimeter}
410 %attr(755,root,root) %{_libdir}/%{name}/multimeter.so
411 %endif
412 %if %{with netlink}
413 %attr(755,root,root) %{_libdir}/%{name}/netlink.so
414 %endif
415 %attr(755,root,root) %{_libdir}/%{name}/network.so
416 %attr(755,root,root) %{_libdir}/%{name}/nut.so
417 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
418 %attr(755,root,root) %{_libdir}/%{name}/ntpd.so
419 #%attr(755,root,root) %{_libdir}/%{name}/perl.so
420 %attr(755,root,root) %{_libdir}/%{name}/postgresql.so
421 %attr(755,root,root) %{_libdir}/%{name}/processes.so
422 %attr(755,root,root) %{_libdir}/%{name}/serial.so
423 %attr(755,root,root) %{_libdir}/%{name}/swap.so
424 %attr(755,root,root) %{_libdir}/%{name}/syslog.so
425 %attr(755,root,root) %{_libdir}/%{name}/tail.so
426 #%attr(755,root,root) %{_libdir}/%{name}/tape.so
427 %attr(755,root,root) %{_libdir}/%{name}/teamspeak2.so
428 %attr(755,root,root) %{_libdir}/%{name}/tcpconns.so
429 %attr(755,root,root) %{_libdir}/%{name}/thermal.so
430 #%attr(755,root,root) %{_libdir}/%{name}/traffic.so
431 %attr(755,root,root) %{_libdir}/%{name}/unixsock.so
432 %attr(755,root,root) %{_libdir}/%{name}/users.so
433 %attr(755,root,root) %{_libdir}/%{name}/vmem.so
434 %attr(755,root,root) %{_libdir}/%{name}/vserver.so
435 %attr(755,root,root) %{_libdir}/%{name}/wireless.so
436 %{_libdir}/%{name}/types.db
437
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
439
440 %attr(754,root,root) /etc/rc.d/init.d/%{name}
441
442 %{_mandir}/man1/collectd.1*
443 %{_mandir}/man1/collectd-nagios.1*
444 %{_mandir}/man5/collectd.conf.5*
445 %{_mandir}/man5/collectd-email.5*
446 %{_mandir}/man5/collectd-exec.5*
447 %{_mandir}/man5/collectd-perl.5*
448 %{_mandir}/man5/collectd-snmp.5*
449 %{_mandir}/man5/collectd-unixsock.5*
450 %{_mandir}/man1/collectdmon.1*
451 %{_mandir}/man5/types.db.5*
452 %{_var}/log/collectd.log
453 %dir %{_var}/lib/%{name}
454
455 ########## PLUGINS:
456 %files ascent
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_libdir}/%{name}/ascent.so
459
460 %files apache
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_libdir}/%{name}/apache.so
463
464 %files collection
465 %defattr(644,root,root,755)
466 %dir %{_webappdir}
467 %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/collection.conf
468 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
469 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
470 %dir %{_appdir}/cgi-bin
471 %attr(755,root,root) %{_appdir}/cgi-bin/collection.cgi
472
473 %files dns
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/%{name}/dns.so
476
477 %files hddtemp
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_libdir}/%{name}/hddtemp.so
480
481 %if %{with ipmi}
482 %files ipmi
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_libdir}/%{name}/ipmi.so
485 %endif
486
487 %files mysql
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
490
491 %files nginx
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_libdir}/%{name}/nginx.so
494
495 %files notify_desktop
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_libdir}/%{name}/notify_desktop.so
498
499 %files ping
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_libdir}/%{name}/ping.so
502
503 %files powerdns
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/%{name}/powerdns.so
506
507 %files rrdtool
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libdir}/%{name}/rrdtool.so
510
511 %files sensors
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/%{name}/sensors.so
514
515 %files snmp
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/%{name}/snmp.so
518
519 %files uuid
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/%{name}/uuid.so
522
523 %files xmms
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/%{name}/xmms.so
This page took 0.076778 seconds and 2 git commands to generate.