]> git.pld-linux.org Git - packages/collectd.git/blob - collectd.spec
- pl
[packages/collectd.git] / collectd.spec
1 # TODO:
2 # - mysql subpackage
3 # - lm_sensors subpackage
4 # - hddtemp subpackage
5 # - initscripts for local/network mode (subpackage ?)
6 # - initscripts for server mode (subpackage ?)
7 # - collection CGI script
8 # - package contrib scripts as %doc
9 Summary:        Collects system information in RRD files
10 Summary(pl):    Zbieranie informacji o systemie w plikach RRD
11 Name:           collectd
12 Version:        3.7.1
13 Release:        0.1
14 License:        GPL v2
15 Group:          Unknow
16 Source0:        http://verplant.org/collectd/files/%{name}-%{version}.tar.gz
17 # Source0-md5:  dc2120fad388e5fc8bc486b4fcadc68e
18 URL:            http://verplant.org/collectd/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 #BuildRequires: intltool
22 BuildRequires:  libstatgrab-devel >= 0.12
23 BuildRequires:  libtool
24 BuildRequires:  rpmbuild(macros) >= 1.228
25 Requires(post,preun):   /sbin/chkconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 collectd is a small daemon which collects system information every 10
30 seconds and writes the results in an RRD-file.
31
32 In contrast to most similar software, collectd is not a script but
33 written in plain C for performance and portability. As a daemon it
34 stays in memory, so there is no need to start up a heavy interpreter
35 every time new values should be logged. This allows collectd to have a
36 10 second resolution while being nice to the system.
37
38 %description -l pl
39 collectd to ma³y demon zbieraj±cy co 10 sekund informacje o systemie i
40 zapisuj±cy wyniki do pliku RRD.
41
42 W odró¿nieniu od innych podobnych programów collectd nie jest
43 skryptem, lecz jest napisany w czystym C z my¶l± o wydajno¶ci i
44 przeno¶no¶ci. Jako demon pozostaje w pamiêci, wiêc nie ma potrzeby
45 urychamiania ciê¿kiego interpretera za ka¿dym razem, kiedy powinny byæ
46 zapisane nowe warto¶ci. Dziêki temu collect mo¿e mieæ rozdzielczo¶æ 10
47 sekund i nie obci±¿aæ zbytnio systemu.
48
49 %prep
50 %setup -q
51
52 %build
53 %{__libtoolize}
54 %{__aclocal}
55 %{__autoconf}
56 %{__autoheader}
57 %{__automake}
58 %configure \
59         --with-libstatgrab=/usr \
60         --with-lm-sensors=/usr \
61         --with-libmysql=/usr \
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69         
70 install %{SOURCE2} $RPM_BUILD_ROOT/etc/collectd.conf
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post 
76 /sbin/chkconfig --add %{name}
77 %service %{name} restart
78
79 %preun 
80 if [ "$1" = "0" ]; then
81         %service -q %{name} stop
82         /sbin/chkconfig --del %{name}
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS ChangeLog README TODO
88
89 %attr(755,root,root) %{_sbindir}/collectd
90 %dir %{_libdir}/%{name}
91 %attr(755,root,root) %{_libdir}/%{name}/battery.so
92 %attr(755,root,root) %{_libdir}/%{name}/cpu.so
93 %attr(755,root,root) %{_libdir}/%{name}/cpufreq.so
94 %attr(755,root,root) %{_libdir}/%{name}/df.so
95 %attr(755,root,root) %{_libdir}/%{name}/disk.so
96 %attr(755,root,root) %{_libdir}/%{name}/hddtemp.so
97 %attr(755,root,root) %{_libdir}/%{name}/load.so
98 %attr(755,root,root) %{_libdir}/%{name}/memory.so
99 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
100 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
101 %attr(755,root,root) %{_libdir}/%{name}/ping.so
102 %attr(755,root,root) %{_libdir}/%{name}/processes.so
103 %attr(755,root,root) %{_libdir}/%{name}/sensors.so
104 %attr(755,root,root) %{_libdir}/%{name}/serial.so
105 %attr(755,root,root) %{_libdir}/%{name}/swap.so
106 %attr(755,root,root) %{_libdir}/%{name}/tape.so
107 %attr(755,root,root) %{_libdir}/%{name}/traffic.so
108 %attr(755,root,root) %{_libdir}/%{name}/users.so
109
110 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
111
112 #%attr(754,root,root) /etc/rc.d/init.d/%{name}
113 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
114
115 %{_mandir}/man1/collectd.1*
116 %{_mandir}/man5/collectd.conf.5*
This page took 0.039723 seconds and 3 git commands to generate.