]> git.pld-linux.org Git - packages/collectd.git/blob - collectd.spec
09287a8c0c4be51c8818f4faea939d7d4c1a3a8f
[packages/collectd.git] / collectd.spec
1 # TODO:
2 # - mysql subpackage
3 # - lm_sensors subpackage
4 # - hddtemp subpackage
5 # - initscripts for local/network mode (subpackage ?)
6 # - initscripts for server mode (subpackage ?)
7 # - collection CGI script
8 # - package contrib scripts as %doc
9 Summary:        Collects system information in RRD files
10 Summary(pl):    Zbieranie informacji o systemie w plikach RRD
11 Name:           collectd
12 Version:        3.8.4
13 Release:        0.1
14 License:        GPL v2
15 Group:          Daemons
16 Source0:        http://collectd.org/files/%{name}-%{version}.tar.gz
17 # Source0-md5:  c2900b156c93265880c5583cbb6898ba
18 Source1:        %{name}.conf
19 Patch0:         %{name}-hddtemp.patch
20 URL:            http://collectd.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 #BuildRequires: intltool
24 BuildRequires:  libstatgrab-devel >= 0.12
25 BuildRequires:  libtool
26 BuildRequires:  rpmbuild(macros) >= 1.228
27 Requires(post,preun):   /sbin/chkconfig
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 collectd is a small daemon which collects system information every 10
32 seconds and writes the results in an RRD-file.
33
34 In contrast to most similar software, collectd is not a script but
35 written in plain C for performance and portability. As a daemon it
36 stays in memory, so there is no need to start up a heavy interpreter
37 every time new values should be logged. This allows collectd to have a
38 10 second resolution while being nice to the system.
39
40 %description -l pl
41 collectd to ma³y demon zbieraj±cy co 10 sekund informacje o systemie i
42 zapisuj±cy wyniki do pliku RRD.
43
44 W odró¿nieniu od innych podobnych programów collectd nie jest
45 skryptem, lecz jest napisany w czystym C z my¶l± o wydajno¶ci i
46 przeno¶no¶ci. Jako demon pozostaje w pamiêci, wiêc nie ma potrzeby
47 urychamiania ciê¿kiego interpretera za ka¿dym razem, kiedy powinny byæ
48 zapisane nowe warto¶ci. Dziêki temu collect mo¿e mieæ rozdzielczo¶æ 10
49 sekund i nie obci±¿aæ zbytnio systemu.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 %{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__autoheader}
60 %{__automake}
61 %configure \
62         --with-libstatgrab=/usr \
63         --with-lm-sensors=/usr \
64         --with-libmysql=/usr \
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/collectd.conf
74
75 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /sbin/chkconfig --add %{name}
82 %service %{name} restart
83
84 %preun
85 if [ "$1" = "0" ]; then
86         %service -q %{name} stop
87         /sbin/chkconfig --del %{name}
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog README TODO
93
94 %attr(755,root,root) %{_sbindir}/collectd
95 %dir %{_libdir}/%{name}
96 %attr(755,root,root) %{_libdir}/%{name}/battery.so
97 %attr(755,root,root) %{_libdir}/%{name}/cpu.so
98 %attr(755,root,root) %{_libdir}/%{name}/cpufreq.so
99 %attr(755,root,root) %{_libdir}/%{name}/df.so
100 %attr(755,root,root) %{_libdir}/%{name}/disk.so
101 %attr(755,root,root) %{_libdir}/%{name}/hddtemp.so
102 %attr(755,root,root) %{_libdir}/%{name}/load.so
103 %attr(755,root,root) %{_libdir}/%{name}/memory.so
104 %attr(755,root,root) %{_libdir}/%{name}/mysql.so
105 %attr(755,root,root) %{_libdir}/%{name}/nfs.so
106 %attr(755,root,root) %{_libdir}/%{name}/ping.so
107 %attr(755,root,root) %{_libdir}/%{name}/processes.so
108 %attr(755,root,root) %{_libdir}/%{name}/sensors.so
109 %attr(755,root,root) %{_libdir}/%{name}/serial.so
110 %attr(755,root,root) %{_libdir}/%{name}/swap.so
111 %attr(755,root,root) %{_libdir}/%{name}/tape.so
112 %attr(755,root,root) %{_libdir}/%{name}/traffic.so
113 %attr(755,root,root) %{_libdir}/%{name}/users.so
114 %attr(755,root,root) %{_libdir}/%{name}/wireless.so
115
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
117
118 #%attr(754,root,root) /etc/rc.d/init.d/%{name}
119 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
120
121 %{_mandir}/man1/collectd.1*
122 %{_mandir}/man5/collectd.conf.5*
This page took 0.039504 seconds and 2 git commands to generate.