]> git.pld-linux.org Git - packages/codeblocks.git/blame - codeblocks.spec
- files almost done. seems to work...
[packages/codeblocks.git] / codeblocks.spec
CommitLineData
d1a853e8
PS
1#
2# TODO:
3# - move plugins to libdir/name/...
4#
f2e658c8
PS
5Summary: An open source, cross platform, free C++ IDE
6Name: codeblocks
7Version: 1.0
8%define _rc rc2
d1a853e8 9Release: 0.%{_rc}.0.2
f2e658c8
PS
10License: GPL
11Group: Development/Languages
12Source0: http://dl.sourceforge.net/codeblocks/%{name}-%{version}%{_rc}.tgz
d1a853e8 13# Source0-md5: 425c700feb77d22b1b85b1061d2504d9
f2e658c8
PS
14URL: http://www.codeblocks.org/
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: dos2unix
18BuildRequires: libtool
19BuildRequires: wxGTK2-devel
d1a853e8 20BuildRequires: wxWidgets-devel
f2e658c8
PS
21BuildRequires: zip
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Code::Blocks is a free C++ IDE built specifically to meet the most
26demanding needs of its users. It was designed, right from the start,
27to be extensible and configurable. Built around a plugin framework,
28Code::Blocks can be extended with plugin DLLs. It includes a plugin
29wizard so you can compile your own plugins!
30
31Features:
32
33Highlights:
34
35 - Open Source! GPL2, no hidden costs.
36 - Cross-platform. Runs on Linux or Windows (uses wxWidgets).
37 - Made in GNU C++. No interpreted languages or proprietary libs
38 needed.
39 - Comes in two presentations: Standalone, and MinGW bundle
40 - Devpack support (optional)
41 - Extensible thru plugins (SDK available in the downloads section)
42
43Compiler-related features:
44
45 - Multiple compiler support:
46 - GCC (MingW / Linux GCC)
47 - MSVC++
48 - Digital Mars
49 - Borland C++ 5.5
50 - Open Watcom
51 - Compiles directly or with makefiles
52 - Predefined project templates
53 - Custom template support
54 - Uses XML format for project files.
55 - Multi-target projects
56 - Workspaces support
57 - Imports MSVC projects and workspaces (NOTE: assembly code and
58 inter-project dependencies not supported yet)
59 - Imports Dev-C++ projects
60 - Integrates with GDB for debugging
61
62Interface Features:
63
64 - Syntax highlighting, customizable and extensible
65 - Code folding for C++ and XML files.
66 - Tabbed interface
67 - Code completion plugin
68 - Class Browser
69 - Smart indent
70 - One-key swap between .h and .c/.cpp files
71 - Open files list for quick switching between files (optional)
72 - External customizable "Tools"
73 - To-do list management with different users
74
75%prep
76%setup -q -n %{name}-%{version}%{_rc}
77find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico" | sed "s/.*/\"\\0\"/" | xargs dos2unix
78chmod a+x acinclude.m4 src/update
79
80%build
81%{__libtoolize}
82%{__aclocal}
83%{__autoconf}
84%{__autoheader}
85%{__automake}
86%configure \
87 --with-wx-config=wx-gtk2-ansi-config
88%{__make}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
102%files
103%defattr(644,root,root,755)
104#doc README COPYING AUTHORS BUGS COMPILERS TODO NEWS ChangeLog
105%attr(755,root,root) %{_bindir}/codeblocks
106%attr(755,root,root) %{_bindir}/console_runner
107%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
7b226dae
PS
108%{_desktopdir}/*.desktop
109%dir %{_datadir}/%{name}
110%{_datadir}/%{name}/*.zip
111%{_datadir}/%{name}/*.txt
112%{_datadir}/%{name}/icons
113%{_datadir}/%{name}/images
114%{_datadir}/%{name}/lexers
115%{_datadir}/%{name}/templates
116# TODO!
117%dir %{_datadir}/%{name}/plugins
118%attr(755,root,root) %{_datadir}/%{name}/plugins/*.so
This page took 0.084305 seconds and 4 git commands to generate.