]> git.pld-linux.org Git - packages/cocoon.git/blob - cocoon.spec
- configuration for web application in servlets area
[packages/cocoon.git] / cocoon.spec
1
2 %define fopver 0_15_0
3 %define xalanver 1_2_D02
4 %define xercesver 1_2
5
6 Summary:        The servlet XML transformation system
7 Name:           cocoon
8 Version:        1.8.2
9 Release:        1
10 License:        Apache
11 Group:          Networking/Utilities
12 Group(de):      Netzwerkwesen/Werkzeuge
13 Group(es):      Red/Utilitarios
14 Group(pl):      Sieciowe/Narzêdzia
15 Group(pt_BR):   Rede/Utilitários
16 Source0:        http://xml.apache.org/cocoon/dist/Cocoon-%{version}.tar.gz
17 Source1:        %{name}-web.xml
18 Source2:        %{name}-webapp.conf
19 Patch0: %{name}-paths.patch
20 URL:            http://xml.apache.org/cocoon/
21 Requires:       java >= 1.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 BuildArch:      noarch
24
25 %description
26 Cocoon is a 100% pure Java publishing framework that relies on new W3C
27 technologies (such as XML and XSL) to provide web content.
28
29 %package doc
30 Group:          Networking/Utilities
31 Group(de):      Netzwerkwesen/Werkzeuge
32 Group(es):      Red/Utilitarios
33 Group(pl):      Sieciowe/Narzêdzia
34 Group(pt_BR):   Rede/Utilitários
35 Summary:        Online manual for Cocoon
36
37 %description doc
38 Documentation for Cocoon, viewable through your web server, too.
39
40 %package optional
41 Group:          Networking/Utilities
42 Group(de):      Netzwerkwesen/Werkzeuge
43 Group(es):      Red/Utilitarios
44 Group(pl):      Sieciowe/Narzêdzia
45 Group(pt_BR):   Rede/Utilitários
46 Requires:       cocoon = %{version}
47 Summary:        Optional jars for cocoon
48
49 %description optional
50 Additional functionality for Cocoon:
51  - bsfengines - Bean Scripting Framework (Xalan existion)
52  - bsf - Bean Scripting Framework (Xalan existion functions)
53  - fop - converts xsl:fo into PDF output
54
55 %package sax-bugfix
56 Group:          Networking/Utilities
57 Group(de):      Netzwerkwesen/Werkzeuge
58 Group(es):      Red/Utilitarios
59 Group(pl):      Sieciowe/Narzêdzia
60 Group(pt_BR):   Rede/Utilitários
61 Requires:       cocoon = %{version}
62 Summary:        Fixes error reporting bug
63
64 %description sax-bugfix
65 Note The sax-bugfix.jar is an optional, unofficial bugfix - which must
66 be ahead of xerces in the CLASSPATH to work - to allow you to see line
67 numbers and column numbers in XML parsing error messages, and is only
68 needed on some virtual machines. If you get "sealing violations", try
69 removing it from your CLASSPATH.
70
71 %package samples
72 Group:          Networking/Utilities
73 Group(de):      Netzwerkwesen/Werkzeuge
74 Group(es):      Red/Utilitarios
75 Group(pl):      Sieciowe/Narzêdzia
76 Group(pt_BR):   Rede/Utilitários
77 Requires:       cocoon = %{version}
78 Summary:        Samples for cocoon
79
80 %description samples
81 This directory contains samples to show you the power of the Cocoon Publishing
82 Framework. Each subdirectory contains examples of possible uses that should
83 give you insights on Cocoon capabilities as well as real-life suggestions on
84 how to XML-ize your web-serving environment.
85
86 %package xmldoc
87 Group:          Networking/Utilities
88 Group(de):      Netzwerkwesen/Werkzeuge
89 Group(es):      Red/Utilitarios
90 Group(pl):      Sieciowe/Narzêdzia
91 Group(pt_BR):   Rede/Utilitários
92 Requires:       cocoon = %{version}
93 Summary:        Documentation for cocoon in XML
94
95 %description xmldoc
96 Documentation for cocoon in XML
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_datadir}/%{name} \
107         $RPM_BUILD_ROOT%{_datadir}/%{name}/{lib,conf} \
108         $RPM_BUILD_ROOT/home/httpd/%{name}/WEB-INF \
109         $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/repository
110
111 cp bin/cocoon.jar \
112         lib/{turbine-pool,w3c,xalan_%{xalanver},xerces_%{xercesver}}.jar \
113         $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
114 cp lib/{bsfengines,bsf,fop_%{fopver}}.jar \
115         $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
116 cp lib/sax-bugfix.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
117
118 cp index.html $RPM_BUILD_ROOT/home/httpd/%{name}
119
120 cp %{SOURCE1} $RPM_BUILD_ROOT/home/httpd/%{name}/WEB-INF/web.xml
121 cp conf/cocoon.properties $RPM_BUILD_ROOT%{_datadir}/%{name}/conf
122 cp %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/conf/webapp.conf
123
124 cp -R samples $RPM_BUILD_ROOT/home/httpd/%{name}
125
126 mv {todo,changes}.xml xdocs
127 cp -R xdocs $RPM_BUILD_ROOT/home/httpd/%{name}
128
129 gzip -9nf LICENSE README
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 ln -sf %{_datadir}/%{name}/{lib,conf/cocoon.properties} /home/httpd/%{name}/WEB-INF
136
137 %postun
138 rm -rf /home/httpd/%{name}/WEB-INF/{lib,cocoon.properties}
139
140 %post doc
141 ln -sf %{_defaultdocdir}/%{name}-doc-%{version}/docs /home/httpd/%{name}
142
143 %postun doc
144 rm -rf /home/httpd/%{name}/docs
145
146 %files
147 %defattr(644,root,root,755)
148 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) %{_datadir}/%{name}/conf/cocoon.properties
149 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) %{_datadir}/%{name}/conf/webapp.conf
150 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) /home/httpd/%{name}/WEB-INF/web.xml
151 %attr(0750,root,http) %dir %{_localstatedir}/lib/%{name}/repository
152 /home/httpd/%{name}/index.html
153 %{_datadir}/%{name}/lib/cocoon.jar
154 %{_datadir}/%{name}/lib/turbine-pool.jar
155 %{_datadir}/%{name}/lib/w3c.jar
156 %{_datadir}/%{name}/lib/xalan_%{xalanver}.jar
157 %{_datadir}/%{name}/lib/xerces_%{xercesver}.jar
158 %doc LICENSE.gz README.gz
159
160 %files doc
161 %defattr(644,root,root,755)
162 %doc docs
163
164 %files optional
165 %defattr(644,root,root,755)
166 %{_datadir}/%{name}/lib/bsfengines.jar
167 %{_datadir}/%{name}/lib/bsf.jar
168 %{_datadir}/%{name}/lib/fop_%{fopver}.jar
169
170 %files sax-bugfix
171 %defattr(644,root,root,755)
172 %{_datadir}/%{name}/lib/sax-bugfix.jar
173
174 %files samples
175 %defattr(644,root,root,755)
176 /home/httpd/%{name}/samples
177
178 %files xmldoc
179 %defattr(644,root,root,755)
180 /home/httpd/%{name}/xdocs
This page took 0.055011 seconds and 3 git commands to generate.