]> git.pld-linux.org Git - packages/cman.git/blob - cman.spec
- package service_cman.lcrso
[packages/cman.git] / cman.spec
1 #
2 # Conditional build:
3 %bcond_with     libonly         # build package only with lib (needed bootstrap with ccs)
4 #
5 Summary:        General-purpose symmetric cluster manager
6 Summary(pl.UTF-8):      Zarządca symetrycznych klastrów ogólnego przeznaczenia
7 Name:           cman
8 Version:        2.00.00
9 Release:        1
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
13 # Source0-md5:  2ef3f4ba9d3c87b50adfc9b406171085
14 URL:            http://sources.redhat.com/cluster/cman/
15 %{!?with_libonly:BuildRequires: ccs-devel}
16 BuildRequires:  openais-devel
17 BuildRequires:  perl-base
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sbindir        /sbin
21
22 %description
23 MAN is a symmetric, general-purpose, kernel-based cluster manager. It
24 has two parts. Connection Manager (cnxman) handles membership,
25 messaging, quorum, event notification and transitions. Service Manager
26 (sm) handles "service groups" which are a general way of representing
27 and managing instances of external systems that require cluster
28 management. The CMAN cluster manager is the foundational system upon
29 which DLM, GFS, CLVM, and Fence all depend. The CMAN API in the kernel
30 and userspace is general and available for other programs to use.
31
32 %description -l pl.UTF-8
33 MAN to zarządca opartych na jądrze symetrycznych klastrów ogólnego
34 przeznaczenia. Składa się z dwóch części. Zarządca połączeń
35 (Connection Manager, cnxman) obsługuje członkostwo, komunikację,
36 kworum, powiadamianie o zdarzeniach i przejścia. Zarządca usług
37 (Service Manager, sm) obsługuje "grupy usług", które są ogólnym
38 sposobem reprezentacji i zarządzania instancjami zewnętrznych systemów
39 wymagających zarządzania klastrem. Zarządca klastrów CMAN to
40 podstawowy system, na którym polegają DLM, GFS, CLVM i Fence. API
41 CMAN-a w jądrze i przestrzeni użytkownika jest ogólne i w całości
42 dostępne do wykorzystania w innych programach.
43
44 %package devel
45 Summary:        CMAN header files
46 Summary(pl.UTF-8):      Pliki nagłówkowe CMAN
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 CMAN header files.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe CMAN.
55
56 %package static
57 Summary:        CMAN static library
58 Summary(pl.UTF-8):      Biblioteka statyczna CMAN
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 CMAN static library.
64
65 %description devel -l pl.UTF-8
66 Biblioteka statyczna CMAN.
67
68 %prep
69 %setup -q -n cluster-%{version}
70
71 cd %{name}
72 %{__perl} -pi -e 's/-g -O/%{rpmcflags}/' lib/Makefile
73 %{__perl} -pi -e 's/-g/%{rpmcflags}/' {cman_tool,tests}/Makefile
74
75 %build
76 cd %{name}
77 ./configure \
78         --ccsincdir="$PWD/../ccs/lib" \
79         --incdir=%{_includedir} \
80         --libdir=%{_libdir} \
81         --libexecdir=%{_libdir} \
82         --mandir=%{_mandir} \
83         --prefix=%{_prefix} \
84         --sbindir=%{_sbindir}
85 %{__make} %{?with_libonly:-C lib} \
86         CC="%{__cc}" \
87         incdir=`pwd`/include
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 cd %{name}
92
93 %{__make} %{?with_libonly:-C lib} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %{!?with_libonly:%attr(755,root,root) %{_sbindir}/*}
105 %attr(755,root,root) %{_libdir}/libcman.so.*.*
106 %if %{without libonly}
107 %attr(755,root,root) %{_libdir}/lcrso/service_cman.lcrso
108 %{_mandir}/man5/cman.5*
109 %{_mandir}/man5/qdisk.5*
110 %{_mandir}/man8/cman_tool.8*
111 %{_mandir}/man8/mkqdisk.8*
112 %{_mandir}/man8/qdiskd.8*
113 #%attr(754,root,root) /etc/rc.d/init.d/cman
114 #%attr(754,root,root) /etc/rc.d/init.d/qdiskd
115 %endif
116
117 %files devel
118 %defattr(644,root,root,755)
119 %{_includedir}/*.h
120 %attr(755,root,root) %{_libdir}/libcman.so
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libcman.a
This page took 0.055209 seconds and 3 git commands to generate.