]> git.pld-linux.org Git - packages/cman.git/blame_incremental - cman.spec
- initial addition of initscripts
[packages/cman.git] / cman.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with libonly # build package only with lib (needed bootstrap with ccs)
4#
5Summary: General-purpose symmetric cluster manager
6Summary(pl.UTF-8): Zarządca symetrycznych klastrów ogólnego przeznaczenia
7Name: cman
8Version: 2.00.00
9Release: 1
10License: GPL v2
11Group: Applications/System
12Source0: ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
13# Source0-md5: 2ef3f4ba9d3c87b50adfc9b406171085
14Source1: %{name}.init
15Source2: %{name}.sysconfig
16URL: http://sources.redhat.com/cluster/cman/
17%{!?with_libonly:BuildRequires: ccs-devel}
18BuildRequires: openais-devel
19BuildRequires: perl-base
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _sbindir /sbin
23
24%description
25MAN is a symmetric, general-purpose, kernel-based cluster manager. It
26has two parts. Connection Manager (cnxman) handles membership,
27messaging, quorum, event notification and transitions. Service Manager
28(sm) handles "service groups" which are a general way of representing
29and managing instances of external systems that require cluster
30management. The CMAN cluster manager is the foundational system upon
31which DLM, GFS, CLVM, and Fence all depend. The CMAN API in the kernel
32and userspace is general and available for other programs to use.
33
34%description -l pl.UTF-8
35MAN to zarządca opartych na jądrze symetrycznych klastrów ogólnego
36przeznaczenia. Składa się z dwóch części. Zarządca połączeń
37(Connection Manager, cnxman) obsługuje członkostwo, komunikację,
38kworum, powiadamianie o zdarzeniach i przejścia. Zarządca usług
39(Service Manager, sm) obsługuje "grupy usług", które są ogólnym
40sposobem reprezentacji i zarządzania instancjami zewnętrznych systemów
41wymagających zarządzania klastrem. Zarządca klastrów CMAN to
42podstawowy system, na którym polegają DLM, GFS, CLVM i Fence. API
43CMAN-a w jądrze i przestrzeni użytkownika jest ogólne i w całości
44dostępne do wykorzystania w innych programach.
45
46%package devel
47Summary: CMAN header files
48Summary(pl.UTF-8): Pliki nagłówkowe CMAN
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
53CMAN header files.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe CMAN.
57
58%package static
59Summary: CMAN static library
60Summary(pl.UTF-8): Biblioteka statyczna CMAN
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65CMAN static library.
66
67%description devel -l pl.UTF-8
68Biblioteka statyczna CMAN.
69
70%prep
71%setup -q -n cluster-%{version}
72
73cd %{name}
74%{__perl} -pi -e 's/-g -O/%{rpmcflags}/' lib/Makefile
75%{__perl} -pi -e 's/-g/%{rpmcflags}/' {cman_tool,tests}/Makefile
76
77%build
78cd %{name}
79./configure \
80 --ccsincdir="$PWD/../ccs/lib" \
81 --incdir=%{_includedir} \
82 --libdir=%{_libdir} \
83 --libexecdir=%{_libdir} \
84 --mandir=%{_mandir} \
85 --prefix=%{_prefix} \
86 --sbindir=%{_sbindir}
87%{__make} %{?with_libonly:-C lib} \
88 CC="%{__cc}" \
89 incdir=`pwd`/include
90
91%install
92rm -rf $RPM_BUILD_ROOT
93install -d $RPM_BUILD_ROOT{/etc/sysconfig,/etc/rc.d/init.d}
94cd %{name}
95
96%{__make} %{?with_libonly:-C lib} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
100install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/%{name}
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
106/sbin/ldconfig
107/sbin/chkconfig --add %{name}
108
109%postun -p /sbin/ldconfig
110
111%preun
112if [ "$1" = "0" ]; then
113 %service -q %{name} stop
114 /sbin/chkconfig --del %{name}
115fi
116
117%files
118%defattr(644,root,root,755)
119%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
120%attr(754,root,root) /etc/rc.d/init.d/%{name}
121%{!?with_libonly:%attr(755,root,root) %{_sbindir}/*}
122%attr(755,root,root) %{_libdir}/libcman.so.*.*
123%if %{without libonly}
124%attr(755,root,root) %{_libdir}/lcrso/service_cman.lcrso
125%{_mandir}/man5/cman.5*
126%{_mandir}/man5/qdisk.5*
127%{_mandir}/man8/cman_tool.8*
128%{_mandir}/man8/mkqdisk.8*
129%{_mandir}/man8/qdiskd.8*
130#%attr(754,root,root) /etc/rc.d/init.d/cman
131#%attr(754,root,root) /etc/rc.d/init.d/qdiskd
132%endif
133
134%files devel
135%defattr(644,root,root,755)
136%{_includedir}/*.h
137%attr(755,root,root) %{_libdir}/libcman.so
138
139%files static
140%defattr(644,root,root,755)
141%{_libdir}/libcman.a
This page took 0.055991 seconds and 4 git commands to generate.