]> git.pld-linux.org Git - packages/cman.git/blame - cman.spec
- workaround for -Werror combined with unused variable
[packages/cman.git] / cman.spec
CommitLineData
ed6d5f29 1#
2# Conditional build:
e8fc3769 3%bcond_with libonly # build package only with lib (needed bootstrap with ccs)
ed6d5f29 4#
762dc73d 5Summary: General-purpose symmetric cluster manager
8f0dac7b 6Summary(pl.UTF-8): Zarządca symetrycznych klastrów ogólnego przeznaczenia
cb602c2e 7Name: cman
e6276ceb 8Version: 2.03.10
e06c11ed 9Release: 2
c66b6748 10License: GPL v2
cb602c2e 11Group: Applications/System
a6bd5743 12Source0: ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
e6276ceb 13# Source0-md5: 379b560096e315d4b52e238a5c72ba4a
c1252bfc 14Source1: %{name}.init
15Source2: %{name}.sysconfig
c31c0e69 16URL: http://sources.redhat.com/cluster/cman/
74ef85ee 17%{!?with_libonly:BuildRequires: ccs-devel >= 2.03.10}
e6276ceb 18BuildRequires: ncurses-devel
74ef85ee 19BuildRequires: openais-devel < 1.0
c66b6748 20BuildRequires: perl-base
e8fc3769 21Requires: %{name}-libs = %{version}-%{release}
cb602c2e
AM
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define _sbindir /sbin
25
e8fc3769
JB
26# aliasing problems in qdisk/disk.c
27%define specflags -fno-strict-aliasing
28
cb602c2e
AM
29%description
30MAN is a symmetric, general-purpose, kernel-based cluster manager. It
31has two parts. Connection Manager (cnxman) handles membership,
32messaging, quorum, event notification and transitions. Service Manager
33(sm) handles "service groups" which are a general way of representing
34and managing instances of external systems that require cluster
35management. The CMAN cluster manager is the foundational system upon
36which DLM, GFS, CLVM, and Fence all depend. The CMAN API in the kernel
37and userspace is general and available for other programs to use.
38
6153d48e
JR
39%description -l pl.UTF-8
40MAN to zarządca opartych na jądrze symetrycznych klastrów ogólnego
41przeznaczenia. Składa się z dwóch części. Zarządca połączeń
42(Connection Manager, cnxman) obsługuje członkostwo, komunikację,
43kworum, powiadamianie o zdarzeniach i przejścia. Zarządca usług
44(Service Manager, sm) obsługuje "grupy usług", które są ogólnym
45sposobem reprezentacji i zarządzania instancjami zewnętrznych systemów
46wymagających zarządzania klastrem. Zarządca klastrów CMAN to
47podstawowy system, na którym polegają DLM, GFS, CLVM i Fence. API
48CMAN-a w jądrze i przestrzeni użytkownika jest ogólne i w całości
49dostępne do wykorzystania w innych programach.
762dc73d 50
e8fc3769
JB
51%package libs
52Summary: CMAN library
53Summary(pl.UTF-8): Biblioteka CMAN
54Group: Libraries
f24bf85c
JB
55Obsoletes: gulm
56Obsoletes: gulm-devel
57Obsoletes: gulm-static
334cd07c 58Obsoletes: iddev
f24bf85c
JB
59Obsoletes: magma
60Obsoletes: magma-devel
61Obsoletes: magma-plugins
62Obsoletes: magma-static
48676e79 63Conflicts: cman < 2.00.00-2
e8fc3769
JB
64
65%description libs
66CMAN library.
67
68%description libs -l pl.UTF-8
69Biblioteka CMAN.
70
9d5dca7b
JB
71%package devel
72Summary: CMAN header files
8f0dac7b 73Summary(pl.UTF-8): Pliki nagłówkowe CMAN
9d5dca7b 74Group: Development/Libraries
e8fc3769 75Requires: %{name}-libs = %{version}-%{release}
9d5dca7b
JB
76
77%description devel
78CMAN header files.
79
6153d48e
JR
80%description devel -l pl.UTF-8
81Pliki nagłówkowe CMAN.
9d5dca7b 82
a6bd5743
AM
83%package static
84Summary: CMAN static library
8f0dac7b 85Summary(pl.UTF-8): Biblioteka statyczna CMAN
a6bd5743 86Group: Development/Libraries
4a979529 87Requires: %{name}-devel = %{version}-%{release}
c66b6748 88
a6bd5743
AM
89%description static
90CMAN static library.
c66b6748 91
fbced621 92%description static -l pl.UTF-8
a6bd5743
AM
93Biblioteka statyczna CMAN.
94
95%prep
96%setup -q -n cluster-%{version}
a6bd5743 97
e06c11ed
JB
98# there are warnings caused by some unused variables
99%{__sed} -i -e 's/-Werror //' %{name}/qdisk/Makefile
100
cb602c2e
AM
101%build
102./configure \
74ef85ee
JB
103 --cc="%{__cc}" \
104 --cflags="%{rpmcflags} -Wall" \
105 --ldflags="%{rpmldflags}" \
cb602c2e 106 --incdir=%{_includedir} \
e6276ceb 107 --ncursesincdir=%{_includedir}/ncurses \
cb602c2e 108 --libdir=%{_libdir} \
a4c8a87c 109 --libexecdir=%{_libdir} \
cb602c2e
AM
110 --mandir=%{_mandir} \
111 --prefix=%{_prefix} \
74ef85ee
JB
112 --sbindir=%{_sbindir} \
113 --without_gfs \
114 --without_gfs2 \
115 --without_gnbd \
116 --without_kernel_modules
e6276ceb 117
74ef85ee 118%{__make} -C %{name}%{?with_libonly:/lib}
cb602c2e
AM
119
120%install
121rm -rf $RPM_BUILD_ROOT
c1252bfc 122install -d $RPM_BUILD_ROOT{/etc/sysconfig,/etc/rc.d/init.d}
cb602c2e 123
e8fc3769 124%{__make} -C %{name}%{?with_libonly:/lib} install \
cb602c2e
AM
125 DESTDIR=$RPM_BUILD_ROOT
126
74ef85ee 127%if %{without libonly}
e8fc3769
JB
128install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
129install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
74ef85ee 130%endif
c1252bfc 131
cb602c2e
AM
132%clean
133rm -rf $RPM_BUILD_ROOT
134
b6ba0aed 135%post
c1252bfc 136/sbin/chkconfig --add %{name}
137
c1252bfc 138%preun
139if [ "$1" = "0" ]; then
140 %service -q %{name} stop
141 /sbin/chkconfig --del %{name}
142fi
143
e8fc3769
JB
144%post libs -p /sbin/ldconfig
145%postun libs -p /sbin/ldconfig
146
58a4b58e 147%if %{without libonly}
cb602c2e
AM
148%files
149%defattr(644,root,root,755)
c1252bfc 150%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
151%attr(754,root,root) /etc/rc.d/init.d/%{name}
e06c11ed 152# TODO: PLDify
e8fc3769 153#%attr(754,root,root) /etc/rc.d/init.d/qdiskd
e06c11ed
JB
154%attr(755,root,root) %{_sbindir}/cman_tool
155%attr(755,root,root) %{_sbindir}/mkqdisk
156%attr(755,root,root) %{_sbindir}/qdiskd
a4c8a87c 157%attr(755,root,root) %{_libdir}/lcrso/service_cman.lcrso
c66b6748 158%{_mandir}/man5/cman.5*
46f80b5f 159%{_mandir}/man5/qdisk.5*
c66b6748 160%{_mandir}/man8/cman_tool.8*
46f80b5f
JB
161%{_mandir}/man8/mkqdisk.8*
162%{_mandir}/man8/qdiskd.8*
ed6d5f29 163%endif
9d5dca7b 164
e8fc3769
JB
165%files libs
166%defattr(644,root,root,755)
167%attr(755,root,root) %{_libdir}/libcman.so.*.*
74ef85ee 168%attr(755,root,root) %ghost %{_libdir}/libcman.so.2
e8fc3769 169
9d5dca7b
JB
170%files devel
171%defattr(644,root,root,755)
0cbf36cb 172%attr(755,root,root) %{_libdir}/libcman.so
74ef85ee 173%{_includedir}/libcman.h
a6bd5743
AM
174
175%files static
176%defattr(644,root,root,755)
0cbf36cb 177%{_libdir}/libcman.a
This page took 0.093874 seconds and 4 git commands to generate.