]> git.pld-linux.org Git - packages/cman.git/blame - cman.spec
- added
[packages/cman.git] / cman.spec
CommitLineData
ed6d5f29 1#
2# Conditional build:
3%bcond_with libonly # build package only with lib (needed bootstrap with ccs)
4#
762dc73d 5Summary: General-purpose symmetric cluster manager
8f0dac7b 6Summary(pl.UTF-8): Zarządca symetrycznych klastrów ogólnego przeznaczenia
cb602c2e 7Name: cman
ed6d5f29 8Version: 2.00.00
a6bd5743 9Release: 1
c66b6748 10License: GPL v2
cb602c2e 11Group: Applications/System
a6bd5743 12Source0: ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
ed6d5f29 13# Source0-md5: 2ef3f4ba9d3c87b50adfc9b406171085
c31c0e69 14URL: http://sources.redhat.com/cluster/cman/
ed6d5f29 15%{!?with_libonly:BuildRequires: ccs-devel}
16BuildRequires: openais-devel
c66b6748 17BuildRequires: perl-base
cb602c2e
AM
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _sbindir /sbin
21
22%description
23MAN is a symmetric, general-purpose, kernel-based cluster manager. It
24has two parts. Connection Manager (cnxman) handles membership,
25messaging, quorum, event notification and transitions. Service Manager
26(sm) handles "service groups" which are a general way of representing
27and managing instances of external systems that require cluster
28management. The CMAN cluster manager is the foundational system upon
29which DLM, GFS, CLVM, and Fence all depend. The CMAN API in the kernel
30and userspace is general and available for other programs to use.
31
6153d48e
JR
32%description -l pl.UTF-8
33MAN to zarządca opartych na jądrze symetrycznych klastrów ogólnego
34przeznaczenia. Składa się z dwóch części. Zarządca połączeń
35(Connection Manager, cnxman) obsługuje członkostwo, komunikację,
36kworum, powiadamianie o zdarzeniach i przejścia. Zarządca usług
37(Service Manager, sm) obsługuje "grupy usług", które są ogólnym
38sposobem reprezentacji i zarządzania instancjami zewnętrznych systemów
39wymagających zarządzania klastrem. Zarządca klastrów CMAN to
40podstawowy system, na którym polegają DLM, GFS, CLVM i Fence. API
41CMAN-a w jądrze i przestrzeni użytkownika jest ogólne i w całości
42dostępne do wykorzystania w innych programach.
762dc73d 43
9d5dca7b
JB
44%package devel
45Summary: CMAN header files
8f0dac7b 46Summary(pl.UTF-8): Pliki nagłówkowe CMAN
9d5dca7b 47Group: Development/Libraries
4a979529 48Requires: %{name} = %{version}-%{release}
9d5dca7b
JB
49
50%description devel
51CMAN header files.
52
6153d48e
JR
53%description devel -l pl.UTF-8
54Pliki nagłówkowe CMAN.
9d5dca7b 55
a6bd5743
AM
56%package static
57Summary: CMAN static library
8f0dac7b 58Summary(pl.UTF-8): Biblioteka statyczna CMAN
a6bd5743 59Group: Development/Libraries
4a979529 60Requires: %{name}-devel = %{version}-%{release}
c66b6748 61
a6bd5743
AM
62%description static
63CMAN static library.
c66b6748 64
6153d48e 65%description devel -l pl.UTF-8
a6bd5743
AM
66Biblioteka statyczna CMAN.
67
68%prep
69%setup -q -n cluster-%{version}
a6bd5743
AM
70
71cd %{name}
c66b6748
JB
72%{__perl} -pi -e 's/-g -O/%{rpmcflags}/' lib/Makefile
73%{__perl} -pi -e 's/-g/%{rpmcflags}/' {cman_tool,tests}/Makefile
cb602c2e
AM
74
75%build
a6bd5743 76cd %{name}
cb602c2e 77./configure \
ed6d5f29 78 --ccsincdir="$PWD/../ccs/lib" \
cb602c2e 79 --incdir=%{_includedir} \
cb602c2e 80 --libdir=%{_libdir} \
a4c8a87c 81 --libexecdir=%{_libdir} \
cb602c2e
AM
82 --mandir=%{_mandir} \
83 --prefix=%{_prefix} \
84 --sbindir=%{_sbindir}
ed6d5f29 85%{__make} %{?with_libonly:-C lib} \
c66b6748
JB
86 CC="%{__cc}" \
87 incdir=`pwd`/include
cb602c2e
AM
88
89%install
90rm -rf $RPM_BUILD_ROOT
a6bd5743 91cd %{name}
cb602c2e 92
ed6d5f29 93%{__make} %{?with_libonly:-C lib} install \
cb602c2e
AM
94 DESTDIR=$RPM_BUILD_ROOT
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
4a979529
JB
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
a6bd5743 101
cb602c2e
AM
102%files
103%defattr(644,root,root,755)
ed6d5f29 104%{!?with_libonly:%attr(755,root,root) %{_sbindir}/*}
0cbf36cb 105%attr(755,root,root) %{_libdir}/libcman.so.*.*
ed6d5f29 106%if %{without libonly}
a4c8a87c 107%attr(755,root,root) %{_libdir}/lcrso/service_cman.lcrso
c66b6748 108%{_mandir}/man5/cman.5*
46f80b5f 109%{_mandir}/man5/qdisk.5*
c66b6748 110%{_mandir}/man8/cman_tool.8*
46f80b5f
JB
111%{_mandir}/man8/mkqdisk.8*
112%{_mandir}/man8/qdiskd.8*
c66b6748 113#%attr(754,root,root) /etc/rc.d/init.d/cman
46f80b5f 114#%attr(754,root,root) /etc/rc.d/init.d/qdiskd
ed6d5f29 115%endif
9d5dca7b
JB
116
117%files devel
118%defattr(644,root,root,755)
a6bd5743 119%{_includedir}/*.h
0cbf36cb 120%attr(755,root,root) %{_libdir}/libcman.so
a6bd5743
AM
121
122%files static
123%defattr(644,root,root,755)
0cbf36cb 124%{_libdir}/libcman.a
This page took 0.083673 seconds and 4 git commands to generate.