]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- add support for ImageMagick 7 auto/th/cmake-3.5.2-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Dec 2016 20:49:33 +0000 (21:49 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Dec 2016 20:49:33 +0000 (21:49 +0100)
- rel 2

cmake.spec
imagemagick7.patch [new file with mode: 0644]

index 5ccf7b10f86535436f5d7663de8c49e9c843a3ce..912645a5d34fb0f3cd80abbea3026f4b6ebd0821 100644 (file)
@@ -15,7 +15,7 @@ Summary:      Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
 Version:       3.5.2
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Building
 Source0:       https://cmake.org/files/v3.5/%{name}-%{version}.tar.gz
@@ -26,6 +26,7 @@ Patch2:               %{name}-helpers.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
 Patch5:                man-syntax.patch
+Patch6:                imagemagick7.patch
 URL:           https://cmake.org/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5.0
@@ -128,6 +129,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
diff --git a/imagemagick7.patch b/imagemagick7.patch
new file mode 100644 (file)
index 0000000..51b0e6f
--- /dev/null
@@ -0,0 +1,41 @@
+--- cmake-3.5.2/Modules/FindImageMagick.cmake~ 2016-04-15 15:41:21.000000000 +0200
++++ cmake-3.5.2/Modules/FindImageMagick.cmake  2016-12-25 21:47:56.573276549 +0100
+@@ -114,7 +114,7 @@
+       ${ImageMagick_INCLUDE_DIRS}
+       "[HKEY_LOCAL_MACHINE\\SOFTWARE\\ImageMagick\\Current;BinPath]/include"
+     PATH_SUFFIXES
+-      ImageMagick ImageMagick-6
++      ImageMagick ImageMagick-6 ImageMagick-7
+     DOC "Path to the ImageMagick arch-independent include dir."
+     )
+   find_path(ImageMagick_${component}_ARCH_INCLUDE_DIR
+@@ -126,7 +126,7 @@
+       ${ImageMagick_INCLUDE_DIRS}
+       "[HKEY_LOCAL_MACHINE\\SOFTWARE\\ImageMagick\\Current;BinPath]/include"
+     PATH_SUFFIXES
+-      ImageMagick ImageMagick-6
++      ImageMagick ImageMagick-6 ImageMagick-7
+     DOC "Path to the ImageMagick arch-specific include dir."
+     )
+   find_library(ImageMagick_${component}_LIBRARY
+@@ -207,17 +207,17 @@
+     )
+   if(component STREQUAL "Magick++")
+     FIND_IMAGEMAGICK_API(Magick++ Magick++.h
+-      Magick++ CORE_RL_Magick++_ Magick++-6.Q16 Magick++-Q16 Magick++-6.Q8 Magick++-Q8 Magick++-6.Q16HDRI Magick++-Q16HDRI Magick++-6.Q8HDRI Magick++-Q8HDRI
++      Magick++ CORE_RL_Magick++_ Magick++-7.Q16 Magick++-6.Q16 Magick++-Q16 Magick++-7.Q8 Magick++-6.Q8 Magick++-Q8 Magick++-7.Q16HDRI Magick++-6.Q16HDRI Magick++-Q16HDRI Magick++-7.Q8HDRI Magick++-6.Q8HDRI Magick++-Q8HDRI
+       )
+     list(APPEND ImageMagick_REQUIRED_VARS ImageMagick_Magick++_LIBRARY)
+   elseif(component STREQUAL "MagickWand")
+     FIND_IMAGEMAGICK_API(MagickWand wand/MagickWand.h
+-      Wand MagickWand CORE_RL_wand_ MagickWand-6.Q16 MagickWand-Q16 MagickWand-6.Q8 MagickWand-Q8 MagickWand-6.Q16HDRI MagickWand-Q16HDRI MagickWand-6.Q8HDRI MagickWand-Q8HDRI
++      Wand MagickWand CORE_RL_wand_ MagickWand-7.Q16 MagickWand-6.Q16 MagickWand-Q16 MagickWand-7.Q8 MagickWand-6.Q8 MagickWand-Q8 MagickWand-7.Q16HDRI MagickWand-6.Q16HDRI MagickWand-Q16HDRI MagickWand-7.Q8HDRI MagickWand-6.Q8HDRI MagickWand-Q8HDRI
+       )
+     list(APPEND ImageMagick_REQUIRED_VARS ImageMagick_MagickWand_LIBRARY)
+   elseif(component STREQUAL "MagickCore")
+     FIND_IMAGEMAGICK_API(MagickCore magick/MagickCore.h
+-      Magick MagickCore CORE_RL_magick_ MagickCore-6.Q16 MagickCore-Q16 MagickCore-6.Q8 MagickCore-Q8 MagickCore-6.Q16HDRI MagickCore-Q16HDRI MagickCore-6.Q8HDRI MagickCore-Q8HDRI
++      Magick MagickCore CORE_RL_magick_ MagickCore-7.Q16 MagickCore-6.Q16 MagickCore-Q16 MagickCore-7.Q8 MagickCore-6.Q8 MagickCore-Q8 MagickCore-7.Q16HDRI MagickCore-6.Q16HDRI MagickCore-Q16HDRI MagickCore-7.Q8HDRI MagickCore-6.Q8HDRI MagickCore-Q8HDRI
+       )
+     list(APPEND ImageMagick_REQUIRED_VARS ImageMagick_MagickCore_LIBRARY)
+   else()
This page took 0.184389 seconds and 4 git commands to generate.