]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- up to 2.8.4 auto/th/cmake-2_8_4-1
authorKacper Kornet <draenog@pld-linux.org>
Wed, 16 Feb 2011 19:06:43 +0000 (19:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- parse.patch applied upstream

Changed files:
    cmake-parse.patch -> 1.2
    cmake.spec -> 1.56

cmake-parse.patch [deleted file]
cmake.spec

diff --git a/cmake-parse.patch b/cmake-parse.patch
deleted file mode 100644 (file)
index 12c7e4a..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-commit 6fe8624b7ff39f8511f4f4d7ebcbc5681932a6a5
-Author: Ben Boeckel <ben.boeckel@kitware.com>
-Date:   Mon Nov 22 14:56:55 2010 -0500
-
-    Fix parsing of cache variables without a type
-    
-    These mainly come from the command line or manual entries in the
-    CMakeCache.txt file. We want to stop at the first '=' because this is
-    what is most likely to have been meant. The variable can be quoted if
-    the '=' is intended.
-    
-    Caveat: What if one wants both '"' and '=' in a variable name?
-
-diff --git a/Source/cmCacheManager.cxx b/Source/cmCacheManager.cxx
-index 2aa6236..fe6467a 100644
---- a/Source/cmCacheManager.cxx
-+++ b/Source/cmCacheManager.cxx
-@@ -97,10 +97,10 @@ bool cmCacheManager::ParseEntry(const char* entry,
-                                 std::string& var,
-                                 std::string& value)
- {
--  // input line is:         key:type=value
-+  // input line is:         key=value
-   static cmsys::RegularExpression reg(
--    "^([^:]*)=(.*[^\r\t ]|[\r\t ]*)[\r\t ]*$");
--  // input line is:         "key":type=value
-+    "^([^=]*)=(.*[^\r\t ]|[\r\t ]*)[\r\t ]*$");
-+  // input line is:         "key"=value
-   static cmsys::RegularExpression regQuoted(
-     "^\"([^\"]*)\"=(.*[^\r\t ]|[\r\t ]*)[\r\t ]*$");
-   bool flag = false;
index 39ab314b2b5e70d6d66cb120eba4a918e5a4899e..10b3bc19f1f5c045f4c5cf5cd4c95b2947402dba 100644 (file)
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.3
-Release:       2
+Version:       2.8.4
+Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: a76a44b93acf5e3badda9de111385921
+# Source0-md5: 209b7d1d04b2e00986538d74ba764fcf
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-tinfo.patch
-Patch2:                %{name}-parse.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -68,7 +67,6 @@ CMake.
 %patch0 -p1
 %endif
 %patch1 -p0
-%patch2 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
This page took 0.120265 seconds and 4 git commands to generate.