]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- recognize python 2.7 in FIND_PACKAGE(PythonLibs); rel 2 auto/th/cmake-2_8_2-2 auto/ti/cmake-2_8_2-2
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 17 Jul 2010 19:57:46 +0000 (19:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cmake.spec -> 1.50
    python-2.7.patch -> 1.1

cmake.spec
python-2.7.patch [new file with mode: 0644]

index 6c748c33abdcd652b75775f401497c1c4f3bd736..7b70bf598998cf882dc4b090f8ec651f42decd64 100644 (file)
@@ -7,18 +7,19 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
-#
+
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
 Version:       2.8.2
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
 # Source0-md5: 8c967d5264657a798f22ee23976ff0d9
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-tinfo.patch
+Patch2:                python-2.7.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libstdc++-devel
@@ -66,6 +67,7 @@ CMake.
 %patch0 -p1
 %endif
 %patch1 -p0
+%patch2 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -91,11 +93,10 @@ export LDFLAGS="%{rpmldflags}"
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}/cmake
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
+rm -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
diff --git a/python-2.7.patch b/python-2.7.patch
new file mode 100644 (file)
index 0000000..afe8052
--- /dev/null
@@ -0,0 +1,11 @@
+--- cmake-2.8.2/Modules/FindPythonLibs.cmake~  2010-06-28 18:15:57.000000000 +0300
++++ cmake-2.8.2/Modules/FindPythonLibs.cmake   2010-07-17 22:49:14.936169397 +0300
+@@ -27,7 +27,7 @@
+ # Search for the python framework on Apple.
+ CMAKE_FIND_FRAMEWORKS(Python)
+-FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
++FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+   STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
+   IF(WIN32)
+     FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
This page took 0.152904 seconds and 4 git commands to generate.