]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- rel 2; fixes version checking bug auto/th/cmake-3.2.3-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 21 Sep 2015 13:53:24 +0000 (15:53 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 21 Sep 2015 13:53:24 +0000 (15:53 +0200)
cmake-min-ver.patch [new file with mode: 0644]
cmake.spec

diff --git a/cmake-min-ver.patch b/cmake-min-ver.patch
new file mode 100644 (file)
index 0000000..f356a09
--- /dev/null
@@ -0,0 +1,40 @@
+From b9ec9392da21a3421e48c6961976060d872faffb Mon Sep 17 00:00:00 2001
+From: Rolf Eike Beer <eike@sf-mail.de>
+Date: Tue, 18 Aug 2015 12:14:43 +0200
+Subject: [PATCH 1/1] FindPkgConfig: remove variable dereference
+
+If CMAKE_MINIMUM_REQUIRED_VERSION is not set because no
+cmake_minimum_required() call is present this line can lead to an error as that
+string is empty so too few arguments are passed to if():
+
+See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeOutput.log".
+See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeError.log".
+CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:112 (elseif):
+  given arguments:
+
+    "VERSION_LESS" "3.1"
+
+  Unknown arguments specified
+Call Stack (most recent call first):
+  /usr/share/cmake/Modules/FindPkgConfig.cmake:501 (_pkgconfig_parse_options)
+  /usr/share/cmake/Modules/FindOpenSSL.cmake:43 (pkg_check_modules)
+---
+ Modules/FindPkgConfig.cmake |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
+index 526a62e..ae6903e 100644
+--- a/Modules/FindPkgConfig.cmake
++++ b/Modules/FindPkgConfig.cmake
+@@ -109,7 +109,7 @@ macro(_pkgconfig_parse_options _result _is_req _is_silent _no_cmake_path _no_cma
+       set(${_no_cmake_path} 1)
+       set(${_no_cmake_environment_path} 1)
+     endif()
+-  elseif(${CMAKE_MINIMUM_REQUIRED_VERSION} VERSION_LESS 3.1)
++  elseif(CMAKE_MINIMUM_REQUIRED_VERSION VERSION_LESS 3.1)
+     set(${_no_cmake_path} 1)
+     set(${_no_cmake_environment_path} 1)
+   endif()
+-- 
+1.7.10.4
+
index 7f58a44c7213ad74f8d35976c50c49b4c609b1f4..2347de36463034c48cab04be8eab8254809373ee 100644 (file)
@@ -15,7 +15,7 @@ Summary:      Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
 Version:       3.2.3
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v3.2/%{name}-%{version}.tar.gz
@@ -24,7 +24,7 @@ Patch0:               %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
 Patch2:                %{name}-findruby.patch
 Patch3:                %{name}-tests.patch
-
+Patch4:                cmake-min-ver.patch
 Patch5:                %{name}-findruby2.patch
 Patch6:                %{name}-findpython.patch
 Patch7:                %{name}-libx32.patch
@@ -119,7 +119,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-
+%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %if "%{_lib}" == "libx32"
This page took 0.123226 seconds and 4 git commands to generate.