]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- updated to 3.8.0 auto/th/cmake-3.8.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 27 Apr 2017 14:45:54 +0000 (16:45 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 27 Apr 2017 14:45:54 +0000 (16:45 +0200)
- added xmlrpc patch (fixes build with xmlrpc enabled)

cmake-xmlrpc.patch [new file with mode: 0644]
cmake.spec

diff --git a/cmake-xmlrpc.patch b/cmake-xmlrpc.patch
new file mode 100644 (file)
index 0000000..6b8809c
--- /dev/null
@@ -0,0 +1,19 @@
+--- cmake-3.8.0/CMakeLists.txt.orig    2017-04-10 17:23:06.000000000 +0200
++++ cmake-3.8.0/CMakeLists.txt 2017-04-26 22:06:31.968941358 +0200
+@@ -539,13 +539,15 @@
+   #---------------------------------------------------------------------
+   # Build XMLRPC library for CMake and CTest.
+   if(CTEST_USE_XMLRPC)
++    find_package(XMLRPC QUIET REQUIRED)
++    set(XMLRPC_BASE_LIBRARIES ${XMLRPC_BASE_LIBRARIES})
+     find_package(XMLRPC QUIET REQUIRED libwww-client)
+     if(NOT XMLRPC_FOUND)
+       message(FATAL_ERROR
+         "CTEST_USE_XMLRPC is ON but xmlrpc is not found!")
+     endif()
+     set(CMAKE_XMLRPC_INCLUDES ${XMLRPC_INCLUDE_DIRS})
+-    set(CMAKE_XMLRPC_LIBRARIES ${XMLRPC_LIBRARIES})
++    set(CMAKE_XMLRPC_LIBRARIES ${XMLRPC_LIBRARIES} ${XMLRPC_BASE_LIBRARIES})
+   endif()
+   #---------------------------------------------------------------------
index 7ed2751925337dbaf53f59fa9258af99b5a266fe..a0d92742706729200bf1058edc3dc33024995ac3 100644 (file)
@@ -1,4 +1,5 @@
 # TODO:
+# - system kwiml?
 # - extend libx32 patch to work also on 64-bit arch
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
@@ -8,18 +9,22 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
+%bcond_with    xmlrpc          # XMLRPC submission method in CTest
 %bcond_with    tests           # perform "make test"
 %bcond_without doc             # don't build documentation
 
+%if %{with bootstrap}
+%undefine      with_xmlrpc
+%endif
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.7.2
-Release:       2
+Version:       3.8.0
+Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       https://cmake.org/files/v3.7/%{name}-%{version}.tar.gz
-# Source0-md5: 79bd7e65cd81ea3aa2619484ad6ff25a
+Source0:       https://cmake.org/files/v3.8/%{name}-%{version}.tar.gz
+# Source0-md5: f28cba717ba38ad82a488daed8f45b5b
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libx32.patch
 Patch2:                %{name}-helpers.patch
@@ -27,13 +32,14 @@ Patch3:             %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
 Patch5:                man-syntax.patch
 Patch6:                imagemagick7.patch
+Patch7:                %{name}-xmlrpc.patch
 URL:           https://cmake.org/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5.0
 BuildRequires: Qt5Gui-devel >= 5.0
 BuildRequires: Qt5Widgets-devel >= 5.0
 %endif
-BuildRequires: curl-devel
+%{!?with_xmlrpc:BuildRequires: curl-devel}
 BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
 BuildRequires: libarchive-devel
@@ -42,10 +48,11 @@ BuildRequires:      libuv-devel
 BuildRequires: ncurses-devel > 5.9-3
 %{?with_gui:BuildRequires:     qt5-build >= 5.0}
 %{?with_gui:BuildRequires:     qt5-qmake >= 5.0}
+BuildRequires: rhash-devel
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
-%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
-BuildRequires: zlib-devel
+%{?with_xmlrpc:BuildRequires:  xmlrpc-c-devel >= 1.4.12-2}
+%{!?with_xmlrpc:BuildRequires: zlib-devel}
 Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -131,6 +138,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -157,7 +165,9 @@ export LDFLAGS="%{rpmldflags}"
        --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
-       --verbose
+       --verbose \
+       -- \
+       %{?with_xmlrpc:-DCTEST_USE_XMLRPC=ON}
 
 %{__make} VERBOSE=1
 
This page took 0.188973 seconds and 4 git commands to generate.