]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- added freetype2 patch (fixes freetype 2.5.1 detection) auto/th/cmake-2.8.12.1-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 6 Dec 2013 20:23:14 +0000 (21:23 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 6 Dec 2013 20:23:14 +0000 (21:23 +0100)
- release 2

cmake-freetype2.patch [new file with mode: 0644]
cmake.spec

diff --git a/cmake-freetype2.patch b/cmake-freetype2.patch
new file mode 100644 (file)
index 0000000..af96e33
--- /dev/null
@@ -0,0 +1,36 @@
+--- cmake-2.8.12.1/Modules/FindFreetype.cmake.orig     2013-11-05 20:07:22.000000000 +0100
++++ cmake-2.8.12.1/Modules/FindFreetype.cmake  2013-12-06 19:50:19.371935997 +0100
+@@ -56,7 +56,7 @@
+   PATH_SUFFIXES include/freetype2 include
+ )
+-find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+   HINTS
+     ENV FREETYPE_DIR
+   PATHS
+@@ -67,7 +67,7 @@
+     ENV GTKMM_BASEPATH
+     [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
+     [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
+-  PATH_SUFFIXES include/freetype2 include
++  PATH_SUFFIXES include/freetype2/freetype include/freetype2 include
+ )
+ find_library(FREETYPE_LIBRARY
+@@ -87,12 +87,12 @@
+ # set the user variables
+ if(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)
+-  set(FREETYPE_INCLUDE_DIRS "${FREETYPE_INCLUDE_DIR_ft2build};${FREETYPE_INCLUDE_DIR_freetype2}")
++  set(FREETYPE_INCLUDE_DIRS "${FREETYPE_INCLUDE_DIR_ft2build}")
+ endif()
+ set(FREETYPE_LIBRARIES "${FREETYPE_LIBRARY}")
+-if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h")
+-    file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h" freetype_version_str
++if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h")
++    file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h" freetype_version_str
+          REGEX "^#[\t ]*define[\t ]+FREETYPE_(MAJOR|MINOR|PATCH)[\t ]+[0-9]+$")
+     unset(FREETYPE_VERSION_STRING)
index f1b0830f8c1b4d5314777d737a5e3632615ae7a6..7d9204fc5f90b87504864898806a00a0aae5ddcf 100644 (file)
@@ -13,7 +13,7 @@ Summary:      Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
 Version:       2.8.12.1
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
@@ -22,6 +22,7 @@ Patch0:               %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
 Patch2:                %{name}-findruby.patch
 Patch3:                %{name}-tests.patch
+Patch4:                %{name}-freetype2.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -97,6 +98,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
This page took 0.081183 seconds and 4 git commands to generate.