]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
up to 3.27.6
[packages/cmake.git] / cmake.spec
index c3accf55f3afddfdf38ca372bcb266a34e411812..fd92643125d0098e291f029a5eb29c642d13fbc0 100644 (file)
@@ -1,31 +1,34 @@
 # TODO:
-# - system kwiml?
+# - system kwiml >= 1.0?
 # - make lib64/libx32 patch changes applicable everywhere
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
 #   (is there any standard way???)
+# - FindJNI.cmake module is a PoS full of random incorrect paths,
+#   needs lib64/libx32 awareness
 #
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
-%bcond_without gui             # don't build gui package
+%bcond_without gui             # gui package
 %bcond_with    tests           # perform "make test"
-%bcond_without doc             # don't build documentation
+%bcond_without doc             # documentation
 
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.16.4
+Version:       3.27.6
 Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       https://cmake.org/files/v3.16/%{name}-%{version}.tar.gz
-# Source0-md5: e3dacb6b612a6b06f7054c7fb4e18616
+Source0:       https://cmake.org/files/v3.27/%{name}-%{version}.tar.gz
+# Source0-md5: 900aad400c67bf40238e5c0119128549
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libx32.patch
-Patch2:                %{name}-helpers.patch
+Patch2:                %{name}-jni.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
+Patch5:                disable-completness-check.patch
 URL:           https://cmake.org/
 # system zlib,bzip2,xz,zstd used only when without system libarchive
 %if %{with gui}
@@ -33,21 +36,32 @@ BuildRequires:      Qt5Core-devel >= 5.0
 BuildRequires: Qt5Gui-devel >= 5.0
 BuildRequires: Qt5Widgets-devel >= 5.0
 %endif
+BuildRequires: automake
+BuildRequires: cppdap-devel
 BuildRequires: curl-devel
 BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
-BuildRequires: libarchive-devel
-BuildRequires: libstdc++-devel
-BuildRequires: libuv-devel
+BuildRequires: libarchive-devel >= 3.3.3
+%ifnarch %arch_with_atomics64
+BuildRequires: libatomic-devel
+%endif
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libuv-devel >= 1.28.0
 BuildRequires: ncurses-devel > 5.9-3
 BuildRequires: ncurses-ext-devel > 5.9-3
+BuildRequires: nghttp2-devel
 %{?with_gui:BuildRequires:     qt5-build >= 5.0}
 %{?with_gui:BuildRequires:     qt5-qmake >= 5.0}
 BuildRequires: rhash-devel
-BuildRequires: rpmbuild(macros) >= 1.167
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 2.025
 %{?with_doc:BuildRequires:     sphinx-pdg}
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires:      filesystem >= 3.0-52
+Requires:      libarchive >= 3.3.3
+Requires:      libuv >= 1.28.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -83,7 +97,10 @@ Dokumentacja do pakietu CMake w formacie HTML.
 Summary:       Qt GUI for CMake
 Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
 Group:         Development/Tools
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk-update-icon-cache
 Requires:      %{name} = %{version}-%{release}
+Requires:      hicolor-icon-theme
 
 %description gui
 This package contains the Qt based GUI for CMake.
@@ -108,10 +125,8 @@ Summary:   bash-completion for cmake
 Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion >= 2.0
-%if "%{_rpmversion}" >= "5"
+Requires:      bash-completion >= 1:2.0
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-%{name}
 bash-completion for cmake.
@@ -130,11 +145,23 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
+       Modules/Compiler/XL-Fortran/cpp
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
 SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
 SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
+SET (CMAKE_SYSTEM_NAME "Linux" CACHE STRING " " FORCE)
+SET (CMAKE_SYSTEM_VERSION "%(uname -r)" CACHE STRING " " FORCE)
+SET (CMAKE_CROSSCOMPILING FALSE CACHE BOOL " " FORCE)
+%ifarch x32
+SET (CMAKE_SYSTEM_PROCESSOR "x86_64" CACHE STRING " " FORCE)
+%else
+SET (CMAKE_SYSTEM_PROCESSOR "%{_target_cpu}" CACHE STRING " " FORCE)
+%endif
 EOF
 
 # cleanup backups after patching, modules are copied as-is
@@ -156,6 +183,7 @@ export LDFLAGS="%{rpmldflags}"
        --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
+       %{?__jobs:--parallel=%{__jobs}} \
        --verbose
 
 %{__make} \
@@ -165,14 +193,26 @@ export LDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# just a bit more recent than packaged in vim.spec
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vim
+# packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post gui
+%update_desktop_database_post
+%update_icon_cache hicolor
+
+%postun gui
+%update_desktop_database_postun
+%update_icon_cache hicolor
+
 %files
 %defattr(644,root,root,755)
 %doc Copyright.txt README.rst *.gif
@@ -189,6 +229,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man7/cmake-buildsystem.7*
 %{_mandir}/man7/cmake-commands.7*
 %{_mandir}/man7/cmake-compile-features.7*
+%{_mandir}/man7/cmake-configure-log.7*
 %{_mandir}/man7/cmake-developer.7*
 %{_mandir}/man7/cmake-env-variables.7*
 %{_mandir}/man7/cmake-file-api.7*
@@ -198,6 +239,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man7/cmake-modules.7*
 %{_mandir}/man7/cmake-packages.7*
 %{_mandir}/man7/cmake-policies.7*
+%{_mandir}/man7/cmake-presets.7*
 %{_mandir}/man7/cmake-properties.7*
 %{_mandir}/man7/cmake-qt.7*
 %{_mandir}/man7/cmake-server.7*
@@ -209,7 +251,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
 %{_datadir}/cmake/Templates
-%{_datadir}/cmake/editors
 %{_datadir}/cmake/include
 %{_aclocaldir}/cmake.m4
 
This page took 0.030547 seconds and 4 git commands to generate.