]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- pl for -emacs and bash-completion-
[packages/cmake.git] / cmake.spec
index 3ca072542cdc7baa86461709de2482789084667d..e554ae2a02ade85ddda3fb4d3b7ade56d4fe7f2d 100644 (file)
@@ -1,22 +1,34 @@
+# TODO:
+# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
+#   (and default non-verbose makefiles are hiding it!)
+# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
+#   (is there any standard way???)
 #
 # Conditional build:
-%bcond_with    bootstrap # use internal versions of some libraries
-#
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
+
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.6.0
-Release:       0.1
+Version:       2.8.9
+Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
-# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
-Patch1:                %{name}-lib64.patch
-URL:           http://www.cmake.org/HTML/Index.html
+Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
+# Source0-md5: 801f4c87f8b604f727df5bf1f05a59e7
+Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-helpers.patch
+URL:           http://www.cmake.org/
+%{?with_gui:BuildRequires:     QtGui-devel}
+BuildRequires: libarchive-devel
 BuildRequires: libstdc++-devel
-BuildRequires: ncurses-devel
+BuildRequires: ncurses-devel > 5.9-3
+%{?with_gui:BuildRequires:     qt4-build}
+%{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
-%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel}
+%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
+Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -33,19 +45,57 @@ CMake służy do sterowania procesem kompilacji oprogramowania przy
 użyciu prostych plików konfiguracyjnych niezależnych od platformy i
 kompilatora. CMake generuje natywne pliki makefile i workspace,
 których można używać w wybranym środowisku kompilatora. CMake jest
-dość przemyślany: może obsłużyć złożone środowiska wymagające
+dość wyrafinowany: może obsłużyć złożone środowiska wymagające
 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
 dziedziczenie szablonów.
 
+%package gui
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
+
+%package emacs
+Summary:       Emacs mode for cmake files
+Summary(pl.UTF-8):     Tryb Emacsa dla plików cmake'a
+Group:         Development/Tools
+
+%description emacs
+Emacs mode for cmake files.
+
+%description emacs -l pl.UTF-8
+Tryb Emacsa dla plików cmake'a.
+
+%package -n bash-completion-%{name}
+Summary:       bash-completion for cmake
+Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+
+%description -n bash-completion-%{name}
+bash-completion for cmake.
+
+%description -n bash-completion-%{name} -l pl.UTF-8
+Bashowe dopełnianie parametrów dla cmake'a.
+
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
-%patch1 -p1
+%patch0 -p1
 %endif
+%patch1 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
-SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
+SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
 EOF
 
 %build
@@ -60,9 +110,11 @@ export LDFLAGS="%{rpmldflags}"
        --datadir=/share/cmake \
        --init=init.cmake \
        %{!?with_bootstrap:--system-libs} \
+       %{?with_gui:--qt-gui} \
+       --qt-qmake=/usr/bin/qmake-qt4 \
        --verbose
 
-%{__make}
+%{__make} VERBOSE=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -70,7 +122,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -82,5 +134,39 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/cmake
 %attr(755,root,root) %{_bindir}/cpack
 %attr(755,root,root) %{_bindir}/ctest
-%{_mandir}/man1/*.1*
-%{_datadir}/cmake
+%{_mandir}/man1/ccmake.1*
+%{_mandir}/man1/cmake.1*
+%{_mandir}/man1/cmakecommands.1*
+%{_mandir}/man1/cmakecompat.1*
+%{_mandir}/man1/cmakemodules.1*
+%{_mandir}/man1/cmakepolicies.1*
+%{_mandir}/man1/cmakeprops.1*
+%{_mandir}/man1/cmakevars.1*
+%{_mandir}/man1/cpack.1*
+%{_mandir}/man1/ctest.1*
+# top cmake/Modules dirs belong to filesystem
+%{_datadir}/cmake/Modules/.NoDartCoverage
+%{_datadir}/cmake/Modules/*
+%{_datadir}/cmake/Templates
+%{_datadir}/cmake/include
+%{_aclocaldir}/cmake.m4
+
+%if %{with gui}
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/cmake-gui
+%{_datadir}/mime/packages/cmakecache.xml
+%{_desktopdir}/CMake.desktop
+%{_pixmapsdir}/CMakeSetup32.png
+%{_mandir}/man1/cmake-gui.1*
+%endif
+
+%files emacs
+%defattr(644,root,root,755)
+%{_datadir}/emacs/site-lisp/cmake-mode.el
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+/etc/bash_completion.d/cmake
+/etc/bash_completion.d/cpack
+/etc/bash_completion.d/ctest
This page took 0.113457 seconds and 4 git commands to generate.