]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- pl for -emacs and bash-completion-
[packages/cmake.git] / cmake.spec
index 10b3bc19f1f5c045f4c5cf5cd4c95b2947402dba..e554ae2a02ade85ddda3fb4d3b7ade56d4fe7f2d 100644 (file)
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.4
+Version:       2.8.9
 Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: 209b7d1d04b2e00986538d74ba764fcf
+# Source0-md5: 801f4c87f8b604f727df5bf1f05a59e7
 Patch0:                %{name}-lib64.patch
-Patch1:                %{name}-tinfo.patch
+Patch1:                %{name}-helpers.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
 BuildRequires: libstdc++-devel
-BuildRequires: ncurses-devel
+BuildRequires: ncurses-devel > 5.9-3
 %{?with_gui:BuildRequires:     qt4-build}
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
 %{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
+Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,15 +62,40 @@ This package contains the Qt based GUI for CMake.
 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
 CMake.
 
+%package emacs
+Summary:       Emacs mode for cmake files
+Summary(pl.UTF-8):     Tryb Emacsa dla plików cmake'a
+Group:         Development/Tools
+
+%description emacs
+Emacs mode for cmake files.
+
+%description emacs -l pl.UTF-8
+Tryb Emacsa dla plików cmake'a.
+
+%package -n bash-completion-%{name}
+Summary:       bash-completion for cmake
+Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+
+%description -n bash-completion-%{name}
+bash-completion for cmake.
+
+%description -n bash-completion-%{name} -l pl.UTF-8
+Bashowe dopełnianie parametrów dla cmake'a.
+
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
-%patch1 -p0
+%patch1 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
 EOF
 
 %build
@@ -92,11 +118,11 @@ export LDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/cmake
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_prefix}/doc
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -118,8 +144,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/cmakevars.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
-%{_datadir}/cmake
-%dir %{_libdir}/cmake
+# top cmake/Modules dirs belong to filesystem
+%{_datadir}/cmake/Modules/.NoDartCoverage
+%{_datadir}/cmake/Modules/*
+%{_datadir}/cmake/Templates
+%{_datadir}/cmake/include
+%{_aclocaldir}/cmake.m4
 
 %if %{with gui}
 %files gui
@@ -130,3 +160,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_pixmapsdir}/CMakeSetup32.png
 %{_mandir}/man1/cmake-gui.1*
 %endif
+
+%files emacs
+%defattr(644,root,root,755)
+%{_datadir}/emacs/site-lisp/cmake-mode.el
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+/etc/bash_completion.d/cmake
+/etc/bash_completion.d/cpack
+/etc/bash_completion.d/ctest
This page took 0.027781 seconds and 4 git commands to generate.