]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- pl for -gui
[packages/cmake.git] / cmake.spec
index c0447fa64c0721588510dfd6c5853587f66aad52..c56a7e0508f62768a058d6fb822d08dd3c5c8e83 100644 (file)
@@ -5,20 +5,21 @@
 #   (is there any standard way???)
 #
 # Conditional build:
-%bcond_with    bootstrap # use internal versions of some libraries
-%bcond_without gui
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
 #
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
 Version:       2.6.1
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
 # Source0-md5: 6717f4bc3cfcced4172ad98660ce7599
-Patch1:                %{name}-lib64.patch
-URL:           http://www.cmake.org/HTML/index.html
+Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-ar.patch
+URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
@@ -47,22 +48,27 @@ konfiguracji systemu, generowanie preprocesora, generowanie kodu
 i dziedziczenie szablonów.
 
 %package gui
-Summary:       Qt GUI for %{name}
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 
-%description    gui
-The %{name}-gui package contains the Qt based GUI for CMake.
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
 
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
-%patch1 -p1
+%patch0 -p1
 %endif
+%patch1 -p0
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
-SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
 EOF
 
 %build
This page took 0.083685 seconds and 4 git commands to generate.