]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- 2.6.0 (functionality of ncurses.patch included)
[packages/cmake.git] / cmake.spec
index a191a3eba47c83daeadfc28b10dbbc22a0eaad55..adce3c4780acac2860076dd6ef7f6466591065e7 100644 (file)
@@ -1,18 +1,22 @@
+#
+# Conditional build:
+%bcond_with    bootstrap # use internal versions of some libraries
+#
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.4.8
-Release:       1
+Version:       2.6.0
+Release:       0.1
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
-# Source0-md5: f5dd061c31765a49dc17ae8bdc986779
-Patch0:                %{name}-ncurses.patch
+Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
+# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
 Patch1:                %{name}-lib64.patch
 URL:           http://www.cmake.org/HTML/Index.html
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
 BuildRequires: rpmbuild(macros) >= 1.167
+%{?!with_bootstrap:BuildRequires:      xmlrpc-c-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -35,13 +39,13 @@ dziedziczenie szablonów.
 
 %prep
 %setup -q
-%patch0 -p1
 %if "%{_lib}" == "lib64"
 %patch1 -p1
 %endif
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
+SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
 EOF
 
 %build
@@ -49,11 +53,13 @@ export CC="%{__cc}"
 export CXX="%{__cxx}"
 export CFLAGS="%{rpmcflags}"
 export CXXFLAGS="%{rpmcxxflags}"
+export LDFLAGS="%{rpmldflags}"
 ./bootstrap \
        --prefix=%{_prefix} \
        --mandir=/share/man \
        --datadir=/share/cmake \
        --init=init.cmake \
+       %{?!with_bootstrap:--system-libs }\
        --verbose
 
 %{__make}
This page took 0.07158 seconds and 4 git commands to generate.