]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- added %{_libdir}/cmake directory; many packages require it, and some broken
[packages/cmake.git] / cmake.spec
index 24dce77ccb334d8e2a8ab352cac24fd7570447dc..aab7396ef648f5b3c98b43850b2d7a2f0b4b4231 100644 (file)
@@ -5,20 +5,19 @@
 #   (is there any standard way???)
 #
 # Conditional build:
-%bcond_with    bootstrap # use internal versions of some libraries
-%bcond_without gui
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
 #
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.6.1
-Release:       2
+Version:       2.6.4
+Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
-# Source0-md5: 6717f4bc3cfcced4172ad98660ce7599
+# Source0-md5: 50f387d0436696c4a68b5512a72c9cde
 Patch0:                %{name}-lib64.patch
-Patch1:                %{name}-ar.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libstdc++-devel
@@ -26,7 +25,7 @@ BuildRequires:        ncurses-devel
 %{?with_gui:BuildRequires:     qt4-build}
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
-%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel}
+%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -48,19 +47,23 @@ konfiguracji systemu, generowanie preprocesora, generowanie kodu
 i dziedziczenie szablonów.
 
 %package gui
-Summary:       Qt GUI for %{name}
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 
-%description    gui
-The %{name}-gui package contains the Qt based GUI for CMake.
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
 
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
-%patch1 -p0
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -85,6 +88,7 @@ export LDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/cmake
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -103,6 +107,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ctest
 %{_mandir}/man1/*.1*
 %{_datadir}/cmake
+%{_libdir}/cmake
 
 %files gui
 %defattr(644,root,root,755)
This page took 0.058085 seconds and 4 git commands to generate.