]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- cmake/Modules top dirs moved to filesystem (>= 3.0-46), so that packages like libmo...
[packages/cmake.git] / cmake.spec
index 8360bfce2dcde8f13d50ca124d472275c1b44ce0..71558a5b5be5b2a8b1d120026ae109f945ab427e 100644 (file)
@@ -1,17 +1,34 @@
+# TODO:
+# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
+#   (and default non-verbose makefiles are hiding it!)
+# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
+#   (is there any standard way???)
+#
+# Conditional build:
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
+
 Summary:       Cross-platform, open-source make system
-Summary(pl):   Wieloplatformowy system make o otwartych ¼ród³ach
+Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.4.1
-Release:       1
+Version:       2.8.4
+Release:       2
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
-# Source0-md5: b3a4588015af8157d9161da771cc5814
-Patch0:                %{name}-ncurses.patch
-URL:           http://www.cmake.org/HTML/Index.html
+Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
+# Source0-md5: 209b7d1d04b2e00986538d74ba764fcf
+Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-tinfo.patch
+URL:           http://www.cmake.org/
+%{?with_gui:BuildRequires:     QtGui-devel}
+BuildRequires: libarchive-devel
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
+%{?with_gui:BuildRequires:     qt4-build}
+%{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
+%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
+Requires:      filesystem >= 3.0-46
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -23,21 +40,37 @@ possible to support complex environments requiring system
 configuration, pre-processor generation, code generation, and template
 instantiation.
 
-%description -l pl
-CMake s³u¿y do sterowania procesem kompilacji oprogramowania przy
-u¿yciu prostych plików konfiguracyjnych niezale¿nych od platformy i
+%description -l pl.UTF-8
+CMake służy do sterowania procesem kompilacji oprogramowania przy
+użyciu prostych plików konfiguracyjnych niezależnych od platformy i
 kompilatora. CMake generuje natywne pliki makefile i workspace,
-których mo¿na u¿ywaæ w wybranym ¶rodowisku kompilatora. CMake jest
-do¶æ przemy¶lany: mo¿e obs³u¿yæ z³o¿one ¶rodowiska wymagaj±ce
+których można używać w wybranym środowisku kompilatora. CMake jest
+dość wyrafinowany: może obsłużyć złożone środowiska wymagające
 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
-dziedziczenie szablonów.
+dziedziczenie szablonów.
+
+%package gui
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
 
 %prep
 %setup -q
+%if "%{_lib}" == "lib64"
 %patch0 -p1
+%endif
+%patch1 -p0
 
 cat > "init.cmake" <<EOF
-SET (CURSES_INCLUDE_PATH "%{_includedir}/ncurses" CACHE PATH " " FORCE)
+SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
 EOF
 
 %build
@@ -45,32 +78,60 @@ export CC="%{__cc}"
 export CXX="%{__cxx}"
 export CFLAGS="%{rpmcflags}"
 export CXXFLAGS="%{rpmcxxflags}"
+export LDFLAGS="%{rpmldflags}"
 ./bootstrap \
        --prefix=%{_prefix} \
        --mandir=/share/man \
        --datadir=/share/cmake \
        --init=init.cmake \
+       %{!?with_bootstrap:--system-libs} \
+       %{?with_gui:--qt-gui} \
+       --qt-qmake=/usr/bin/qmake-qt4 \
        --verbose
 
-%{__make}
+%{__make} VERBOSE=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
+install -d $RPM_BUILD_ROOT%{_libdir}/cmake
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
+rm -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog.* Copyright.txt *.gif *.pdf Docs/{cmake,ctest}.{txt,html}
+%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
 %attr(755,root,root) %{_bindir}/ccmake
 %attr(755,root,root) %{_bindir}/cmake
 %attr(755,root,root) %{_bindir}/cpack
 %attr(755,root,root) %{_bindir}/ctest
-%{_mandir}/man1/*.1*
-%{_datadir}/cmake
+%{_mandir}/man1/ccmake.1*
+%{_mandir}/man1/cmake.1*
+%{_mandir}/man1/cmakecommands.1*
+%{_mandir}/man1/cmakecompat.1*
+%{_mandir}/man1/cmakemodules.1*
+%{_mandir}/man1/cmakepolicies.1*
+%{_mandir}/man1/cmakeprops.1*
+%{_mandir}/man1/cmakevars.1*
+%{_mandir}/man1/cpack.1*
+%{_mandir}/man1/ctest.1*
+# top cmake/Modules dirs belong to filesystem
+%{_datadir}/cmake/Modules/.NoDartCoverage
+%{_datadir}/cmake/Modules/*
+%{_datadir}/cmake/Templates
+%{_datadir}/cmake/include
+%dir %{_libdir}/cmake
+
+%if %{with gui}
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/cmake-gui
+%{_datadir}/mime/packages/cmakecache.xml
+%{_desktopdir}/CMake.desktop
+%{_pixmapsdir}/CMakeSetup32.png
+%{_mandir}/man1/cmake-gui.1*
+%endif
This page took 0.046976 seconds and 4 git commands to generate.