]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- if you say dir, then do dir
[packages/cmake.git] / cmake.spec
index adce3c4780acac2860076dd6ef7f6466591065e7..5800bb5e9f656ddc39be95701ad72fc881e8c8b7 100644 (file)
@@ -1,22 +1,31 @@
+# TODO:
+# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
+#   (and default non-verbose makefiles are hiding it!)
+# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
+#   (is there any standard way???)
 #
 # Conditional build:
-%bcond_with    bootstrap # use internal versions of some libraries
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
 #
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.6.0
-Release:       0.1
+Version:       2.6.4
+Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
-# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
-Patch1:                %{name}-lib64.patch
-URL:           http://www.cmake.org/HTML/Index.html
+# Source0-md5: 50f387d0436696c4a68b5512a72c9cde
+Patch0:                %{name}-lib64.patch
+URL:           http://www.cmake.org/
+%{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
+%{?with_gui:BuildRequires:     qt4-build}
+%{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
-%{?!with_bootstrap:BuildRequires:      xmlrpc-c-devel}
+%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,22 +39,34 @@ instantiation.
 
 %description -l pl.UTF-8
 CMake służy do sterowania procesem kompilacji oprogramowania przy
-użyciu prostych plików konfiguracyjnych niezależnych od platformy i
-kompilatora. CMake generuje natywne pliki makefile i workspace,
+użyciu prostych plików konfiguracyjnych niezależnych od platformy
+kompilatora. CMake generuje natywne pliki makefile i workspace,
 których można używać w wybranym środowisku kompilatora. CMake jest
 dość przemyślany: może obsłużyć złożone środowiska wymagające
-konfiguracji systemu, generowanie preprocesora, generowanie kodu i
-dziedziczenie szablonów.
+konfiguracji systemu, generowanie preprocesora, generowanie kodu
+i dziedziczenie szablonów.
+
+%package gui
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
 
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
-%patch1 -p1
+%patch0 -p1
 %endif
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
-SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
 EOF
 
 %build
@@ -59,13 +80,15 @@ export LDFLAGS="%{rpmldflags}"
        --mandir=/share/man \
        --datadir=/share/cmake \
        --init=init.cmake \
-       %{?!with_bootstrap:--system-libs }\
+       %{!?with_bootstrap:--system-libs} \
+       %{?with_gui:--qt-gui} \
        --verbose
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/cmake
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -84,3 +107,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ctest
 %{_mandir}/man1/*.1*
 %{_datadir}/cmake
+%dir %{_libdir}/cmake
+
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/cmake-gui
+%{_datadir}/mime/packages/cmakecache.xml
+%{_desktopdir}/CMake.desktop
+%{_pixmapsdir}/CMakeSetup.png
This page took 0.02705 seconds and 4 git commands to generate.