]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- updated to 2.4.7
[packages/cmake.git] / cmake.spec
index d5eb062dcf4da4e80e059aafdcf721cc1a2adafc..05f8be5b51b199c862135d81abeb1082d3312c58 100644 (file)
@@ -1,56 +1,76 @@
-%define name cmake
-%define version 1.4.7
-%define release 1
-
-Summary: Cross-platform, open-source make system
-Name: %name
-Version: %version
-Release: %release
-License: BSD
-Group: Development/Other
-Url: http://www.cmake.org/HTML/Index.html
-Source: CMake%{version}-src-unix.tar.bz2
-Patch0: cmake-ncurses.patch
-BuildRoot: %_tmppath/%name-%version
+Summary:       Cross-platform, open-source make system
+Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
+Name:          cmake
+Version:       2.4.7
+Release:       1
+License:       BSD
+Group:         Development/Building
+Source0:       http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
+# Source0-md5: 4476c423b8f74266136964e42ea88028
+Patch0:                %{name}-ncurses.patch
+URL:           http://www.cmake.org/HTML/Index.html
+BuildRequires: libstdc++-devel
+BuildRequires: ncurses-devel
+BuildRequires: rpmbuild(macros) >= 1.167
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-CMake is used to control the software compilation process using
-simple platform and compiler independent configuration files.
-CMake generates native makefiles and workspaces that can be
-used in the compiler environment of your choice. CMake is quite
-sophisticated: it is possible to support complex environments
-requiring system configuration, pre-processor generation, code
-generation, and template instantiation.
+CMake is used to control the software compilation process using simple
+platform and compiler independent configuration files. CMake generates
+native makefiles and workspaces that can be used in the compiler
+environment of your choice. CMake is quite sophisticated: it is
+possible to support complex environments requiring system
+configuration, pre-processor generation, code generation, and template
+instantiation.
+
+%description -l pl.UTF-8
+CMake służy do sterowania procesem kompilacji oprogramowania przy
+użyciu prostych plików konfiguracyjnych niezależnych od platformy i
+kompilatora. CMake generuje natywne pliki makefile i workspace,
+których można używać w wybranym środowisku kompilatora. CMake jest
+dość przemyślany: może obsłużyć złożone środowiska wymagające
+konfiguracji systemu, generowanie preprocesora, generowanie kodu i
+dziedziczenie szablonów.
 
 %prep
-%setup -q -n CMake-%version
+%setup -q
 %patch0 -p1
 
+cat > "init.cmake" <<EOF
+SET (CURSES_INCLUDE_PATH "%{_includedir}/ncurses" CACHE PATH " " FORCE)
+EOF
+
 %build
-CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
-%configure2_13
-%{__make} \
-       CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+export CFLAGS="%{rpmcflags}"
+export CXXFLAGS="%{rpmcxxflags}"
+./bootstrap \
+       --prefix=%{_prefix} \
+       --mandir=/share/man \
+       --datadir=/share/cmake \
+       --init=init.cmake \
+       --verbose
+
+%{__make}
 
 %install
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT/%_datadir/
-bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(-,root,root)
-%doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
-%_bindir/ccmake
-%_bindir/cmake
-%_bindir/cmaketest
-%_bindir/ctest
-%_mandir/man1/*.1.*
-%_datadir/CMake/Modules
-%_datadir/CMake/Templates
-
-%changelog
-* Thu Jan 9 2003 Austin Acton <aacton@yorku.ca> 1.4.7-1mdk
-- initial package
+%defattr(644,root,root,755)
+%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
+%attr(755,root,root) %{_bindir}/ccmake
+%attr(755,root,root) %{_bindir}/cmake
+%attr(755,root,root) %{_bindir}/cpack
+%attr(755,root,root) %{_bindir}/ctest
+%{_mandir}/man1/*.1*
+%{_datadir}/cmake
This page took 0.04203 seconds and 4 git commands to generate.