]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- fix ar detection
[packages/cmake.git] / cmake.spec
1 # TODO:
2 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3 #   (and default non-verbose makefiles are hiding it!)
4 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5 #   (is there any standard way???)
6 #
7 # Conditional build:
8 %bcond_with     bootstrap # use internal versions of some libraries
9 %bcond_without  gui
10 #
11 Summary:        Cross-platform, open-source make system
12 Summary(pl.UTF-8):      Wieloplatformowy system make o otwartych źródłach
13 Name:           cmake
14 Version:        2.6.1
15 Release:        2
16 License:        BSD
17 Group:          Development/Building
18 Source0:        http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
19 # Source0-md5:  6717f4bc3cfcced4172ad98660ce7599
20 Patch0:         %{name}-lib64.patch
21 Patch1:         %{name}-ar.patch
22 URL:            http://www.cmake.org/HTML/
23 %{?with_gui:BuildRequires:      QtGui-devel}
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  ncurses-devel
26 %{?with_gui:BuildRequires:      qt4-build}
27 %{?with_gui:BuildRequires:      qt4-qmake}
28 BuildRequires:  rpmbuild(macros) >= 1.167
29 %{!?with_bootstrap:BuildRequires:       xmlrpc-c-devel}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 CMake is used to control the software compilation process using simple
34 platform and compiler independent configuration files. CMake generates
35 native makefiles and workspaces that can be used in the compiler
36 environment of your choice. CMake is quite sophisticated: it is
37 possible to support complex environments requiring system
38 configuration, pre-processor generation, code generation, and template
39 instantiation.
40
41 %description -l pl.UTF-8
42 CMake służy do sterowania procesem kompilacji oprogramowania przy
43 użyciu prostych plików konfiguracyjnych niezależnych od platformy
44 i kompilatora. CMake generuje natywne pliki makefile i workspace,
45 których można używać w wybranym środowisku kompilatora. CMake jest
46 dość przemyślany: może obsłużyć złożone środowiska wymagające
47 konfiguracji systemu, generowanie preprocesora, generowanie kodu
48 i dziedziczenie szablonów.
49
50 %package gui
51 Summary:        Qt GUI for %{name}
52 Group:          Development/Tools
53 Requires:       %{name} = %{version}-%{release}
54
55 %description    gui
56 The %{name}-gui package contains the Qt based GUI for CMake.
57
58 %prep
59 %setup -q
60 %if "%{_lib}" == "lib64"
61 %patch0 -p1
62 %endif
63 %patch1 -p0
64
65 cat > "init.cmake" <<EOF
66 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
67 EOF
68
69 %build
70 export CC="%{__cc}"
71 export CXX="%{__cxx}"
72 export CFLAGS="%{rpmcflags}"
73 export CXXFLAGS="%{rpmcxxflags}"
74 export LDFLAGS="%{rpmldflags}"
75 ./bootstrap \
76         --prefix=%{_prefix} \
77         --mandir=/share/man \
78         --datadir=/share/cmake \
79         --init=init.cmake \
80         %{!?with_bootstrap:--system-libs} \
81         %{?with_gui:--qt-gui} \
82         --verbose
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
100 %attr(755,root,root) %{_bindir}/ccmake
101 %attr(755,root,root) %{_bindir}/cmake
102 %attr(755,root,root) %{_bindir}/cpack
103 %attr(755,root,root) %{_bindir}/ctest
104 %{_mandir}/man1/*.1*
105 %{_datadir}/cmake
106
107 %files gui
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/cmake-gui
110 %{_datadir}/mime/packages/cmakecache.xml
111 %{_desktopdir}/CMake.desktop
112 %{_pixmapsdir}/CMakeSetup.png
This page took 0.034042 seconds and 4 git commands to generate.