]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- 2.4.4
[packages/cmake.git] / cmake.spec
1 Summary:        Cross-platform, open-source make system
2 Summary(pl):    Wieloplatformowy system make o otwartych ¼ród³ach
3 Name:           cmake
4 Version:        2.4.4
5 Release:        1
6 License:        BSD
7 Group:          Development/Building
8 Source0:        http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
9 # Source0-md5:  8c99af9e6e70f154314cf0d160b61e6e
10 Patch0:         %{name}-ncurses.patch
11 URL:            http://www.cmake.org/HTML/Index.html
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  ncurses-devel
14 BuildRequires:  rpmbuild(macros) >= 1.167
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 CMake is used to control the software compilation process using simple
19 platform and compiler independent configuration files. CMake generates
20 native makefiles and workspaces that can be used in the compiler
21 environment of your choice. CMake is quite sophisticated: it is
22 possible to support complex environments requiring system
23 configuration, pre-processor generation, code generation, and template
24 instantiation.
25
26 %description -l pl
27 CMake s³u¿y do sterowania procesem kompilacji oprogramowania przy
28 u¿yciu prostych plików konfiguracyjnych niezale¿nych od platformy i
29 kompilatora. CMake generuje natywne pliki makefile i workspace,
30 których mo¿na u¿ywaæ w wybranym ¶rodowisku kompilatora. CMake jest
31 do¶æ przemy¶lany: mo¿e obs³u¿yæ z³o¿one ¶rodowiska wymagaj±ce
32 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
33 dziedziczenie szablonów.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38
39 cat > "init.cmake" <<EOF
40 SET (CURSES_INCLUDE_PATH "%{_includedir}/ncurses" CACHE PATH " " FORCE)
41 EOF
42
43 %build
44 export CC="%{__cc}"
45 export CXX="%{__cxx}"
46 export CFLAGS="%{rpmcflags}"
47 export CXXFLAGS="%{rpmcxxflags}"
48 ./bootstrap \
49         --prefix=%{_prefix} \
50         --mandir=/share/man \
51         --datadir=/share/cmake \
52         --init=init.cmake \
53         --verbose
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
71 %attr(755,root,root) %{_bindir}/ccmake
72 %attr(755,root,root) %{_bindir}/cmake
73 %attr(755,root,root) %{_bindir}/cpack
74 %attr(755,root,root) %{_bindir}/ctest
75 %{_mandir}/man1/*.1*
76 %{_datadir}/cmake
This page took 0.033664 seconds and 4 git commands to generate.