]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- rel 2; fix imagemagick detection from upstream
[packages/cmake.git] / cmake.spec
1 # TODO:
2 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3 #   (and default non-verbose makefiles are hiding it!)
4 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5 #   (is there any standard way???)
6 #
7 # Conditional build:
8 %bcond_with     bootstrap       # use internal versions of some libraries
9 %bcond_without  gui             # don't build gui package
10 %bcond_without  tests
11
12 Summary:        Cross-platform, open-source make system
13 Summary(pl.UTF-8):      Wieloplatformowy system make o otwartych źródłach
14 Name:           cmake
15 Version:        2.8.11.1
16 Release:        2
17 License:        BSD
18 Group:          Development/Building
19 Source0:        http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
20 # Source0-md5:  df5324a3b203373a9e0a04b924281a43
21 Patch0:         %{name}-lib64.patch
22 Patch1:         %{name}-helpers.patch
23 Patch2:         cmake-findruby.patch
24 Patch3:         cmake-git.patch
25 URL:            http://www.cmake.org/
26 %{?with_gui:BuildRequires:      QtGui-devel}
27 BuildRequires:  libarchive-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  ncurses-devel > 5.9-3
30 %{?with_gui:BuildRequires:      qt4-build}
31 %{?with_gui:BuildRequires:      qt4-qmake}
32 BuildRequires:  rpmbuild(macros) >= 1.167
33 %{!?with_bootstrap:BuildRequires:       xmlrpc-c-devel >= 1.4.12-2}
34 Requires:       filesystem >= 3.0-52
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 CMake is used to control the software compilation process using simple
39 platform and compiler independent configuration files. CMake generates
40 native makefiles and workspaces that can be used in the compiler
41 environment of your choice. CMake is quite sophisticated: it is
42 possible to support complex environments requiring system
43 configuration, pre-processor generation, code generation, and template
44 instantiation.
45
46 %description -l pl.UTF-8
47 CMake służy do sterowania procesem kompilacji oprogramowania przy
48 użyciu prostych plików konfiguracyjnych niezależnych od platformy i
49 kompilatora. CMake generuje natywne pliki makefile i workspace,
50 których można używać w wybranym środowisku kompilatora. CMake jest
51 dość wyrafinowany: może obsłużyć złożone środowiska wymagające
52 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
53 dziedziczenie szablonów.
54
55 %package gui
56 Summary:        Qt GUI for CMake
57 Summary(pl.UTF-8):      Graficzny interfejs użytkownika Qt dla CMake
58 Group:          Development/Tools
59 Requires:       %{name} = %{version}-%{release}
60
61 %description gui
62 This package contains the Qt based GUI for CMake.
63
64 %description gui -l pl.UTF-8
65 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
66 CMake.
67
68 %package emacs
69 Summary:        Emacs mode for cmake files
70 Summary(pl.UTF-8):      Tryb Emacsa dla plików cmake'a
71 Group:          Development/Tools
72
73 %description emacs
74 Emacs mode for cmake files.
75
76 %description emacs -l pl.UTF-8
77 Tryb Emacsa dla plików cmake'a.
78
79 %package -n bash-completion-%{name}
80 Summary:        bash-completion for cmake
81 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla cmake'a
82 Group:          Applications/Shells
83 Requires:       %{name} = %{version}-%{release}
84
85 %description -n bash-completion-%{name}
86 bash-completion for cmake.
87
88 %description -n bash-completion-%{name} -l pl.UTF-8
89 Bashowe dopełnianie parametrów dla cmake'a.
90
91 %prep
92 %setup -q
93 %if "%{_lib}" == "lib64"
94 %patch0 -p1
95 %endif
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p1
99
100 cat > "init.cmake" <<EOF
101 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
102 SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
103 SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
104 EOF
105
106 %build
107 export CC="%{__cc}"
108 export CXX="%{__cxx}"
109 export CFLAGS="%{rpmcflags}"
110 export CXXFLAGS="%{rpmcxxflags}"
111 export LDFLAGS="%{rpmldflags}"
112 ./bootstrap \
113         --prefix=%{_prefix} \
114         --mandir=/share/man \
115         --datadir=/share/cmake \
116         --init=init.cmake \
117         %{!?with_bootstrap:--system-libs} \
118         %{?with_gui:--qt-gui} \
119         --qt-qmake=/usr/bin/qmake-qt4 \
120         --verbose
121
122 %{__make} VERBOSE=1
123
124 %{?with_tests:%{__make} test}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
139 %attr(755,root,root) %{_bindir}/ccmake
140 %attr(755,root,root) %{_bindir}/cmake
141 %attr(755,root,root) %{_bindir}/cpack
142 %attr(755,root,root) %{_bindir}/ctest
143 %{_mandir}/man1/ccmake.1*
144 %{_mandir}/man1/cmake.1*
145 %{_mandir}/man1/cmakecommands.1*
146 %{_mandir}/man1/cmakecompat.1*
147 %{_mandir}/man1/cmakemodules.1*
148 %{_mandir}/man1/cmakepolicies.1*
149 %{_mandir}/man1/cmakeprops.1*
150 %{_mandir}/man1/cmakevars.1*
151 %{_mandir}/man1/cpack.1*
152 %{_mandir}/man1/ctest.1*
153 # top cmake/Modules dirs belong to filesystem
154 %{_datadir}/cmake/Modules/.NoDartCoverage
155 %{_datadir}/cmake/Modules/*
156 %{_datadir}/cmake/Templates
157 %{_datadir}/cmake/editors
158 %{_datadir}/cmake/include
159 %{_aclocaldir}/cmake.m4
160
161 %if %{with gui}
162 %files gui
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/cmake-gui
165 %{_datadir}/mime/packages/cmakecache.xml
166 %{_desktopdir}/CMake.desktop
167 %{_pixmapsdir}/CMakeSetup32.png
168 %{_mandir}/man1/cmake-gui.1*
169 %endif
170
171 %files emacs
172 %defattr(644,root,root,755)
173 %{_datadir}/emacs/site-lisp/cmake-mode.el
174
175 %files -n bash-completion-%{name}
176 %defattr(644,root,root,755)
177 /etc/bash_completion.d/cmake
178 /etc/bash_completion.d/cpack
179 /etc/bash_completion.d/ctest
This page took 0.036294 seconds and 3 git commands to generate.