]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- new, almost raw (taken from Mandrake)
[packages/cmake.git] / cmake.spec
1 %define name cmake
2 %define version 1.4.7
3 %define release 1
4
5 Summary: Cross-platform, open-source make system
6 Name: %name
7 Version: %version
8 Release: %release
9 License: BSD
10 Group: Development/Other
11 Url: http://www.cmake.org/HTML/Index.html
12 Source: CMake%{version}-src-unix.tar.bz2
13 Patch0: cmake-ncurses.patch
14 BuildRoot: %_tmppath/%name-%version
15
16 %description
17 CMake is used to control the software compilation process using
18 simple platform and compiler independent configuration files.
19 CMake generates native makefiles and workspaces that can be
20 used in the compiler environment of your choice. CMake is quite
21 sophisticated: it is possible to support complex environments
22 requiring system configuration, pre-processor generation, code
23 generation, and template instantiation.
24
25 %prep
26 %setup -q -n CMake-%version
27 %patch0 -p1
28
29 %build
30 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
31 %configure2_13
32 %{__make} \
33         CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
34
35 %install
36 %{__make} install DESTDIR=$RPM_BUILD_ROOT
37 mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT/%_datadir/
38 bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(-,root,root)
45 %doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
46 %_bindir/ccmake
47 %_bindir/cmake
48 %_bindir/cmaketest
49 %_bindir/ctest
50 %_mandir/man1/*.1.*
51 %_datadir/CMake/Modules
52 %_datadir/CMake/Templates
53
54 %changelog
55 * Thu Jan 9 2003 Austin Acton <aacton@yorku.ca> 1.4.7-1mdk
56 - initial package
This page took 0.040531 seconds and 3 git commands to generate.