]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- adapterized
[packages/cmake.git] / cmake.spec
1 %define name cmake
2 %define version 1.4.7
3 %define release 1
4
5 Summary:        Cross-platform, open-source make system
6 Name:           %name
7 Version:        %version
8 Release:        %release
9 License:        BSD
10 Group:          Development/Other
11 ######          Unknown group!
12 Url:            http://www.cmake.org/HTML/Index.html
13 Source0:        CMake%{version}-src-unix.tar.bz2
14 Patch0:         cmake-ncurses.patch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 CMake is used to control the software compilation process using simple
19 platform and compiler independent configuration files. CMake generates
20 native makefiles and workspaces that can be used in the compiler
21 environment of your choice. CMake is quite sophisticated: it is
22 possible to support complex environments requiring system
23 configuration, pre-processor generation, code generation, and template
24 instantiation.
25
26 %prep
27 %setup -q -n CMake-%version
28 %patch0 -p1
29
30 %build
31 CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
32 %configure2_13
33 %{__make} \
34         CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__make} install DESTDIR=$RPM_BUILD_ROOT
39 mv $RPM_BUILD_ROOT%{_prefix}/man $RPM_BUILD_ROOT/%_datadir/
40 bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
48 %_bindir/ccmake
49 %_bindir/cmake
50 %_bindir/cmaketest
51 %_bindir/ctest
52 %_mandir/man1/*.1.*
53 %_datadir/CMake/Modules
54 %_datadir/CMake/Templates
This page took 0.066076 seconds and 3 git commands to generate.