]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- updated to 2.8.12
[packages/cmake.git] / cmake.spec
1 # TODO:
2 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3 #   (and default non-verbose makefiles are hiding it!)
4 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5 #   (is there any standard way???)
6 #
7 # Conditional build:
8 %bcond_with     bootstrap       # use internal versions of some libraries
9 %bcond_without  gui             # don't build gui package
10 %bcond_without  tests           # do not perform "make test"
11
12 Summary:        Cross-platform, open-source make system
13 Summary(pl.UTF-8):      Wieloplatformowy system make o otwartych źródłach
14 Name:           cmake
15 Version:        2.8.12
16 Release:        1
17 License:        BSD
18 Group:          Development/Building
19 Source0:        http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
20 # Source0-md5:  105bc6d21cc2e9b6aff901e43c53afea
21 Patch0:         %{name}-lib64.patch
22 Patch1:         %{name}-helpers.patch
23 Patch2:         cmake-findruby.patch
24 URL:            http://www.cmake.org/
25 %{?with_gui:BuildRequires:      QtGui-devel}
26 BuildRequires:  libarchive-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  ncurses-devel > 5.9-3
29 %{?with_gui:BuildRequires:      qt4-build}
30 %{?with_gui:BuildRequires:      qt4-qmake}
31 BuildRequires:  rpmbuild(macros) >= 1.167
32 %{!?with_bootstrap:BuildRequires:       xmlrpc-c-devel >= 1.4.12-2}
33 Requires:       filesystem >= 3.0-52
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 CMake is used to control the software compilation process using simple
38 platform and compiler independent configuration files. CMake generates
39 native makefiles and workspaces that can be used in the compiler
40 environment of your choice. CMake is quite sophisticated: it is
41 possible to support complex environments requiring system
42 configuration, pre-processor generation, code generation, and template
43 instantiation.
44
45 %description -l pl.UTF-8
46 CMake służy do sterowania procesem kompilacji oprogramowania przy
47 użyciu prostych plików konfiguracyjnych niezależnych od platformy i
48 kompilatora. CMake generuje natywne pliki makefile i workspace,
49 których można używać w wybranym środowisku kompilatora. CMake jest
50 dość wyrafinowany: może obsłużyć złożone środowiska wymagające
51 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
52 dziedziczenie szablonów.
53
54 %package gui
55 Summary:        Qt GUI for CMake
56 Summary(pl.UTF-8):      Graficzny interfejs użytkownika Qt dla CMake
57 Group:          Development/Tools
58 Requires:       %{name} = %{version}-%{release}
59
60 %description gui
61 This package contains the Qt based GUI for CMake.
62
63 %description gui -l pl.UTF-8
64 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
65 CMake.
66
67 %package emacs
68 Summary:        Emacs mode for cmake files
69 Summary(pl.UTF-8):      Tryb Emacsa dla plików cmake'a
70 Group:          Development/Tools
71
72 %description emacs
73 Emacs mode for cmake files.
74
75 %description emacs -l pl.UTF-8
76 Tryb Emacsa dla plików cmake'a.
77
78 %package -n bash-completion-%{name}
79 Summary:        bash-completion for cmake
80 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla cmake'a
81 Group:          Applications/Shells
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       bash-completion >= 2.0
84
85 %description -n bash-completion-%{name}
86 bash-completion for cmake.
87
88 %description -n bash-completion-%{name} -l pl.UTF-8
89 Bashowe dopełnianie parametrów dla cmake'a.
90
91 %prep
92 %setup -q
93 %if "%{_lib}" == "lib64"
94 %patch0 -p1
95 %endif
96 %patch1 -p1
97 %patch2 -p1
98
99 cat > "init.cmake" <<EOF
100 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
101 SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
102 SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
103 EOF
104
105 %build
106 export CC="%{__cc}"
107 export CXX="%{__cxx}"
108 export CFLAGS="%{rpmcflags}"
109 export CXXFLAGS="%{rpmcxxflags}"
110 export LDFLAGS="%{rpmldflags}"
111 ./bootstrap \
112         --prefix=%{_prefix} \
113         --mandir=/share/man \
114         --datadir=/share/cmake \
115         --init=init.cmake \
116         %{!?with_bootstrap:--system-libs} \
117         %{?with_gui:--qt-gui} \
118         --qt-qmake=/usr/bin/qmake-qt4 \
119         --verbose
120
121 %{__make} VERBOSE=1
122
123 %{?with_tests:%{__make} test}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
138 %attr(755,root,root) %{_bindir}/ccmake
139 %attr(755,root,root) %{_bindir}/cmake
140 %attr(755,root,root) %{_bindir}/cpack
141 %attr(755,root,root) %{_bindir}/ctest
142 %{_mandir}/man1/ccmake.1*
143 %{_mandir}/man1/cmake.1*
144 %{_mandir}/man1/cmakecommands.1*
145 %{_mandir}/man1/cmakecompat.1*
146 %{_mandir}/man1/cmakemodules.1*
147 %{_mandir}/man1/cmakepolicies.1*
148 %{_mandir}/man1/cmakeprops.1*
149 %{_mandir}/man1/cmakevars.1*
150 %{_mandir}/man1/cpack.1*
151 %{_mandir}/man1/ctest.1*
152 # top cmake/Modules dirs belong to filesystem
153 %{_datadir}/cmake/Modules/.NoDartCoverage
154 %{_datadir}/cmake/Modules/*
155 %{_datadir}/cmake/Templates
156 %{_datadir}/cmake/editors
157 %{_datadir}/cmake/include
158 %{_aclocaldir}/cmake.m4
159
160 %if %{with gui}
161 %files gui
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/cmake-gui
164 %{_datadir}/mime/packages/cmakecache.xml
165 %{_desktopdir}/CMake.desktop
166 %{_pixmapsdir}/CMakeSetup32.png
167 %{_mandir}/man1/cmake-gui.1*
168 %endif
169
170 %files emacs
171 %defattr(644,root,root,755)
172 %{_datadir}/emacs/site-lisp/cmake-mode.el
173
174 %files -n bash-completion-%{name}
175 %defattr(644,root,root,755)
176 %{_datadir}/bash-completion/completions/cmake
177 %{_datadir}/bash-completion/completions/cpack
178 %{_datadir}/bash-completion/completions/ctest
This page took 0.045525 seconds and 3 git commands to generate.