]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- up to 2.6.3
[packages/cmake.git] / cmake.spec
1 # TODO:
2 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3 #   (and default non-verbose makefiles are hiding it!)
4 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5 #   (is there any standard way???)
6 #
7 # Conditional build:
8 %bcond_with     bootstrap       # use internal versions of some libraries
9 %bcond_without  gui             # don't build gui package
10 #
11 Summary:        Cross-platform, open-source make system
12 Summary(pl.UTF-8):      Wieloplatformowy system make o otwartych źródłach
13 Name:           cmake
14 Version:        2.6.3
15 Release:        1
16 License:        BSD
17 Group:          Development/Building
18 Source0:        http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
19 # Source0-md5:  5ba47a94ce276f326abca1fd72a7e7c6
20 Patch0:         %{name}-lib64.patch
21 URL:            http://www.cmake.org/
22 %{?with_gui:BuildRequires:      QtGui-devel}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  ncurses-devel
25 %{?with_gui:BuildRequires:      qt4-build}
26 %{?with_gui:BuildRequires:      qt4-qmake}
27 BuildRequires:  rpmbuild(macros) >= 1.167
28 %{!?with_bootstrap:BuildRequires:       xmlrpc-c-devel >= 1.4.12-2}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 CMake is used to control the software compilation process using simple
33 platform and compiler independent configuration files. CMake generates
34 native makefiles and workspaces that can be used in the compiler
35 environment of your choice. CMake is quite sophisticated: it is
36 possible to support complex environments requiring system
37 configuration, pre-processor generation, code generation, and template
38 instantiation.
39
40 %description -l pl.UTF-8
41 CMake służy do sterowania procesem kompilacji oprogramowania przy
42 użyciu prostych plików konfiguracyjnych niezależnych od platformy
43 i kompilatora. CMake generuje natywne pliki makefile i workspace,
44 których można używać w wybranym środowisku kompilatora. CMake jest
45 dość przemyślany: może obsłużyć złożone środowiska wymagające
46 konfiguracji systemu, generowanie preprocesora, generowanie kodu
47 i dziedziczenie szablonów.
48
49 %package gui
50 Summary:        Qt GUI for CMake
51 Summary(pl.UTF-8):      Graficzny interfejs użytkownika Qt dla CMake
52 Group:          Development/Tools
53 Requires:       %{name} = %{version}-%{release}
54
55 %description gui
56 This package contains the Qt based GUI for CMake.
57
58 %description gui -l pl.UTF-8
59 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
60 CMake.
61
62 %prep
63 %setup -q
64 %if "%{_lib}" == "lib64"
65 %patch0 -p1
66 %endif
67
68 cat > "init.cmake" <<EOF
69 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
70 EOF
71
72 %build
73 export CC="%{__cc}"
74 export CXX="%{__cxx}"
75 export CFLAGS="%{rpmcflags}"
76 export CXXFLAGS="%{rpmcxxflags}"
77 export LDFLAGS="%{rpmldflags}"
78 ./bootstrap \
79         --prefix=%{_prefix} \
80         --mandir=/share/man \
81         --datadir=/share/cmake \
82         --init=init.cmake \
83         %{!?with_bootstrap:--system-libs} \
84         %{?with_gui:--qt-gui} \
85         --verbose
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
103 %attr(755,root,root) %{_bindir}/ccmake
104 %attr(755,root,root) %{_bindir}/cmake
105 %attr(755,root,root) %{_bindir}/cpack
106 %attr(755,root,root) %{_bindir}/ctest
107 %{_mandir}/man1/*.1*
108 %{_datadir}/cmake
109
110 %files gui
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/cmake-gui
113 %{_datadir}/mime/packages/cmakecache.xml
114 %{_desktopdir}/CMake.desktop
115 %{_pixmapsdir}/CMakeSetup.png
This page took 0.057995 seconds and 3 git commands to generate.