- rel 2; fixes version checking bug
[packages/cmake.git] / cmake-min-ver.patch
1 From b9ec9392da21a3421e48c6961976060d872faffb Mon Sep 17 00:00:00 2001
2 From: Rolf Eike Beer <eike@sf-mail.de>
3 Date: Tue, 18 Aug 2015 12:14:43 +0200
4 Subject: [PATCH 1/1] FindPkgConfig: remove variable dereference
5
6 If CMAKE_MINIMUM_REQUIRED_VERSION is not set because no
7 cmake_minimum_required() call is present this line can lead to an error as that
8 string is empty so too few arguments are passed to if():
9
10 See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeOutput.log".
11 See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeError.log".
12 CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:112 (elseif):
13   given arguments:
14
15     "VERSION_LESS" "3.1"
16
17   Unknown arguments specified
18 Call Stack (most recent call first):
19   /usr/share/cmake/Modules/FindPkgConfig.cmake:501 (_pkgconfig_parse_options)
20   /usr/share/cmake/Modules/FindOpenSSL.cmake:43 (pkg_check_modules)
21 ---
22  Modules/FindPkgConfig.cmake |    2 +-
23  1 file changed, 1 insertion(+), 1 deletion(-)
24
25 diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
26 index 526a62e..ae6903e 100644
27 --- a/Modules/FindPkgConfig.cmake
28 +++ b/Modules/FindPkgConfig.cmake
29 @@ -109,7 +109,7 @@ macro(_pkgconfig_parse_options _result _is_req _is_silent _no_cmake_path _no_cma
30        set(${_no_cmake_path} 1)
31        set(${_no_cmake_environment_path} 1)
32      endif()
33 -  elseif(${CMAKE_MINIMUM_REQUIRED_VERSION} VERSION_LESS 3.1)
34 +  elseif(CMAKE_MINIMUM_REQUIRED_VERSION VERSION_LESS 3.1)
35      set(${_no_cmake_path} 1)
36      set(${_no_cmake_environment_path} 1)
37    endif()
38 -- 
39 1.7.10.4
40
This page took 0.046624 seconds and 3 git commands to generate.