]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- updated to 2.8.1
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
6#
7# Conditional build:
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
10#
11Summary: Cross-platform, open-source make system
12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
13Name: cmake
14Version: 2.8.1
15Release: 1
16License: BSD
17Group: Development/Building
18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
19# Source0-md5: a92ad653f9ccc1595d16cd9707f49acc
20Patch0: %{name}-lib64.patch
21URL: http://www.cmake.org/
22%{?with_gui:BuildRequires: QtGui-devel}
23BuildRequires: libstdc++-devel
24BuildRequires: ncurses-devel
25%{?with_gui:BuildRequires: qt4-build}
26%{?with_gui:BuildRequires: qt4-qmake}
27BuildRequires: rpmbuild(macros) >= 1.167
28%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32CMake is used to control the software compilation process using simple
33platform and compiler independent configuration files. CMake generates
34native makefiles and workspaces that can be used in the compiler
35environment of your choice. CMake is quite sophisticated: it is
36possible to support complex environments requiring system
37configuration, pre-processor generation, code generation, and template
38instantiation.
39
40%description -l pl.UTF-8
41CMake służy do sterowania procesem kompilacji oprogramowania przy
42użyciu prostych plików konfiguracyjnych niezależnych od platformy i
43kompilatora. CMake generuje natywne pliki makefile i workspace,
44których można używać w wybranym środowisku kompilatora. CMake jest
45dość przemyślany: może obsłużyć złożone środowiska wymagające
46konfiguracji systemu, generowanie preprocesora, generowanie kodu i
47dziedziczenie szablonów.
48
49%package gui
50Summary: Qt GUI for CMake
51Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
52Group: Development/Tools
53Requires: %{name} = %{version}-%{release}
54
55%description gui
56This package contains the Qt based GUI for CMake.
57
58%description gui -l pl.UTF-8
59Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
60CMake.
61
62%prep
63%setup -q
64%if "%{_lib}" == "lib64"
65%patch0 -p1
66%endif
67
68cat > "init.cmake" <<EOF
69SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
70EOF
71
72%build
73export CC="%{__cc}"
74export CXX="%{__cxx}"
75export CFLAGS="%{rpmcflags}"
76export CXXFLAGS="%{rpmcxxflags}"
77export LDFLAGS="%{rpmldflags}"
78./bootstrap \
79 --prefix=%{_prefix} \
80 --mandir=/share/man \
81 --datadir=/share/cmake \
82 --init=init.cmake \
83 %{!?with_bootstrap:--system-libs} \
84 %{?with_gui:--qt-gui} \
85 --verbose
86
87%{__make} VERBOSE=1
88
89%install
90rm -rf $RPM_BUILD_ROOT
91install -d $RPM_BUILD_ROOT%{_libdir}/cmake
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
96rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(644,root,root,755)
103%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
104%attr(755,root,root) %{_bindir}/ccmake
105%attr(755,root,root) %{_bindir}/cmake
106%attr(755,root,root) %{_bindir}/cpack
107%attr(755,root,root) %{_bindir}/ctest
108%{_mandir}/man1/*.1*
109%{_datadir}/cmake
110%dir %{_libdir}/cmake
111
112%if %{with gui}
113%files gui
114%defattr(644,root,root,755)
115%attr(755,root,root) %{_bindir}/cmake-gui
116%{_datadir}/mime/packages/cmakecache.xml
117%{_desktopdir}/CMake.desktop
118%{_pixmapsdir}/CMakeSetup32.png
119%endif
This page took 0.040952 seconds and 4 git commands to generate.