]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- removed redundant libarchive R (soname dep is autodetected)
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
6#
7# Conditional build:
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
10
11Summary: Cross-platform, open-source make system
12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
13Name: cmake
14Version: 2.8.3
15Release: 1
16License: BSD
17Group: Development/Building
18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
19# Source0-md5: a76a44b93acf5e3badda9de111385921
20Patch0: %{name}-lib64.patch
21Patch1: %{name}-tinfo.patch
22URL: http://www.cmake.org/
23%{?with_gui:BuildRequires: QtGui-devel}
24BuildRequires: libarchive-devel
25BuildRequires: libstdc++-devel
26BuildRequires: ncurses-devel
27%{?with_gui:BuildRequires: qt4-build}
28%{?with_gui:BuildRequires: qt4-qmake}
29BuildRequires: rpmbuild(macros) >= 1.167
30%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34CMake is used to control the software compilation process using simple
35platform and compiler independent configuration files. CMake generates
36native makefiles and workspaces that can be used in the compiler
37environment of your choice. CMake is quite sophisticated: it is
38possible to support complex environments requiring system
39configuration, pre-processor generation, code generation, and template
40instantiation.
41
42%description -l pl.UTF-8
43CMake służy do sterowania procesem kompilacji oprogramowania przy
44użyciu prostych plików konfiguracyjnych niezależnych od platformy i
45kompilatora. CMake generuje natywne pliki makefile i workspace,
46których można używać w wybranym środowisku kompilatora. CMake jest
47dość wyrafinowany: może obsłużyć złożone środowiska wymagające
48konfiguracji systemu, generowanie preprocesora, generowanie kodu i
49dziedziczenie szablonów.
50
51%package gui
52Summary: Qt GUI for CMake
53Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
54Group: Development/Tools
55Requires: %{name} = %{version}-%{release}
56
57%description gui
58This package contains the Qt based GUI for CMake.
59
60%description gui -l pl.UTF-8
61Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
62CMake.
63
64%prep
65%setup -q
66%if "%{_lib}" == "lib64"
67%patch0 -p1
68%endif
69%patch1 -p0
70
71cat > "init.cmake" <<EOF
72SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
73EOF
74
75%build
76export CC="%{__cc}"
77export CXX="%{__cxx}"
78export CFLAGS="%{rpmcflags}"
79export CXXFLAGS="%{rpmcxxflags}"
80export LDFLAGS="%{rpmldflags}"
81./bootstrap \
82 --prefix=%{_prefix} \
83 --mandir=/share/man \
84 --datadir=/share/cmake \
85 --init=init.cmake \
86 %{!?with_bootstrap:--system-libs} \
87 %{?with_gui:--qt-gui} \
88 --qt-qmake=/usr/bin/qmake-qt4 \
89 --verbose
90
91%{__make} VERBOSE=1
92
93%install
94rm -rf $RPM_BUILD_ROOT
95install -d $RPM_BUILD_ROOT%{_libdir}/cmake
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99rm -r $RPM_BUILD_ROOT%{_prefix}/doc
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(644,root,root,755)
106%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
107%attr(755,root,root) %{_bindir}/ccmake
108%attr(755,root,root) %{_bindir}/cmake
109%attr(755,root,root) %{_bindir}/cpack
110%attr(755,root,root) %{_bindir}/ctest
111%{_mandir}/man1/ccmake.1*
112%{_mandir}/man1/cmake.1*
113%{_mandir}/man1/cmakecommands.1*
114%{_mandir}/man1/cmakecompat.1*
115%{_mandir}/man1/cmakemodules.1*
116%{_mandir}/man1/cmakepolicies.1*
117%{_mandir}/man1/cmakeprops.1*
118%{_mandir}/man1/cmakevars.1*
119%{_mandir}/man1/cpack.1*
120%{_mandir}/man1/ctest.1*
121%{_datadir}/cmake
122%dir %{_libdir}/cmake
123
124%if %{with gui}
125%files gui
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_bindir}/cmake-gui
128%{_datadir}/mime/packages/cmakecache.xml
129%{_desktopdir}/CMake.desktop
130%{_pixmapsdir}/CMakeSetup32.png
131%{_mandir}/man1/cmake-gui.1*
132%endif
This page took 0.064829 seconds and 4 git commands to generate.