]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- sick...
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1# TODO: any valid CMAKE_BUILD_TYPE causes overriding of our optflags
2# (and default non-verbose makefiles are hiding it!)
3#
4# Conditional build:
5%bcond_with bootstrap # use internal versions of some libraries
6#
7Summary: Cross-platform, open-source make system
8Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
9Name: cmake
10Version: 2.6.0
11Release: 0.1
12License: BSD
13Group: Development/Building
14Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
15# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
16Patch1: %{name}-lib64.patch
17URL: http://www.cmake.org/HTML/Index.html
18BuildRequires: libstdc++-devel
19BuildRequires: ncurses-devel
20BuildRequires: rpmbuild(macros) >= 1.167
21%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25CMake is used to control the software compilation process using simple
26platform and compiler independent configuration files. CMake generates
27native makefiles and workspaces that can be used in the compiler
28environment of your choice. CMake is quite sophisticated: it is
29possible to support complex environments requiring system
30configuration, pre-processor generation, code generation, and template
31instantiation.
32
33%description -l pl.UTF-8
34CMake służy do sterowania procesem kompilacji oprogramowania przy
35użyciu prostych plików konfiguracyjnych niezależnych od platformy i
36kompilatora. CMake generuje natywne pliki makefile i workspace,
37których można używać w wybranym środowisku kompilatora. CMake jest
38dość przemyślany: może obsłużyć złożone środowiska wymagające
39konfiguracji systemu, generowanie preprocesora, generowanie kodu i
40dziedziczenie szablonów.
41
42%prep
43%setup -q
44%if "%{_lib}" == "lib64"
45%patch1 -p1
46%endif
47
48cat > "init.cmake" <<EOF
49SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
50SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
51EOF
52
53%build
54export CC="%{__cc}"
55export CXX="%{__cxx}"
56export CFLAGS="%{rpmcflags}"
57export CXXFLAGS="%{rpmcxxflags}"
58export LDFLAGS="%{rpmldflags}"
59./bootstrap \
60 --prefix=%{_prefix} \
61 --mandir=/share/man \
62 --datadir=/share/cmake \
63 --init=init.cmake \
64 %{!?with_bootstrap:--system-libs} \
65 --verbose
66
67%{__make}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
83%attr(755,root,root) %{_bindir}/ccmake
84%attr(755,root,root) %{_bindir}/cmake
85%attr(755,root,root) %{_bindir}/cpack
86%attr(755,root,root) %{_bindir}/ctest
87%{_mandir}/man1/*.1*
88%{_datadir}/cmake
This page took 0.024491 seconds and 4 git commands to generate.