]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- outdated
[packages/cmake.git] / cmake.spec
CommitLineData
ccca321d
KK
1#
2# Conditional build:
3%bcond_with bootstrap # use internal versions of some libraries
4#
efafbc62 5Summary: Cross-platform, open-source make system
ac3ea35a 6Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 7Name: cmake
ccca321d
KK
8Version: 2.6.0
9Release: 0.1
efafbc62 10License: BSD
72a696fa 11Group: Development/Building
ccca321d
KK
12Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
13# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
286b1479 14Patch1: %{name}-lib64.patch
7503d318 15URL: http://www.cmake.org/HTML/Index.html
ece9e155
KK
16BuildRequires: libstdc++-devel
17BuildRequires: ncurses-devel
18BuildRequires: rpmbuild(macros) >= 1.167
c342f103 19%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel}
efafbc62 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
21
22%description
efafbc62
AG
23CMake is used to control the software compilation process using simple
24platform and compiler independent configuration files. CMake generates
25native makefiles and workspaces that can be used in the compiler
26environment of your choice. CMake is quite sophisticated: it is
27possible to support complex environments requiring system
28configuration, pre-processor generation, code generation, and template
29instantiation.
3fcbc09a 30
520c9eb8
JR
31%description -l pl.UTF-8
32CMake służy do sterowania procesem kompilacji oprogramowania przy
33użyciu prostych plików konfiguracyjnych niezależnych od platformy i
72a696fa 34kompilatora. CMake generuje natywne pliki makefile i workspace,
520c9eb8
JR
35których można używać w wybranym środowisku kompilatora. CMake jest
36dość przemyślany: może obsłużyć złożone środowiska wymagające
72a696fa 37konfiguracji systemu, generowanie preprocesora, generowanie kodu i
520c9eb8 38dziedziczenie szablonów.
72a696fa 39
3fcbc09a 40%prep
923851a2 41%setup -q
286b1479
ER
42%if "%{_lib}" == "lib64"
43%patch1 -p1
44%endif
3fcbc09a 45
ece9e155 46cat > "init.cmake" <<EOF
286b1479 47SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ccca321d 48SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
ece9e155
KK
49EOF
50
3fcbc09a 51%build
ece9e155
KK
52export CC="%{__cc}"
53export CXX="%{__cxx}"
54export CFLAGS="%{rpmcflags}"
55export CXXFLAGS="%{rpmcxxflags}"
ccca321d 56export LDFLAGS="%{rpmldflags}"
923851a2
AG
57./bootstrap \
58 --prefix=%{_prefix} \
59 --mandir=/share/man \
60 --datadir=/share/cmake \
ece9e155 61 --init=init.cmake \
c342f103 62 %{!?with_bootstrap:--system-libs} \
923851a2
AG
63 --verbose
64
923851a2 65%{__make}
3fcbc09a
AG
66
67%install
efafbc62 68rm -rf $RPM_BUILD_ROOT
72a696fa
JB
69
70%{__make} install \
71 DESTDIR=$RPM_BUILD_ROOT
72
c4bbee29 73rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
efafbc62 79%defattr(644,root,root,755)
51ed65c6 80%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
81%attr(755,root,root) %{_bindir}/ccmake
82%attr(755,root,root) %{_bindir}/cmake
08b6790a 83%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
84%attr(755,root,root) %{_bindir}/ctest
85%{_mandir}/man1/*.1*
923851a2 86%{_datadir}/cmake
This page took 0.042152 seconds and 4 git commands to generate.