]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- up to 3.5.0
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c 1# TODO:
0f3fad68 2# - extend libx32 patch to work also on 64-bit arch
d1b2e54c
JB
3# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
4# (and default non-verbose makefiles are hiding it!)
5# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
6# (is there any standard way???)
ccca321d
KK
7#
8# Conditional build:
b563f9dc
JB
9%bcond_with bootstrap # use internal versions of some libraries
10%bcond_without gui # don't build gui package
63b5fdd8 11%bcond_with tests # perform "make test"
90b41c6c 12%bcond_without doc # don't build documentation
77f8acdd 13
efafbc62 14Summary: Cross-platform, open-source make system
ac3ea35a 15Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 16Name: cmake
3771629b 17Version: 3.5.0
834c9659 18Release: 1
efafbc62 19License: BSD
72a696fa 20Group: Development/Building
3771629b
AM
21Source0: http://www.cmake.org/files/v3.5/%{name}-%{version}.tar.gz
22# Source0-md5: 33c5d09d4c33d4ffcc63578a6ba8777e
6342daf8 23Patch0: %{name}-lib64.patch
834c9659
JR
24Patch1: %{name}-libx32.patch
25Patch2: %{name}-helpers.patch
26Patch3: %{name}-findruby.patch
27Patch4: %{name}-findruby2.patch
44c49ab5 28Patch5: man-syntax.patch
a315a797 29URL: http://www.cmake.org/
33042d59 30%{?with_gui:BuildRequires: QtGui-devel}
466fdfa1 31BuildRequires: jsoncpp-devel >= 1.6.2-2
fef12180 32BuildRequires: libarchive-devel
ece9e155 33BuildRequires: libstdc++-devel
59917d1a 34BuildRequires: ncurses-devel > 5.9-3
0278e558
BS
35%{?with_gui:BuildRequires: qt5-build}
36%{?with_gui:BuildRequires: qt5-qmake}
ece9e155 37BuildRequires: rpmbuild(macros) >= 1.167
90b41c6c 38%{?with_doc:BuildRequires: sphinx-pdg}
ab02ad6a 39%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 40Requires: filesystem >= 3.0-52
efafbc62 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
42
43%description
efafbc62
AG
44CMake is used to control the software compilation process using simple
45platform and compiler independent configuration files. CMake generates
46native makefiles and workspaces that can be used in the compiler
47environment of your choice. CMake is quite sophisticated: it is
48possible to support complex environments requiring system
49configuration, pre-processor generation, code generation, and template
50instantiation.
3fcbc09a 51
520c9eb8
JR
52%description -l pl.UTF-8
53CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 54użyciu prostych plików konfiguracyjnych niezależnych od platformy i
55kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 56których można używać w wybranym środowisku kompilatora. CMake jest
59787775 57dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 58konfiguracji systemu, generowanie preprocesora, generowanie kodu i
59dziedziczenie szablonów.
33042d59 60
fe46a853
JB
61%package doc-html
62Summary: CMake documentation in HTML format
63Summary(pl.UTF-8): Dokumentacja do pakietu CMake w formacie HTML
64Group: Documentation
65
66%description doc-html
67CMake documentation in HTML format.
68
69%description doc-html -l pl.UTF-8
70Dokumentacja do pakietu CMake w formacie HTML.
71
33042d59 72%package gui
b563f9dc
JB
73Summary: Qt GUI for CMake
74Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
75Group: Development/Tools
76Requires: %{name} = %{version}-%{release}
77
b563f9dc
JB
78%description gui
79This package contains the Qt based GUI for CMake.
80
81%description gui -l pl.UTF-8
82Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
83CMake.
72a696fa 84
9ec4f08d 85%package emacs
69d19c08
JB
86Summary: Emacs mode for cmake files
87Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
88Group: Development/Tools
89
90%description emacs
69d19c08
JB
91Emacs mode for cmake files.
92
93%description emacs -l pl.UTF-8
94Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
95
96%package -n bash-completion-%{name}
97Summary: bash-completion for cmake
69d19c08 98Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 99Group: Applications/Shells
69d19c08 100Requires: %{name} = %{version}-%{release}
a9b1845f 101Requires: bash-completion >= 2.0
6465d90a
ER
102%if "%{_rpmversion}" >= "5"
103BuildArch: noarch
104%endif
9ec4f08d
KK
105
106%description -n bash-completion-%{name}
69d19c08
JB
107bash-completion for cmake.
108
109%description -n bash-completion-%{name} -l pl.UTF-8
110Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 111
3fcbc09a 112%prep
923851a2 113%setup -q
286b1479 114%if "%{_lib}" == "lib64"
6342daf8 115%patch0 -p1
286b1479 116%endif
834c9659 117%if "%{_lib}" == "libx32"
9ec4f08d 118%patch1 -p1
834c9659 119%endif
fe667d6f 120%patch2 -p1
04706b61 121%patch3 -p1
834c9659 122%patch4 -p1
44c49ab5 123%patch5 -p1
3fcbc09a 124
ece9e155 125cat > "init.cmake" <<EOF
286b1479 126SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
127SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
128SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
129EOF
130
b343cdb1
JR
131# cleanup backups after patching, modules are copied as-is
132find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
133
3fcbc09a 134%build
ece9e155
KK
135export CC="%{__cc}"
136export CXX="%{__cxx}"
137export CFLAGS="%{rpmcflags}"
138export CXXFLAGS="%{rpmcxxflags}"
ccca321d 139export LDFLAGS="%{rpmldflags}"
923851a2
AG
140./bootstrap \
141 --prefix=%{_prefix} \
142 --mandir=/share/man \
143 --datadir=/share/cmake \
ece9e155 144 --init=init.cmake \
c342f103 145 %{!?with_bootstrap:--system-libs} \
33042d59 146 %{?with_gui:--qt-gui} \
466fdfa1 147 --qt-qmake=%{_bindir}/qmake-qt4 \
90b41c6c
JR
148 %{?with_doc:--sphinx-html} \
149 %{?with_doc:--sphinx-man} \
923851a2
AG
150 --verbose
151
28f0bd6c 152%{__make} VERBOSE=1
3fcbc09a 153
1fbe3ed6
AM
154%{?with_tests:%{__make} test}
155
3fcbc09a 156%install
efafbc62 157rm -rf $RPM_BUILD_ROOT
72a696fa
JB
158%{__make} install \
159 DESTDIR=$RPM_BUILD_ROOT
160
75cb386f 161%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%files
efafbc62 167%defattr(644,root,root,755)
fe46a853 168%doc Copyright.txt README.rst *.gif
72a696fa
JB
169%attr(755,root,root) %{_bindir}/ccmake
170%attr(755,root,root) %{_bindir}/cmake
08b6790a 171%attr(755,root,root) %{_bindir}/cpack
72a696fa 172%attr(755,root,root) %{_bindir}/ctest
90b41c6c 173%if %{with doc}
08bb5e07
JB
174%{_mandir}/man1/ccmake.1*
175%{_mandir}/man1/cmake.1*
08bb5e07
JB
176%{_mandir}/man1/cpack.1*
177%{_mandir}/man1/ctest.1*
fe46a853
JB
178%{_mandir}/man7/cmake-buildsystem.7*
179%{_mandir}/man7/cmake-commands.7*
cda7a827 180%{_mandir}/man7/cmake-compile-features.7*
fe46a853
JB
181%{_mandir}/man7/cmake-developer.7*
182%{_mandir}/man7/cmake-generator-expressions.7*
183%{_mandir}/man7/cmake-generators.7*
184%{_mandir}/man7/cmake-language.7*
185%{_mandir}/man7/cmake-modules.7*
186%{_mandir}/man7/cmake-packages.7*
187%{_mandir}/man7/cmake-policies.7*
188%{_mandir}/man7/cmake-properties.7*
189%{_mandir}/man7/cmake-qt.7*
190%{_mandir}/man7/cmake-toolchains.7*
191%{_mandir}/man7/cmake-variables.7*
0278e558 192%{_datadir}/cmake/Help
90b41c6c 193%endif
b24a2e64
JB
194# top cmake/Modules dirs belong to filesystem
195%{_datadir}/cmake/Modules/.NoDartCoverage
196%{_datadir}/cmake/Modules/*
197%{_datadir}/cmake/Templates
f13d1e41 198%{_datadir}/cmake/editors
b24a2e64 199%{_datadir}/cmake/include
09f5d631 200%{_aclocaldir}/cmake.m4
33042d59 201
90b41c6c 202%if %{with doc}
fe46a853
JB
203%files doc-html
204%defattr(644,root,root,755)
205%doc Utilities/Sphinx/html/*
90b41c6c 206%endif
fe46a853 207
1a3a9dcd 208%if %{with gui}
33042d59
KK
209%files gui
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_bindir}/cmake-gui
212%{_datadir}/mime/packages/cmakecache.xml
213%{_desktopdir}/CMake.desktop
466fdfa1
AM
214%{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
215%{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
08bb5e07 216%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 217%endif
9ec4f08d
KK
218
219%files emacs
220%defattr(644,root,root,755)
221%{_datadir}/emacs/site-lisp/cmake-mode.el
222
223%files -n bash-completion-%{name}
224%defattr(644,root,root,755)
466fdfa1
AM
225%{bash_compdir}/cmake
226%{bash_compdir}/cpack
227%{bash_compdir}/ctest
This page took 0.055914 seconds and 4 git commands to generate.