]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
add FindRuby patch from fedora
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
552867d7 14Version: 2.8.11
fe667d6f 15Release: 2
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
552867d7 19# Source0-md5: be6008f2299613d23fe82ab53ef7472e
6342daf8 20Patch0: %{name}-lib64.patch
9ec4f08d 21Patch1: %{name}-helpers.patch
fe667d6f 22Patch2: cmake-findruby.patch
a315a797 23URL: http://www.cmake.org/
33042d59 24%{?with_gui:BuildRequires: QtGui-devel}
fef12180 25BuildRequires: libarchive-devel
ece9e155 26BuildRequires: libstdc++-devel
59917d1a 27BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
28%{?with_gui:BuildRequires: qt4-build}
29%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 30BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 31%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 32Requires: filesystem >= 3.0-52
efafbc62 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
34
35%description
efafbc62
AG
36CMake is used to control the software compilation process using simple
37platform and compiler independent configuration files. CMake generates
38native makefiles and workspaces that can be used in the compiler
39environment of your choice. CMake is quite sophisticated: it is
40possible to support complex environments requiring system
41configuration, pre-processor generation, code generation, and template
42instantiation.
3fcbc09a 43
520c9eb8
JR
44%description -l pl.UTF-8
45CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 46użyciu prostych plików konfiguracyjnych niezależnych od platformy i
47kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 48których można używać w wybranym środowisku kompilatora. CMake jest
59787775 49dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 50konfiguracji systemu, generowanie preprocesora, generowanie kodu i
51dziedziczenie szablonów.
33042d59
KK
52
53%package gui
b563f9dc
JB
54Summary: Qt GUI for CMake
55Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
56Group: Development/Tools
57Requires: %{name} = %{version}-%{release}
58
b563f9dc
JB
59%description gui
60This package contains the Qt based GUI for CMake.
61
62%description gui -l pl.UTF-8
63Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
64CMake.
72a696fa 65
9ec4f08d 66%package emacs
69d19c08
JB
67Summary: Emacs mode for cmake files
68Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
69Group: Development/Tools
70
71%description emacs
69d19c08
JB
72Emacs mode for cmake files.
73
74%description emacs -l pl.UTF-8
75Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
76
77%package -n bash-completion-%{name}
78Summary: bash-completion for cmake
69d19c08 79Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 80Group: Applications/Shells
69d19c08 81Requires: %{name} = %{version}-%{release}
9ec4f08d
KK
82
83%description -n bash-completion-%{name}
69d19c08
JB
84bash-completion for cmake.
85
86%description -n bash-completion-%{name} -l pl.UTF-8
87Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 88
3fcbc09a 89%prep
923851a2 90%setup -q
286b1479 91%if "%{_lib}" == "lib64"
6342daf8 92%patch0 -p1
286b1479 93%endif
9ec4f08d 94%patch1 -p1
fe667d6f 95%patch2 -p1
3fcbc09a 96
ece9e155 97cat > "init.cmake" <<EOF
286b1479 98SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
99SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
100SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
101EOF
102
3fcbc09a 103%build
ece9e155
KK
104export CC="%{__cc}"
105export CXX="%{__cxx}"
106export CFLAGS="%{rpmcflags}"
107export CXXFLAGS="%{rpmcxxflags}"
ccca321d 108export LDFLAGS="%{rpmldflags}"
923851a2
AG
109./bootstrap \
110 --prefix=%{_prefix} \
111 --mandir=/share/man \
112 --datadir=/share/cmake \
ece9e155 113 --init=init.cmake \
c342f103 114 %{!?with_bootstrap:--system-libs} \
33042d59 115 %{?with_gui:--qt-gui} \
08bb5e07 116 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
117 --verbose
118
28f0bd6c 119%{__make} VERBOSE=1
3fcbc09a
AG
120
121%install
efafbc62 122rm -rf $RPM_BUILD_ROOT
72a696fa
JB
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
75cb386f 126%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%files
efafbc62 132%defattr(644,root,root,755)
51ed65c6 133%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
134%attr(755,root,root) %{_bindir}/ccmake
135%attr(755,root,root) %{_bindir}/cmake
08b6790a 136%attr(755,root,root) %{_bindir}/cpack
72a696fa 137%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
138%{_mandir}/man1/ccmake.1*
139%{_mandir}/man1/cmake.1*
140%{_mandir}/man1/cmakecommands.1*
141%{_mandir}/man1/cmakecompat.1*
142%{_mandir}/man1/cmakemodules.1*
143%{_mandir}/man1/cmakepolicies.1*
144%{_mandir}/man1/cmakeprops.1*
145%{_mandir}/man1/cmakevars.1*
146%{_mandir}/man1/cpack.1*
147%{_mandir}/man1/ctest.1*
b24a2e64
JB
148# top cmake/Modules dirs belong to filesystem
149%{_datadir}/cmake/Modules/.NoDartCoverage
150%{_datadir}/cmake/Modules/*
151%{_datadir}/cmake/Templates
f13d1e41 152%{_datadir}/cmake/editors
b24a2e64 153%{_datadir}/cmake/include
09f5d631 154%{_aclocaldir}/cmake.m4
33042d59 155
1a3a9dcd 156%if %{with gui}
33042d59
KK
157%files gui
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/cmake-gui
160%{_datadir}/mime/packages/cmakecache.xml
161%{_desktopdir}/CMake.desktop
ca760f29 162%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 163%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 164%endif
9ec4f08d
KK
165
166%files emacs
167%defattr(644,root,root,755)
168%{_datadir}/emacs/site-lisp/cmake-mode.el
169
170%files -n bash-completion-%{name}
171%defattr(644,root,root,755)
69d19c08
JB
172/etc/bash_completion.d/cmake
173/etc/bash_completion.d/cpack
174/etc/bash_completion.d/ctest
This page took 0.097532 seconds and 4 git commands to generate.