]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- up to 2.8.6
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
59917d1a
KK
14Version: 2.8.6
15Release: 1
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
59917d1a 19# Source0-md5: 2147da452fd9212bb9b4542a9eee9d5b
6342daf8 20Patch0: %{name}-lib64.patch
a315a797 21URL: http://www.cmake.org/
33042d59 22%{?with_gui:BuildRequires: QtGui-devel}
fef12180 23BuildRequires: libarchive-devel
ece9e155 24BuildRequires: libstdc++-devel
59917d1a 25BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
26%{?with_gui:BuildRequires: qt4-build}
27%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 28BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 29%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
b24a2e64 30Requires: filesystem >= 3.0-46
efafbc62 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
32
33%description
efafbc62
AG
34CMake is used to control the software compilation process using simple
35platform and compiler independent configuration files. CMake generates
36native makefiles and workspaces that can be used in the compiler
37environment of your choice. CMake is quite sophisticated: it is
38possible to support complex environments requiring system
39configuration, pre-processor generation, code generation, and template
40instantiation.
3fcbc09a 41
520c9eb8
JR
42%description -l pl.UTF-8
43CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 44użyciu prostych plików konfiguracyjnych niezależnych od platformy i
45kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 46których można używać w wybranym środowisku kompilatora. CMake jest
59787775 47dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 48konfiguracji systemu, generowanie preprocesora, generowanie kodu i
49dziedziczenie szablonów.
33042d59
KK
50
51%package gui
b563f9dc
JB
52Summary: Qt GUI for CMake
53Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
54Group: Development/Tools
55Requires: %{name} = %{version}-%{release}
56
b563f9dc
JB
57%description gui
58This package contains the Qt based GUI for CMake.
59
60%description gui -l pl.UTF-8
61Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
62CMake.
72a696fa 63
3fcbc09a 64%prep
923851a2 65%setup -q
286b1479 66%if "%{_lib}" == "lib64"
6342daf8 67%patch0 -p1
286b1479 68%endif
3fcbc09a 69
ece9e155 70cat > "init.cmake" <<EOF
286b1479 71SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
72EOF
73
3fcbc09a 74%build
ece9e155
KK
75export CC="%{__cc}"
76export CXX="%{__cxx}"
77export CFLAGS="%{rpmcflags}"
78export CXXFLAGS="%{rpmcxxflags}"
ccca321d 79export LDFLAGS="%{rpmldflags}"
923851a2
AG
80./bootstrap \
81 --prefix=%{_prefix} \
82 --mandir=/share/man \
83 --datadir=/share/cmake \
ece9e155 84 --init=init.cmake \
c342f103 85 %{!?with_bootstrap:--system-libs} \
33042d59 86 %{?with_gui:--qt-gui} \
08bb5e07 87 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
88 --verbose
89
28f0bd6c 90%{__make} VERBOSE=1
3fcbc09a
AG
91
92%install
efafbc62 93rm -rf $RPM_BUILD_ROOT
9ecf094d 94install -d $RPM_BUILD_ROOT%{_libdir}/cmake
72a696fa
JB
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
77f8acdd 98rm -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
efafbc62 104%defattr(644,root,root,755)
51ed65c6 105%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
106%attr(755,root,root) %{_bindir}/ccmake
107%attr(755,root,root) %{_bindir}/cmake
08b6790a 108%attr(755,root,root) %{_bindir}/cpack
72a696fa 109%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
110%{_mandir}/man1/ccmake.1*
111%{_mandir}/man1/cmake.1*
112%{_mandir}/man1/cmakecommands.1*
113%{_mandir}/man1/cmakecompat.1*
114%{_mandir}/man1/cmakemodules.1*
115%{_mandir}/man1/cmakepolicies.1*
116%{_mandir}/man1/cmakeprops.1*
117%{_mandir}/man1/cmakevars.1*
118%{_mandir}/man1/cpack.1*
119%{_mandir}/man1/ctest.1*
b24a2e64
JB
120# top cmake/Modules dirs belong to filesystem
121%{_datadir}/cmake/Modules/.NoDartCoverage
122%{_datadir}/cmake/Modules/*
123%{_datadir}/cmake/Templates
124%{_datadir}/cmake/include
1941b22e 125%dir %{_libdir}/cmake
33042d59 126
1a3a9dcd 127%if %{with gui}
33042d59
KK
128%files gui
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_bindir}/cmake-gui
131%{_datadir}/mime/packages/cmakecache.xml
132%{_desktopdir}/CMake.desktop
ca760f29 133%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 134%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 135%endif
This page took 0.090538 seconds and 4 git commands to generate.