]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- updated to 2.8.5
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
77f8acdd 10
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
c59c071d 14Version: 2.8.5
15Release: 1
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c 18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
c59c071d 19# Source0-md5: 3c5d32cec0f4c2dc45f4c2e84f4a20c5
6342daf8 20Patch0: %{name}-lib64.patch
44af9955 21Patch1: %{name}-tinfo.patch
a315a797 22URL: http://www.cmake.org/
33042d59 23%{?with_gui:BuildRequires: QtGui-devel}
fef12180 24BuildRequires: libarchive-devel
ece9e155
KK
25BuildRequires: libstdc++-devel
26BuildRequires: ncurses-devel
33042d59
KK
27%{?with_gui:BuildRequires: qt4-build}
28%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 29BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 30%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
b24a2e64 31Requires: filesystem >= 3.0-46
efafbc62 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
33
34%description
efafbc62
AG
35CMake is used to control the software compilation process using simple
36platform and compiler independent configuration files. CMake generates
37native makefiles and workspaces that can be used in the compiler
38environment of your choice. CMake is quite sophisticated: it is
39possible to support complex environments requiring system
40configuration, pre-processor generation, code generation, and template
41instantiation.
3fcbc09a 42
520c9eb8
JR
43%description -l pl.UTF-8
44CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 45użyciu prostych plików konfiguracyjnych niezależnych od platformy i
46kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 47których można używać w wybranym środowisku kompilatora. CMake jest
59787775 48dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 49konfiguracji systemu, generowanie preprocesora, generowanie kodu i
50dziedziczenie szablonów.
33042d59
KK
51
52%package gui
b563f9dc
JB
53Summary: Qt GUI for CMake
54Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
55Group: Development/Tools
56Requires: %{name} = %{version}-%{release}
57
b563f9dc
JB
58%description gui
59This package contains the Qt based GUI for CMake.
60
61%description gui -l pl.UTF-8
62Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
63CMake.
72a696fa 64
3fcbc09a 65%prep
923851a2 66%setup -q
286b1479 67%if "%{_lib}" == "lib64"
6342daf8 68%patch0 -p1
286b1479 69%endif
44af9955 70%patch1 -p0
3fcbc09a 71
ece9e155 72cat > "init.cmake" <<EOF
286b1479 73SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
74EOF
75
3fcbc09a 76%build
ece9e155
KK
77export CC="%{__cc}"
78export CXX="%{__cxx}"
79export CFLAGS="%{rpmcflags}"
80export CXXFLAGS="%{rpmcxxflags}"
ccca321d 81export LDFLAGS="%{rpmldflags}"
923851a2
AG
82./bootstrap \
83 --prefix=%{_prefix} \
84 --mandir=/share/man \
85 --datadir=/share/cmake \
ece9e155 86 --init=init.cmake \
c342f103 87 %{!?with_bootstrap:--system-libs} \
33042d59 88 %{?with_gui:--qt-gui} \
08bb5e07 89 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
90 --verbose
91
28f0bd6c 92%{__make} VERBOSE=1
3fcbc09a
AG
93
94%install
efafbc62 95rm -rf $RPM_BUILD_ROOT
9ecf094d 96install -d $RPM_BUILD_ROOT%{_libdir}/cmake
72a696fa
JB
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
99
77f8acdd 100rm -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
efafbc62 106%defattr(644,root,root,755)
51ed65c6 107%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
108%attr(755,root,root) %{_bindir}/ccmake
109%attr(755,root,root) %{_bindir}/cmake
08b6790a 110%attr(755,root,root) %{_bindir}/cpack
72a696fa 111%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
112%{_mandir}/man1/ccmake.1*
113%{_mandir}/man1/cmake.1*
114%{_mandir}/man1/cmakecommands.1*
115%{_mandir}/man1/cmakecompat.1*
116%{_mandir}/man1/cmakemodules.1*
117%{_mandir}/man1/cmakepolicies.1*
118%{_mandir}/man1/cmakeprops.1*
119%{_mandir}/man1/cmakevars.1*
120%{_mandir}/man1/cpack.1*
121%{_mandir}/man1/ctest.1*
b24a2e64
JB
122# top cmake/Modules dirs belong to filesystem
123%{_datadir}/cmake/Modules/.NoDartCoverage
124%{_datadir}/cmake/Modules/*
125%{_datadir}/cmake/Templates
126%{_datadir}/cmake/include
1941b22e 127%dir %{_libdir}/cmake
33042d59 128
1a3a9dcd 129%if %{with gui}
33042d59
KK
130%files gui
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_bindir}/cmake-gui
133%{_datadir}/mime/packages/cmakecache.xml
134%{_desktopdir}/CMake.desktop
ca760f29 135%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 136%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 137%endif
This page took 0.044059 seconds and 4 git commands to generate.