]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- new, almost raw (taken from Mandrake)
[packages/cmake.git] / cmake.spec
CommitLineData
3fcbc09a
AG
1%define name cmake
2%define version 1.4.7
3%define release 1
4
5Summary: Cross-platform, open-source make system
6Name: %name
7Version: %version
8Release: %release
9License: BSD
10Group: Development/Other
11Url: http://www.cmake.org/HTML/Index.html
12Source: CMake%{version}-src-unix.tar.bz2
13Patch0: cmake-ncurses.patch
14BuildRoot: %_tmppath/%name-%version
15
16%description
17CMake is used to control the software compilation process using
18simple platform and compiler independent configuration files.
19CMake generates native makefiles and workspaces that can be
20used in the compiler environment of your choice. CMake is quite
21sophisticated: it is possible to support complex environments
22requiring system configuration, pre-processor generation, code
23generation, and template instantiation.
24
25%prep
26%setup -q -n CMake-%version
27%patch0 -p1
28
29%build
30CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
31%configure2_13
32%{__make} \
33 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
34
35%install
36%{__make} install DESTDIR=$RPM_BUILD_ROOT
37mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT/%_datadir/
38bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
39
40%clean
41rm -rf $RPM_BUILD_ROOT
42
43%files
44%defattr(-,root,root)
45%doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
46%_bindir/ccmake
47%_bindir/cmake
48%_bindir/cmaketest
49%_bindir/ctest
50%_mandir/man1/*.1.*
51%_datadir/CMake/Modules
52%_datadir/CMake/Templates
53
54%changelog
55* Thu Jan 9 2003 Austin Acton <aacton@yorku.ca> 1.4.7-1mdk
56- initial package
This page took 0.061488 seconds and 4 git commands to generate.