]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- die
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
ccca321d 10#
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
e2ce4760 14Version: 2.6.2
15Release: 1
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
ccca321d 18Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
e2ce4760 19# Source0-md5: 9e82aa3beb991aa8e5797cf330618d42
6342daf8 20Patch0: %{name}-lib64.patch
21Patch1: %{name}-ar.patch
a315a797 22URL: http://www.cmake.org/
33042d59 23%{?with_gui:BuildRequires: QtGui-devel}
ece9e155
KK
24BuildRequires: libstdc++-devel
25BuildRequires: ncurses-devel
33042d59
KK
26%{?with_gui:BuildRequires: qt4-build}
27%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 28BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 29%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
efafbc62 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
31
32%description
efafbc62
AG
33CMake is used to control the software compilation process using simple
34platform and compiler independent configuration files. CMake generates
35native makefiles and workspaces that can be used in the compiler
36environment of your choice. CMake is quite sophisticated: it is
37possible to support complex environments requiring system
38configuration, pre-processor generation, code generation, and template
39instantiation.
3fcbc09a 40
520c9eb8
JR
41%description -l pl.UTF-8
42CMake służy do sterowania procesem kompilacji oprogramowania przy
485d9a7a
KK
43użyciu prostych plików konfiguracyjnych niezależnych od platformy
44i kompilatora. CMake generuje natywne pliki makefile i workspace,
45których można używać w wybranym środowisku kompilatora. CMake jest
46dość przemyślany: może obsłużyć złożone środowiska wymagające
47konfiguracji systemu, generowanie preprocesora, generowanie kodu
48i dziedziczenie szablonów.
33042d59
KK
49
50%package gui
b563f9dc
JB
51Summary: Qt GUI for CMake
52Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
53Group: Development/Tools
54Requires: %{name} = %{version}-%{release}
55
b563f9dc
JB
56%description gui
57This package contains the Qt based GUI for CMake.
58
59%description gui -l pl.UTF-8
60Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
61CMake.
72a696fa 62
3fcbc09a 63%prep
923851a2 64%setup -q
286b1479 65%if "%{_lib}" == "lib64"
6342daf8 66%patch0 -p1
286b1479 67%endif
6342daf8 68%patch1 -p0
3fcbc09a 69
ece9e155 70cat > "init.cmake" <<EOF
286b1479 71SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
72EOF
73
3fcbc09a 74%build
ece9e155
KK
75export CC="%{__cc}"
76export CXX="%{__cxx}"
77export CFLAGS="%{rpmcflags}"
78export CXXFLAGS="%{rpmcxxflags}"
ccca321d 79export LDFLAGS="%{rpmldflags}"
923851a2
AG
80./bootstrap \
81 --prefix=%{_prefix} \
82 --mandir=/share/man \
83 --datadir=/share/cmake \
ece9e155 84 --init=init.cmake \
c342f103 85 %{!?with_bootstrap:--system-libs} \
33042d59 86 %{?with_gui:--qt-gui} \
923851a2
AG
87 --verbose
88
923851a2 89%{__make}
3fcbc09a
AG
90
91%install
efafbc62 92rm -rf $RPM_BUILD_ROOT
72a696fa
JB
93
94%{__make} install \
95 DESTDIR=$RPM_BUILD_ROOT
96
c4bbee29 97rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
efafbc62 103%defattr(644,root,root,755)
51ed65c6 104%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
105%attr(755,root,root) %{_bindir}/ccmake
106%attr(755,root,root) %{_bindir}/cmake
08b6790a 107%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
108%attr(755,root,root) %{_bindir}/ctest
109%{_mandir}/man1/*.1*
923851a2 110%{_datadir}/cmake
33042d59
KK
111
112%files gui
113%defattr(644,root,root,755)
114%attr(755,root,root) %{_bindir}/cmake-gui
115%{_datadir}/mime/packages/cmakecache.xml
116%{_desktopdir}/CMake.desktop
117%{_pixmapsdir}/CMakeSetup.png
This page took 0.046311 seconds and 4 git commands to generate.