]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- rel 1
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
8%bcond_with bootstrap # use internal versions of some libraries
33042d59 9%bcond_without gui
ccca321d 10#
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
ccca321d 14Version: 2.6.0
30541df8 15Release: 1
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
ccca321d
KK
18Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
19# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
286b1479 20Patch1: %{name}-lib64.patch
7503d318 21URL: http://www.cmake.org/HTML/Index.html
33042d59 22%{?with_gui:BuildRequires: QtGui-devel}
ece9e155
KK
23BuildRequires: libstdc++-devel
24BuildRequires: ncurses-devel
33042d59
KK
25%{?with_gui:BuildRequires: qt4-build}
26%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 27BuildRequires: rpmbuild(macros) >= 1.167
c342f103 28%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel}
efafbc62 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
30
31%description
efafbc62
AG
32CMake is used to control the software compilation process using simple
33platform and compiler independent configuration files. CMake generates
34native makefiles and workspaces that can be used in the compiler
35environment of your choice. CMake is quite sophisticated: it is
36possible to support complex environments requiring system
37configuration, pre-processor generation, code generation, and template
38instantiation.
3fcbc09a 39
520c9eb8
JR
40%description -l pl.UTF-8
41CMake służy do sterowania procesem kompilacji oprogramowania przy
42użyciu prostych plików konfiguracyjnych niezależnych od platformy i
72a696fa 43kompilatora. CMake generuje natywne pliki makefile i workspace,
33042d59
KK
44których można użyMesa-libGLU-devel-7.0.3-2.athlonwać w wybranym
45środowisku kompilatora. CMake jest dość przemyślany: może
46obsłużyć złożone środowiska wymagające konfiguracji systemu,
47generowanie preprocesora, generowanie kodu i dziedziczenie szablonów.
48
49%package gui
50Summary: Qt GUI for %{name}
51Group: Development/Tools
52Requires: %{name} = %{version}-%{release}
53
54%description gui
55The %{name}-gui package contains the Qt based GUI for CMake.
72a696fa 56
3fcbc09a 57%prep
923851a2 58%setup -q
286b1479
ER
59%if "%{_lib}" == "lib64"
60%patch1 -p1
61%endif
3fcbc09a 62
ece9e155 63cat > "init.cmake" <<EOF
286b1479 64SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ccca321d 65SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
ece9e155
KK
66EOF
67
3fcbc09a 68%build
ece9e155
KK
69export CC="%{__cc}"
70export CXX="%{__cxx}"
71export CFLAGS="%{rpmcflags}"
72export CXXFLAGS="%{rpmcxxflags}"
ccca321d 73export LDFLAGS="%{rpmldflags}"
923851a2
AG
74./bootstrap \
75 --prefix=%{_prefix} \
76 --mandir=/share/man \
77 --datadir=/share/cmake \
ece9e155 78 --init=init.cmake \
c342f103 79 %{!?with_bootstrap:--system-libs} \
33042d59 80 %{?with_gui:--qt-gui} \
923851a2
AG
81 --verbose
82
923851a2 83%{__make}
3fcbc09a
AG
84
85%install
efafbc62 86rm -rf $RPM_BUILD_ROOT
72a696fa
JB
87
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
90
c4bbee29 91rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
efafbc62 97%defattr(644,root,root,755)
51ed65c6 98%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
99%attr(755,root,root) %{_bindir}/ccmake
100%attr(755,root,root) %{_bindir}/cmake
08b6790a 101%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
102%attr(755,root,root) %{_bindir}/ctest
103%{_mandir}/man1/*.1*
923851a2 104%{_datadir}/cmake
33042d59
KK
105
106%files gui
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_bindir}/cmake-gui
109%{_datadir}/mime/packages/cmakecache.xml
110%{_desktopdir}/CMake.desktop
111%{_pixmapsdir}/CMakeSetup.png
This page took 0.073536 seconds and 4 git commands to generate.